macOS Monterey 12.6.5 and Big Sur 11.7.6

Originally published at: macOS Monterey 12.6.5 and Big Sur 11.7.6 - TidBITS

Security patches for Monterey and Big Sur. (Free, various sizes, macOS 12 and 11)

1 Like

FWIW, Monterey 12.6.5 hasn’t blown up anything here (yet… ;-)

1 Like

I updated my iMac from macOS Monterey 12.6.4 to macOS Monterey 12.6.5 late this afternoon.
And, now Mail suddenly quits at seemingly random intervals. I have sent 3 or 4 of those automatic reports to Apple already.
Mail was not behaving well under previous OSs, but this is terrible.

Gil M.
my system: iMac, 2017, Retina 5K, 27-inch, 3.5 GHz Quad-Core Intel Core i5, 16 GB RAM

1 Like

No 12.6.5 Mail issues here, but believe me, if you look at my postings elsewhere here, “I feel your pain.”

Sorry, I have no help. Maybe the “Mailbox / Rebuild” menu item?

“1. In the Mail app on your Mac, select a mailbox in the sidebar.
2. Choose Mailbox > Rebuild.”

I would guess rebuilding the Inbox first?

1 Like

No Mail issues whatsoever after the update. Similar setup with same iMac, a bit faster and more RAM.

Have also applied same update to my Big Sur partition. Will let you know if I have any Mail issues there after it runs for awhile.

1 Like

I was running around doing things, so I only checked in sporadically. It took a long time and tried pressing random keys, but my 2018 MacMini running Monterey 12.6.4 never woke from sleep to show progress. After a while, I tried to look at its screen from my MacbookAir running 12.6.4 and saw what looked like the start-up screen on the Mini, so I went back to see if it had woken up. It hadn’t, and after a few minutes of trying to wake up the Mini and I concluded it was frozen. It successfully restarted after I forced a restart and so far so good. But it’s disturbing to have an upgrade end with a freeze.

So advises me— I have an older iMac that cannot be updated past OSX 10.13.6

Is it safe to keep using such old hardware–is it left updated by Apple? Or is it time to cough up a thousand dollars for a newer computer again, as I’ve had to do every five or ten years?

Yeah, I’m old.

After doing the Monterey 12.6.5 update- it completely removed all my printers and settings for those printers.
I haven’t seen any other screw ups as yet-but it’s only been about 1 day since I did it.

It depends on what you need to use that computer for.

The big deal is that Apple (probably) won’t be releasing security updates for these old systems. But that really only matters for software that interacts with the Internet.

So use a compatible browser that is still being kept up to date. For example, Firefox 112 (the current version) requires macOS 10.12 or later.

If you use an office suite that is no longer being updated for your platform (like Microsoft Office), then don’t use it to open documents received from the Internet. If you’re like me, you may never receive any and therefore don’t have to care. If you do, then you’ll need to see if there is a package you can use that is still supported on macOS 10.13 (sadly, the current version of LibreOffice requires 10.14 or later). Or alternatively, maybe open them with a web-based office package, which will only depend on your browser’s capabilities, not your Mac’s.

FWIW, I still use a 2011 MacBook Air, running macOS 10.12 (“Sierra”). I run the latest Firefox for my web browsing. I use the most recent Microsoft Office version that is compatible (16.30 - from 2019). Microsoft constantly asks me to upgrade, but there’s nothing to upgrade to, because of the macOS version. But since I only use this computer to create new documents or to edit documents that I created (and never with documents I receive from others), I’m not concerned. And the only other thing I do with this computer is log in to other computers on my network (via screen sharing or SSH sessions).

I’ll probably replace this computer soon after Firefox drops support for macOS 10.12. And when I do, I’ll probably get the least expensive MacBook Air as a replacement, since every model sold will be better than what I’m using now (2nd gen Core i5, 1.6 GHz, 4GB RAM, 128GB SSD), and even with the minimal RAM and storage configuration, it will be just fine for what I do with this computer.

1 Like

Just checked and all printers are gone on 12.6.5.

No problems with mail so far.

After the update, I lost my scanner but not my printer. After some fiddling around I got it back, but I’m not sure exactly what worked.

I apologize for the long delay in returning to this.

Thank you to Al, Will and Lauri for their suggestions.
I had rebuilt Mail’s inbox, and the sudden quits persisted. I shut down for the night, and since the next day this problem has not reoccured. Others however …

After restarting a day or two ago, my scanner (Epson Perfection V330 Photo) again does not connect to my Mac via EpsonScan 2, and I cannot reconnect it. I tried reinstalling EpsonScan 2 a couple of times, but no joy. I used Time Machine to reinstall the scanner from a time when it did work, and now it doesn’t. Something is strange here, and all I can say is that the upgrade to 12.6.5 appears to be incompatible with EpsonScan 2, which had worked for at least some earlier versions of 12.6. That’s disappointing. After problems with an earlier upgrade, I bought VueScan, and EpsonScan2 is a more powerful tool. I checked the Epson site and they no longer show any scanning software for the Epson Perfection V330 Photo. Has anybody had any luck with Ventura?

I lost some printers, too, but they were easy enough to set up again.
However, I have been seeing some real oddities since the update although I cannot be certain that it was the update that caused them. Examples:

  • a few .txt files cannot be opened with TextEdit, BBedit opens them
  • a few .rar files cannot be opened by keka or MacPar
  • and the weirdest of the lot, sometimes when I drag a group of mp3 files to Apple Music only some of them are added to the library, in one recent case I dragged 13 files and 10 were added, separately dragging the “missed” files to Music added them
  • sometimes the trash bin icon says there’s something in the trash, but when I open it, there isn’t anything there and I can’t “empty” it

I’ve not found any other reports of similar (mis)behaviour, does anyone have any ideas please?
In the good old days (prior to APFS) :wink:, I’d have run DiskWarrior and looked at the files with File Buddy to see what might be causing it. I know about the problems Alsoft and TechTool have had with APFS but is there a modern equivalent of File Buddy?
Thanks for any suggestions.

Model Identifier: MacBookPro15,1
System Version: macOS 12.6.5 (21G531)

I’d definitely run Disk Utility’s First Aid function on the drive. I could imagine some disk corruption.

When you say that TextEdit couldn’t open a text file, what actually happened? That’s truly funky since it doesn’t get any simpler than text.

First, this only happens with a minority of files, but when a given file refuses to be opened, then it remains un-openable.
In the case of the .txt files, I tried double clicking, the application is woken up but nothing happens. I tried control-click and open with text edit, same result. I dragged the file onto the text edit icon, same result.
Open with, and dragging the file onto the icon, opened the file in BBedit.
Looking at get info for the recalcitrant file shows nothing out of the ordinary, compared to a similar file that opens normally.
I wondered whether there was something odd in the file name - invisible characters maybe, characters with accents - so I tried renaming it, same result.
I’ll try disk utility first aid from the recovery partition and see what happens …
Thanks for responding!

Well, that’s a relief!
Made backups / clones / etc. and ran Malwarebytes: nothing found.
Ran disk utility from recovery and two files which had previously refused to unrar, worked as expected.
Given that the problem was occasional I’ll have to wait and see if the problem really has gone away.
Thank you again for your reaction.

I’ve found a smoking gun that points to the 12.6.5 update messing around with printers and scanners. Both the printer and scanner active on the machine and Apple apps carry the same date modified: April 4, 2023 at 3:24 A.M.

I am not having problems with my printer, but EpsonScan 2 application is not able to contact the scanner. I have been able to wake up the scanner by opening it up under printers and scanners, but modified scanner is crippled and has lost some functions. I tried updating the scanner software on the Epson site, but the updated EsponScan 2 still cannot make contact. What I see now in the Printer folder is an app called EPSON Perfection and copyright by Apple (as are all the Printer files.
I don’t understand what happened, but it looks like the 12.6.5 update did something.
I also ran First Air in Disk Utility and it found no problem.

I just checked Time Machine and the Epson Perfection was NOT in the Printers/Scanners folder before the upgrade. I don’t know where it came from, and that version of the scanner has some important differences from the one I was using earlier. I’m wondering if Apple moved it from somewhere else.

Hi there! Since I updated to 12.6.5 I have severe memory problems because all programs seem to need more ram. Partially ridiculous much: Affinity publisher 6gb, Thunderbird and firefox always >1,5gb, pdf expert with 2 ordinary pdfs open >1GB and so on. Any Idea what to do?

Not severe until the graph turns Red. That’s when you would need to seriously consider increasing the amount of RAM you have. The graph shows that macOS is adequately handling the amount of RAM needed using compression, so whatever is causing the increases should not be of any concern to you at this time.

I will say that Google Chrome is notoriously famous for using an excessive amount of both RAM and CPU power, so I personally never use it. If you insist on a Chromium based browser, then Brave may be a better choice. Firefox should also be an option and Arc is a new product slowly coming on-line.

1 Like