macOS Files and Folders - Can't add apps

In System Preference > Privacy > Files and Folders, the +/- buttons are greyed out, even after I’m logged in, so I can’t add an app to give it access. I’m on the most current version of Big Sur; anyone ever see this behavior before? Trying to set up tethered shooting with an app called Fujifilm X-Acquire, and I’m hitting this very annoying roadblock.

Hmm, I see that here under Monterey. If I select something in the list, the “-” button becomes active (“ungreys”). But the plus “+” button remains grey. I’m not sure this different behavior? Usually, the complaining app has brought me here, and often inserted itself into the list, just waiting to have its checkbox clicked.

Didn’t the FujuFilm app do that when you tried to run it?

That normally means you didn’t unlock the Pref Pane first.

“That normally means you didn’t unlock the Pref Pane first.”

I can’t speak for flysi3000, but I did.

Likewise; screenshot attached. (User is Administrator, macOS 12.3.1 (21E258))

If I click on an item the minus becomes active.

Plus remains greyed out.

EDIT: Replace PDF with PNG and add OS details

With regard to your screenshot (a .jpg or .png would be visible here without having to download a .pdf first) I don’t see the item you say you clicked on and the minus isn’t active, so not sure it shows exactly what you’ve described, but do see that the plus is greyed out which should not be.

If you did highlight an item in the list, then it expects you to do something about that specific item and plus should not be an option for that item. You must click on that item again so as not to be selected and the plus should then not be greyed, but apparently isn’t.

Hi Al, thanks for advice re jpg/png for screenshots, have replaced.

Same here. The plus button never becomes active.

1 Like

Yep, I definitely did.

I’m thinking that there is not meant to be a “+” for this particular pane. If you click the help button in that preference pane ("?" bottom-right), under, for example, “Full Disk Access”, the help file says:

Allow apps to access all files on your computer, including data from other apps (for example, Mail, Messages, Safari, and Home), data from Time Machine backups, and certain administrative settings for all users on this Mac. The listed apps have requested access.

To add an app, click the Add button, select the app in the list, then click Open.

(The bolding was added by me.)

But under “Files and Folders”:

Allow apps to access files and folders in different locations on this Mac. The listed apps have requested access.

It doesn’t say anything there about adding an app.

The “To add an app…” wording is there for Accessibility, Input Monitoring, Screen Recording, and Bluetooth, and when you access those panes, the “+” becomes active.

Interesting when you know that the Big Sur and Monterey style has been to hide controls that are not applicable. I guess that Apple just hasn’t changed this page yet.

Hm, that’s an interesting point. The app did work in the past – at least, prior to me installing the Big Sur public beta. I hadn’t tried it again since until a few months ago, and again this weekend.

The app is supposed to allow the user to select a folder on a local drive where photos will be saved as they are shot on the camera. All the options for selecting a save location are greyed out in the app, and my assumption is that it’s because the app doesn’t have access in the Files and Folders preference pane.
image
The app’s settings screen has a message about allowing permission in System Preferences (though it has a typo, which doesn’t foster confidence in the quality of the app anyway):


I deleted the app, along with all its settings and .plist files (with the help of Hazel), and reinstalled it, and still didn’t get the expected prompt to allow permissions, so I guess I have to wait for Fujifilm to update it.

Perhaps you could add the app to the Full Disk Access pane and that would allow the selection of a folder for storing photos in the app.

1 Like

:point_up_2: This is what he needs to do. You can’t add an app to the “Files and Folders” list because apps are only added to that list by the system when they try to access a particular file or folder (the app gets checkboxes under it only for the folders it tries to access). You need to instead add Fujifilm X-Acquire to the “Full Disk Access” list - that’ll let it save files wherever.

And yes, this is all as clear as mud, given the user interface in Security & Privacy. Apple’s been falling down in the UX department pretty badly lately, and it’s gotten markedly worse since Big Sur.

2 Likes

Thanks for that, Jon and Terry! Fujifilm X-Acquire does indeed show up as having access under Files and Folders after having added it to Full Disk Access (and I swear I thought of that at some point in the past), but all the menu items (specify destination folder, etc) are still greyed out in the app’s menu:
image

Sigh…

(also @gotow, big fan and longtime user of DFX here; thanks for helping troubleshoot!)

@ flysi3000, nice to hear you’re a Default Folder X user :-) But back to the issue at hand - I think there’s something else afoot with Fujifilm X-Acquire. It’s got some other reason for disabling those menu items. I unfortunately can’t test it here because I don’t have a FujiFilm camera attached (I presume that’s the reason anyway), but I suspect that you need to open an image-browser window or some other “main window” before those menu items get enabled. Is that possible?

1 Like

Update: I’ve been using a TetherTools cable to test this, and it obviously hasn’t been working this whole time. I’ll confess that during a shoot some months ago, the laptop I was tethered to fell – not from a high distance, thankfully – but one end of the cable suffered the worst of the impact, and the male part of the USB-C connector has become a little crooked since then. It still charges the camera, so I thought it still worked. Well, I just tried a different USB-C cable and:
image
Voila, no more greyed out menu options. Mystery solved – but I’m still sad, because that was a $50 cable, and I barely got to use it. :pensive:

Anyway, thanks again for all the help, guys!!

4 Likes

I have experienced the same problem. Unless the app asks for access and is denied, it will not show up on this list. There is no way I know of to force it to add an app. Some apps poorly written will simply not show up here. I have one (“Chirp”) used to program handheld radios. I had to sign the app (there’s a way to code-sign with a personal certificate) to get it to run at all, and then it can only open/save files in the folder that it’s in.