macOS 12.3 seems to not support 2 external monitors on MacBook Pro 2020

This morning, after upgrading to macOS 12.3 on my MacBook Pro 2020, one of my two external monitors no longer displays. It also does not show up in the monitors section of the system preferences. Both of these motors are LG HDR 4K’s and are connected to the laptop via CalDigit USB-C Pro Dock with DVI cables

The left monitor was assigned as the primary monitor and It is the one that no longer works. If I unplug the monitor and plug it back in, the display shows a backlight but then says no signal and goes to sleep. Rebooting makes no difference.

Is there a solution for this? It looks as if this may have been a problem with a beta release.

So no offense, but…you’ve tried all the usual I assume? Run the cable going to the “good” monitor to the dark one (and vice versa) to eliminate the monitor and cable as the source of the problem? I have nearly the same setup, although my MPB is a 2021 M1 Pro. I’m about ready to do the update myself, so I’ll let you know if I have any issues.

FWIW, I just updated to 12.3, no issues.

You make a point. I should’ve tested the cables and I had not. What I have discovered is that both cables work correctly and both monitors work correctly but it appears to be the second display port on the CalDigit USB-C Pro Dock that is not recognizing a monitor after the update, though the monitor does react to being plugged into it,

I have shut down the computer and unplugged the hub with no changes.

Oh, so you’re saying if you bypass the hub altogether, and plug the cables directly into the MBP, then both monitors work?

Do you have 13" 2020 MBP M1? If so, this is sounding vaguely familiar. I believe there was a limitation on the original M1 chip that precluded driving two monitors off of one TB port. But if that’s the issue here, why did it work at all? Very odd. Wish I could give you more help!

Actually everything worked when I plugged into the first display port at the back of the CalDigit hub and nothing would work when it was plugged into the second port of the CalDigit hub. I am currently chatting with Cal digit about this.

Any luck? I am facing this same issue.

No. I called Cal digit and did all the steps that they suggested for me to do in order to be able to make it work. It appears that the hub will only drive one monitor at a time after the 12.3 update. I was willing to buy a replacement but they do not have any. Both display ports will work if it is the only one that is attached. Otherwise, if they are both attached, only display port 1 will will work but there is some evidence that there is power going to port 2. I do not know a solution.

What hub are you using?


Yes, I was able to resolve the issue by switching my DisplayPort settings from 1.4 to 1.2.

Both my LG monitors are set to 1.2 and the only option I could find was to turn it off which I did and it made no difference. Looking at the documentation, it appears that the hubs ports are version 1.2 and I do not see where are they are adjustable. Looking in macOS system functions I cannot see the DisplayPort version through the thunderbolt port on the Mac. I can see that the CalDigit is present but again, no version and it only appears to recognize one external video connection.

Intel Iris Plus Graphics:

Chipset Model: Intel Iris Plus Graphics
Type: GPU
Bus: Built-In
VRAM (Dynamic, Max): 1536 MB
Vendor: Intel
Device ID: 0x8a53
Revision ID: 0x0007
Metal Family: Supported, Metal GPUFamily macOS 2
Color LCD:
Display Type: Built-In Retina LCD
Resolution: 2560 x 1600 Retina
Framebuffer Depth: 30-Bit Color (ARGB2101010)
Main Display: Yes
Mirror: Off
Online: Yes
Automatically Adjust Brightness: Yes
Connection Type: Internal
Resolution: 6016 x 3384
UI Looks like: 3008 x 1692 @ 30.00Hz
Framebuffer Depth: 30-Bit Color (ARGB2101010)
Mirror: Off
Online: Yes
Rotation: Supported
Connection Type: Thunderbolt/DisplayPort

Thunderbolt Bus 1:

Vendor Name: Apple Inc.
Device Name: MacBook Pro
Route String: 0
Firmware Version: 86.0
Domain UUID: 02272BA5-80A2-515A-9374-6A52A8A5C5BF
Status: Device connected
Link Status: 0x2
Speed: Up to 40 Gb/s x1
Current Link Width: 0x2
Receptacle: 0
Link Controller Firmware Version: 1.38.0
Status: No device connected
Link Status: 0x7
Speed: Up to 40 Gb/s x1
Current Link Width: 0x1
Receptacle: 0
Link Controller Firmware Version: 1.38.0

USB-C Pro Dock:

Vendor Name: CalDigit, Inc.
Device Name: USB-C Pro Dock
Mode: Thunderbolt 3
Device ID: 0x18
Vendor ID: 0x3D
Device Revision: 0x1
Route String: 1
Firmware Version: 43.1
Port (Upstream):
Status: Device connected
Link Status: 0x2
Speed: Up to 40 Gb/s x1
Current Link Width: 0x2
Link Controller Firmware Version: 1.23.0

Where did you find your adjustment?


The 12.3.1 update resolved the issue. Now both LG monitors are working as well as the laptop.

1 Like