macOS 10.15.7 Catalina, iOS 14.0.1, iPadOS 14.0.1, watchOS 7.0.1, and tvOS 14.0.1 Squash Bugs

I’ve had only worsening problems with Mail since the updates. IMAP messages are apparently not properly deleted and moved to Trash - on the deleting device they go away, but checking mail on another device shows them as still in the Inbox and Unread. Even many hours later. Even after quitting Mail. This previously only occurred on my old iPad Pro, but is now on all iDevices since the updates. Also when reading Mail in portrait mode on the iPad, the unread count does not decrement. Haven’t tried other orientations yet. Surely others are seeing this now, as it is universal on my devices.

First, @fritz, I’m sorry to hear about iTunes turning on your hotspot. That seems completely inappropriate.

Sorry if I’m being dense here. Earlier in the thread, I asked about doing just what I think you described, and I understood @Simon to say it wasn’t possible (at my level of expertise).

Still earlier, in a different thread that I don’t recall, I had asked about obtaining older versions of iOS, and I understood the answer to be that it wasn’t possible (at my level of expertise and perhaps not at all).

Keeping in mind that I’m ignorant and need things to be spelled out, would someone please explain how to restore a previous version of iOS (if I have a backup) or confirm that it is to complicated for me? Thanks.

Will, don’t get me wrong. It can be done. Aside from the backup you need the OS installer (the .ipsw file) and Apple still needs to sign the version you’re attempting to install. Right now Apple is still signing 13.7. I don’t know exactly where to get the 13.7 .ipsw file from apple.com, but I’m sure a friendly and knowledgeable fellow poster can help out there.

Edit: they’re no longer signing 13.7, see below.

Apple stopped signing 13.7 last week. Once you are on 14.x you cannot go back to 13.x.

2 Likes

My apologies. I missed that. You’re absolutely right, Doug. Apparently they stopped signing 13.7 on Sep 22.

Hello everyone interested in this sub-thread (probably only Fritz at this point),

An update: I suspected Verizon’s cellular service was not behaving correctly, after an iPadOS update to 14.0.1, so I called the local Verizon retailer, and the person answering said he just experienced the same issue (as I) with an iPhone (which belonged to a customer of Verizon) which just updated to iOS 14.x.

The proposed solution was to turn off, then on, several times, the iPhone (and in my case the iPad), until the Verizon-cellular signal started working correctly. This sounded like an absurd solution, but I tried it, and it worked. Just letting anyone know, who is interested.

1 Like

One bug that has not been fixed is that the Fitness app on the iPhone, after a walking workout tracked on the Watch, no longer shows your walking route map. That disappeared with iOS 14.0. Many users have been reporting this.

By the way, oddly enough, the Apple Feedback page, where you report bugs, doesn’t let you choose iOS 14 as your OS. It only lets you select up through iOS 13.6.

It shows it for me (Series 4 Watch on 7.0.1 and XSmax on 14.0.1). I realize that a map showing for me and not showing for you is not super helpful to you but i just wanted to point out it’s not a universal thing. This was my walk to the gym today image.png
James Arnold

I have a Series 1 Watch, which I believe can’t be updated to 7.0.1. My iPhone is a X running 14.01. Maybe something was lost in compatibility between iOS 14 and WatchOS after 6? :frowning:

Losin the map happened to me once when I was on watchOS 6 and iOS 13.x and the cause was losing location services for the Apple Watch Workouts app in settings / privacy / location services (after I had to do a settings / general / reset / reset settings because I needed to reset iTunes pairing info.) The only fix for me that worked was unpairing and re-pairing the watch. I never lost any data (save for the last hour or so took to unpair and pair the watch again.)

However, the cause may be different on iOS 14. FWIW I also have maps showing in the Activity app for my workouts since updating to iOS 14 and watchOS 7.

I just checked and it seem I have not lost the location services settings. It must be paired, because the activity itself is getting sent over, right?

Thanks,

The activity came over for me at the time, too - just no map. But it’s obviously a different issue for you. You could try to unpair and pair the watch again - it does tend to fix frustrating issues. But if this is being reported by multiple people, that still may not fix the issue.

We haven’t updated Tonya’s Apple Watch Series 3 to watchOS 7 yet, but it sounds like it might be worth waiting if you have that model too.

Well, I tried unpair and pair yesterday. I just came back from a 2 hour walk with my dog. No map in the activity.

doug

Apple says restoring Watch may fix missing GPS data bug.

It’s more than restoring the watch, which Doug already tried: It’s unpairing the watch, factory resetting the iPhone and restoring the iPhone from the iCloud backup, and pairing and restoring the watch again.

But Doug does have a different circumstance from that support document, since he has a Series 1 that is not running (and cannot run) watchOS 7. Still, it might be worth trying, if this is more an issue with iOS 14 than it is with watchOS 7.

No disagreement there. Their ‘fix’ sounds like a massive PITA.

To be honest, whenever support advice is to nuke and start over, my suspicion is they don’t really understand what’s going on and are just hoping to be lucky.

It does sound like If you're missing Workout GPS routes or Health data after updating to iOS 14 and watchOS 7 - Apple Support

Apple Support wants me to try that. I hate those full iPhone resets. It takes forever to get back where you were, with the Walker and all.

I finally got around to trying this and it did fix the workout map route bug.

It took about 90 minutes to restore everything, including my Apple Pay. But it did work.

1 Like

Since. updating my 2019 MacBook Pro to 10.15.7, it now randomly drops its WiFi connection, something it NEVER did before! I’ve found that it does it most often a few minutes after waking it from sleep. I can manually reconnect or wait a few seconds, and it will automatically reconnect. I know that it’s not an issue with my router, as nothing is drops; both music and AppleTV shows continue to stream without interruption, and no one else in the house complains of drops.