macOS 10.15.7 Catalina, iOS 14.0.1, iPadOS 14.0.1, watchOS 7.0.1, and tvOS 14.0.1 Squash Bugs

I managed to get all five updates installed this morning although I continued to have problems updating my series 3 watch where the “Verifying” alert seems to go on forever. After googling Apple, Watch and Verifying, I landed on the Apple help forum which revealed I was not alone. It was recommended to shut down the watch, quit all the phone’s Apps, restart on the iPhone and watch and try again. This worked.


Is there any way to tell when an update will be released? I am usually slow to update, and at least once I decided to update only to find an new version had been released hours before.

For example, if I had wanted to install iOS 14 (which I have not done), I believe I have now lost the opportunity. In most cases, I probably would prefer x.0.1 to x.0.0, but I might prefer x.0.2 to x.1.0.

Would a possible solution be to back up my iPhone or iPad, archive the backup, install the new release, back up again, archive, then restore the previous release (keeping careful notes, of course)? In case it matters, I back up to a Mac over a cable using iTunes, and I have never restored an iOS or an iPadOS backup. (I hope it’s as simple as clicking the restore button in iTunes.)

Advice or thoughts?

1 Like

I think the backup/restore approach can work, but only as long as Apple is still signing the older version. IIRC in some cases they have been quite aggressive to stop that, like after ~1 week.

You still need to get your hands on the older OS version so you can install that to your device. The backup does not include that (or any other content that is considered ‘synced’).

1 Like

No, it’s a surprise to all of us. All I can suggest is that you check the TidBITS home page for mention of updates before installing. We’ll almost always have coverage within the day.

1 Like

It seems to have killed Siri on my IPad. It’s still there but never answers any questions. The most I get is “Just a moment.”

A post was merged into an existing topic: Security Update 2020-005 (Mojave and High Sierra)

I updated my iPad from iPadOS 13.x to 14.0.1. Now the capability of using my iPad (which has cell signal capability) as a personal hotspot is not available when checking the settings. I was using this hotspot feature easily, under 13.x. Can anyone shed some light on this problem??

Have you changed your carrier plan recently? The same thing appeared to happen to me as well. Coincidentally, at almost the same time I upgraded from 13.x to 14.x, I had upgraded my carrier plan to an unlimited plan (from Verizon). It turns out that not all of Verizon’s “unlimited” plans are the same, and I had to upgrade to a more expensive “unlimited” plan to restore hotspot capability. It was another $10/month. As near as I can tell, none of Verizon’s “unlimited” plans are actually unlimited because the amount of data that can go through the hotspot is still limited.

1 Like

I have not changed the carrier plan since it was first established for the iPad in mid-2019. Still Verizon at 10.00/month (for the iPad), for being on a cell plan which has one cell phone (my wife’s), and my iPad on it. Note: As far as am able to tell, there did not seem to be Verizon data restrictions when using the hotspot under iPadOS 13.x, but I could be mistaken about this.

The irony of this situation is that, when I was upgrading my iPhone to 14.0.1, it was plugged into my MBP and iTunes was managing the update (this is because I like to do a local backup of the iOS device before upgrading in case I want to revert). Now, even though the MBP was connected to the Internet via an ethernet connection to Comcast, for some reason iTunes decided to automatically turn on the hotspot and do the download through the hotspot instead of Comcast. As a result I exceeded my monthly Verizon data limit. I don’t know why it would do this, but it was the second time iTunes has done this when downloading an iOS update. Since I was already faced with paying a penalty for exceeding my data limit, and this was the second time it had happened, when Verizon offered me an unlimited data plan, I thought that would solve this weird problem. It wasn’t until the next time I wanted to legitimately use the hotspot that I discovered the hotspot was disabled. That’s when I contacted Verizon and they told me I had to pay another $10/month to get the hotspot functionality restored. I think it’s a bug that iTunes can turn your hotspot on even when you’re connected via ethernet or wifi, but it can, and it does.

You might still want to check with Verizon. They might have changed your data plan. When they changed my new “unlimited” plan to add back the hotspot capability, I had to restart the phone after they made the change (note: I didn’t have to do a restart to change from my previous data plan to the initial “unlimited” plan). Since you have to do a restart when updating iOS, it might have been that they previously applied a change removing the hotspot capability, but it didn’t take effect until you restarted your iPad after applying the iOS update (which would be even sneakier). I never had any issues or data restrictions using my Verizon hotspot under iOS 13.x.

I’ve had only worsening problems with Mail since the updates. IMAP messages are apparently not properly deleted and moved to Trash - on the deleting device they go away, but checking mail on another device shows them as still in the Inbox and Unread. Even many hours later. Even after quitting Mail. This previously only occurred on my old iPad Pro, but is now on all iDevices since the updates. Also when reading Mail in portrait mode on the iPad, the unread count does not decrement. Haven’t tried other orientations yet. Surely others are seeing this now, as it is universal on my devices.

First, @fritz, I’m sorry to hear about iTunes turning on your hotspot. That seems completely inappropriate.

Sorry if I’m being dense here. Earlier in the thread, I asked about doing just what I think you described, and I understood @Simon to say it wasn’t possible (at my level of expertise).

Still earlier, in a different thread that I don’t recall, I had asked about obtaining older versions of iOS, and I understood the answer to be that it wasn’t possible (at my level of expertise and perhaps not at all).

Keeping in mind that I’m ignorant and need things to be spelled out, would someone please explain how to restore a previous version of iOS (if I have a backup) or confirm that it is to complicated for me? Thanks.

Will, don’t get me wrong. It can be done. Aside from the backup you need the OS installer (the .ipsw file) and Apple still needs to sign the version you’re attempting to install. Right now Apple is still signing 13.7. I don’t know exactly where to get the 13.7 .ipsw file from, but I’m sure a friendly and knowledgeable fellow poster can help out there.

Edit: they’re no longer signing 13.7, see below.

Apple stopped signing 13.7 last week. Once you are on 14.x you cannot go back to 13.x.


My apologies. I missed that. You’re absolutely right, Doug. Apparently they stopped signing 13.7 on Sep 22.

Hello everyone interested in this sub-thread (probably only Fritz at this point),

An update: I suspected Verizon’s cellular service was not behaving correctly, after an iPadOS update to 14.0.1, so I called the local Verizon retailer, and the person answering said he just experienced the same issue (as I) with an iPhone (which belonged to a customer of Verizon) which just updated to iOS 14.x.

The proposed solution was to turn off, then on, several times, the iPhone (and in my case the iPad), until the Verizon-cellular signal started working correctly. This sounded like an absurd solution, but I tried it, and it worked. Just letting anyone know, who is interested.

1 Like

One bug that has not been fixed is that the Fitness app on the iPhone, after a walking workout tracked on the Watch, no longer shows your walking route map. That disappeared with iOS 14.0. Many users have been reporting this.

By the way, oddly enough, the Apple Feedback page, where you report bugs, doesn’t let you choose iOS 14 as your OS. It only lets you select up through iOS 13.6.

It shows it for me (Series 4 Watch on 7.0.1 and XSmax on 14.0.1). I realize that a map showing for me and not showing for you is not super helpful to you but i just wanted to point out it’s not a universal thing. This was my walk to the gym today image.png
James Arnold

I have a Series 1 Watch, which I believe can’t be updated to 7.0.1. My iPhone is a X running 14.01. Maybe something was lost in compatibility between iOS 14 and WatchOS after 6? :frowning: