macOS 10.13.5 High Sierra Brings Messages in iCloud


(Josh Centers) #1

Originally published at: https://tidbits.com/2018/06/01/macos-10-13-5-high-sierra-brings-messages-in-icloud/

Following a few days after iOS 11.4, macOS 10.13.5 High Sierra brings the Messages in iCloud feature to the Mac.


(Dave Watts) #2

Thank you. I was wondering how to activate it.


#3

G’day Folks

Am totally confusticated about how iCloud calculates usage for Messages.

Deleted all old messages/photos/files from my iPhone and iPad. Local storage on each device showed as under 1 MB. Turned on iCloud for Messages and iCloud showed 57 MB used for Messages!?

Installed macOS 10.13.5 yesterday. Manually deleted all the old stuff, leaving the same six conversations, each containing about 10 messages (no attachments) as above. Turned on iCloud for Messages.

Apparently Messages is now using 458 MB of iCloud storage!!!

Something ain’t right.

Cheers, Gobit


(Laurence R. Martin) #4

Updated but messages preference dialogue box doesn’t have a button to enable messages in the cloud. Totally useless. Not able to sync.


(David Byrum) #5

I am disappointed that no mention was made that in order to activate Messages in the cloud you have to be using two-factor authentication.

I travel back and forth between Thailand and the USA and use two different Sim cards in my iPhoneX and at this time I don’t want to use two-factor authentication. So while Messages in the Cloud would be great for me, I won’t be using it anytime soon.


(Alan Forkosh) #6

Unlike IOS, the setting is in the Preferences for the App, not in the iCloud preferences. Open the Messages app and go to Messages->Preferences. Select the Accounts tab and click the iMessage account. The ‘Enable Messages in iCloud’ selection is there under ‘Enable this account’.


(Laurence R. Martin) #7

Thanks, but on my iMac and MacBook no such option appears in the Messages preferences dialogue box. That is the issue.


(Al Varnell) #8

That normally means that you have not enabled 2FA for your iCloud AppleID.

-Al-


(Laurence R. Martin) #9

Thanks but have enabled 2FA.


(Doug Miller) #10

That happened to me as well on my MacBook Air after I installed 10.13.5. Well, after I thought I had installed 10.13.5, because the update must have failed. I checked “About This Mac” and it was still on 10.13.4. Another attempt to install the update failed, but doing “First Aid” from Disk Utility on the drive fixed whatever was preventing the update. (It’d be nice if macOS would actually tell you on the next restart with a dialog that the update failed.)

So, I’d check “About This Mac” to make sure that your computer is on 10.13.5 if you are not seeing the option to tenable Messages in iCloud in the account tab of the preferences pane of the Messages app.


(Alan Forkosh) #11

A poster at MacinTouch was able to finally view the option by logging out of iCloud and then logging back in. See comment #12 at https://www.macintouch.com/community/index.php?threads/icloud-issues.721/#post-3722


(Josh Centers) #12

Our bad, but it’s one of those things that isn’t immediately obvious to us who have that enabled (which is everyone at TidBITS).


(David Byrum) #13

Thanks fir the quick reply! Much appreciated and another reason why I subscribe to TidBits! Thanks :pray:

David


(Adam Engst) #14

Remember that this will cause iCloud Photo Library to spend many hours or days resyncing.