MacBook trackpad woes in Safari

My 2011 MacBook trackpad is annoying me in Safari since I upgraded to 10.13.6 High Sierra. In all apps, my thumb occasionally contacts the trackpad when I’m using a finger to move the mouse. It isn’t a problem. However, in Safari, immediately up to 20 open windows are shrunk so that I can choose any of them. I absolutely Do Not Want To! It is deeply frustrating because within a second, the processor goes into overdrive, the fan kicks in and I have to quit Safari, leave it for 30 seconds to cool down and then restart Safari and HOPE that my thumb stays away from the trackpad. Aargh! How do I adjust the settings so that my wandering thumb doesn’t trigger this? Help. Please. Eternal gratitude