MacBook Air 2012 crashes a lot

Lately my MBA has been crashing with no consistent pattern. I mainly use Safari, Photos and an occasional project in Movies. Lately it’s been crashing one or two times a week. And by crash, it’s the gray screen of death, or sometimes and app stack trace followed by a freeze.

I tried zapping the NVRAM. No improvement
I tried updating the OS, which ended with a blank screen with a folder and question mark. I rebooted (no idea if the update worked), and then the crashing started to happening every 0 to 15 minutes.

Restarted in safe mode and opened Photos. It started doing a restore. This went on for 10 to 15 minutes, sometimes crashing. I tried opening Photos in “repair mode”; this completed but it still said “restoring” when restarting. I do use iCloud Photos.

I have a bootable backup on an external SSD made with Super Duper. Painfully slow, but it did boot. But the Mac froze
while setting up Super Duper to do a restore.

Any other suggestions? Could it be a hardware problem? The HD is an OWC SSD replaced about 5 years ago.

Thanks for any help. The latest M3 MBA release got me thinking about retiring this unit, but I would like to get it running again if possible.

Sounds like it could be hardware.

What macOS release - if you’re running OCLP, I wouldn’t count out an incompatibility. In which case you should contact the OCLP developers.

Have you run any diagnostics?

I ran Disk Utility/First Aid in recovery mode and it found a problem on the “data” part of the drive
Checking the fsroot tree
warning: btn: invalid btn_flags (0x8002)
error: btn: invalid value (65535,0)
fsroot tree is invalid
The volume /dev/rdisk2s1 could not be verified completely

An invalid fsroot tree sounds significant. I’ll start googling.

I applaud you keeping the MBA 2012 running (old Mac hardware is a passion of mine). I do suspect that your 5-year-old SSD is warning you its days are numbered, though.

If Disk Utility can’t repair it, then I’d suggest you boot your clone, then erase the internal SSD and clone it back to that SSD.

If the SSD actually needs to be replaced, that’s an option. OWC sells compatible drives: SSD Upgrade Kits for MacBook Air 2012

These are pretty easy to install. But the one time I tried it (to upgrade a 2011 Air), the drive would overheat when under heavy use, causing it to go off-line until it cooled down again. The thermal pad they provided (which is supposed to let it dissipate heat to the lower case cover) was clearly insufficient. They were very good about replacing the drive, but the replacement also had this problem.

Hopefully, they’ve fixed this problem, since this was many years ago, but I haven’t tried again since then.

I’ve only had something like this very rarely, but when I did, my usual routine, in this order: CMMX, OnyX, TechTool Pro. Since I’ve only VERY rarely had to make use of my bootable clone, this has often helped. Might be a good idea to run TTP on the clone, too; the other two won’t work there if you’ve booted from the Mac.

It’s running 10.15.7 Catalina, which is the latest that this 2012 MBA will run. Ive been running it for at least a year or two, so I don’t think there is a compatibility problem.

I ran Disk Utility/First aid. Found a problem with fsroot. I posted the details earlier in this thread.

Any other suggestions for a utility. Is ther something that tests the RAM?

Thanks @Shamino , The current drive is an OWC Aura drive. This gives me an idea that I should contact OWC. Maybe they have an idea. -

In my original post I incorrectly said that the MBA crashed, even when running from the bootable external backup. I tried it again, but this time I unmounted the internal drive. Ive been using it to do normal stuff and no crashes. So the internal drive is the main suspect.

I ran DU->First Aid on the bootable external drive, and it too had an error verifying fsroot!

I was thinking that the fsroot error on the internal drive was the cause of the crashes, but the drive may have other problems. Or, not all fsroot errors lead to frequent crashes.

Have you tried running Apple Diagnostics?

Thanks, I didnt know about those diagnostics. I tried the diagnostics could not run because it couldn’t find a file TestSupport.efi.

It turns out that that 2010 to 2013 Macs used different diagnostics, and the ones loaded with the D key do not support the older Macs. Some other comments were that the diagnostics that came witht the Mac, called Apple Hardware Test back in 2012, is stored on the hard drive, but is sometimes lost through upgrades.