MacBook, Acer display, Ethernet problem


(Will M) #1

I have a plain MacBook. When I use it in my office, I connect it to an Acer display. Most mornings, I use the MacBook away from the Acer display, and then connect it when I return to my office. At this point, sometimes ethernet works, and sometimes it doesn’t. That’s the problem, and it has been recurring since I bought the Acer display in 2016.

Ethernet comes from an Apple Time Capsule, through an ethernet to USB adapter. (I have three of them from two different manufacturers; the problem is independent of the adapters.) The ethernet adapter is connected to one of the Acer display’s two USB ports. My primary guide that ethernet does not work is that the indicator in the Network pane remains red, but that indicator seems to completely reliable regarding the status of the ethernet connection.

The MacBook is running MacOS X El Capitan 10.11.6. (There might have been an incremental update since I bought the Acer display; I don’t recall.) Anker (manufacturer of two of the ethernet adapters) support suggested I install the latest ethernet drivers, which I did.

When the Acer display was new, ethernet rarely worked upon reconnecting the Acer display. After installing the new drivers made no difference, Anker sent a replacement ethernet adapter, which made no difference. For some reason lost in the mists of time, one day I connected the ethernet adapter directly to the MacBook when I returned to my office, and the indicator in the Network pane turned green. After the MacBook went to sleep, I disconnected the ethernet adapter, connected the MacBook to the Acer display, woke the MacBook, and found the Network indicator was green. I thought I had found the solution, but I was wrong.

Since then, I have tried waking the MacBook and connecting ethernet before using the MacBook remotely and then connecting ethernet after return and letting the MacBook fall asleep before connecting it to the Acer display. I have simply taken the MacBook for remote use but then connected ethernet directly when I returned to my office. I have simply taken the MacBook, used it remotely, and connected the Acer display when I returned. (That’s the procedure that failed almost all the time when the Acer display was new.) All of these usually work, but fail with distressing regularity.

These days, when ethernet does not work, I restart the MacBook and then ethernet works. (At least once, that did not solve the problem, but a subsequent restart did.) Many months ago, I simply used the MacBook without ethernet, and ethernet started working when I woke the MacBook. (Sometimes it seemed to require four hours; sometimes it seemed to require two days. I have no idea why it was different.)

Does anyone have any hints on improving the reliability of establishing an ethernet connection? For that matter, does anyone have a similar setup, with or without the ethernet problems? Thanks for any help.


(Alan Forkosh) #2

You could use a hub like the one at https://www.amazon.com/gp/product/B079GSMZ7G and then connect the monitor using the HDMI port and Ethernet directly. It also has a USB-C port that you can charge your MacBook through. Note that the Ethernet port is a bit kludgy—I would just leave the Ethernet Cable plugged in (alternatively could run your Ethernet through one of the USB ports using your adapter.

Note: I use one of these with my MacBook Pro.


(Will M) #3

Thanks, Alan. That looks like a nifty device.

This just doesn’t feel like a hardware problem, so I’m not confident that changing hardware would solve it. Since I get different results on different days with the same hardware, I expect that there is some bit somewhere that I’m flipping unintentionally. If I knew how to set that bit correctly, I think my problem would go away.

As an example, when I connect ethernet directly to the USB-C port on the MacBook, sometimes I get one reaction, sometimes another, and sometimes a third. (Sometimes ethernet just works; sometimes the green connection light on the adapter lights, goes out, lights again, and then ethernet works; sometimes the green connection light on the adapter lights but ethernet does not work. As before, “ethernet does not work” means that the indicator in the Network pane of System Preferences stays red.) This happens with three different ethernet-to-USB adapters from two different manufacturers. Of course, when ethernet comes through the Acer display, there are more variables, but there is inconsistency in the computer’s response to an ethernet connection when that connection is just about as simple as possible.

I feel both good and bad that no one has said, “Hey, that happens to me, too!” While I wouldn’t wish the problem on a random stranger, misery does like company—and someone might have had the problem and found a solution.


(Gordon Meyer) #4

Look for a firmware update from Acer. I have one of their USB-C monitors that doesn’t work with the newest MacBook Air and there is a firmware update that supposedly fixes it. (Alas you need a Windows computer to install it.)


(Simon) #5

In my experience monitor USB hubs can be finicky. I have resorted to not using any at all. Instead I use a TB dock and connect only the monitor through its DP. USB goes straight to the dock. If I need more USB ports I’d connect a proper USB hub to the TB dock.

I’d go with something like @aforkosh suggested. Sure, you’d have to pay for the USB-C hub, but once you have it you can connect all peripherals directly w/o any additional adapters. It’s convenient and it’s simple. Keeping things simple usually means fewer problems, and if you do run into issues, there’s fewer unknowns.


(Will M) #6

Thanks, Gordon Meyer, for that info. Since I’ve had the problem since the display was new, I have little expectation that Acer decided to address the issue at this late date. Nonetheless, I am hopeful. The major issue is access to a Windows computer. Am I correct that installation consists of running a program downloaded from the Acer web site on the Windows computer while the Acer display is attached?

Simon, thank you for your comment. As I said in my reply to Alan Forkosh, ethernet is not consistent even when there is no hub involved. In more detail, the ethernet cable from the Time Capsule is connected to an ethernet to USB adapter, which is connected to a USB to USB-C adapter, which connects to the MacBook, and the indicator in the Network pane of System Preferences sometimes shows a connection and sometimes doesn’t. When it does show a connection, sometimes it happens the first time the connection light on the ethernet to USB adapter turns on, and sometimes the connection light on the adapter turns on, turns off, and turns back on again before the connection is established. Do you have any thoughts about all this variability with no hub involved? Do you believe a finicky hub in the display could cause the various responses when the display is not connected? If yes, then I’ll bump getting the hub up on my priority list. (Eventually, I expect to get the hub for travel, but it’s low on my priority list right now.)

Thank you to all for your continuing help.


(Simon) #7

I’m not sure if I’d blame the hub in the display or the adapter. But if you get a USB-C dock you’ve removed two unknowns. Sure, the dock could itself have issues (and some do), but there are plenty of reviews indicating that there are solid docks available for reasonable amounts. Just my 2¢. I’ve seen so many strange issues with monitor hubs that I’d try to not rely on those for more than maybe a KB or mouse. In fact, I don’t even connect those to it anymore. I have had good experience with a USB Ethernet adapter, but it’s the old 100 MBbps adapter from Apple. Researching for a new Gigabit adapter I remember reading a lot of comments from people who observed flaky behavior on their no-names. Again, just my own anecdotal experience.


(Doug Miller) #8

Belkin makes a USB-C to Ethernet adapter. It might be worth trying to eliminate the possibility of a bad dongle.

Belkin USB-C to Gigabit Ethernet Adapter


(Will M) #9

As I said in the original post (and I’m not blaming anyone for not reading the whole thing; it is too long but I thought it was all pertinent), I have three ethernet to USB adapters (two Anker and one with only a logo; I’ll look it up if someone thinks it matters) and the problem exists with all of them. I didn’t mention it, but I have two USB to USB-C adapters the problem has manifested itself with each of them. Repeating what I said later, the problem of no ethernet connection will occur when there is no hub involved (as well as through the hub in the Acer display). The common hardware is the MacBook and the Time Capsule; even the cables have been swapped out.

Also, restarting the MacBook solves the problem. (At least twice, I have needed to restart the MacBook twice, but almost always, a single restart fixes it.) Would this be consistent with a hardware problem?

Finally, the problem is not the norm. Usually, when I connect ethernet to the MacBook or I connect the MacBook to the Acer display (which has ethernet connected to one of its USB ports), it works. But maybe one out of five to one out of ten times, it doesn’t. But one malfunction out of ten attempts is way more malfunctions than there should be.