M1 MacBook Pro Slow File Sharing after Wake from Sleep

I ran into a weird problem with File Sharing read and write access speeds. I have an older Mac mini that is sharing its hard drive on my local network. Files and Folders are shared using smb.

Read and Write disk speed is measured with Black Magic Speed Test on M1 MBP.

M1 Pro MacBook Pro is using a USB-C Ethernet adapter.

  1. With a freshly mounted Mac mini hard drive I get about 100 MB/s Read speed from my M1 MBP.

  2. I then keep Mac mini mounted and put M1 MBP to sleep for a few minutes. I wake up M1 MBP and see that Mac mini is still mounted. But now I only get about 10 MB/s Read speed.

  3. I unmount Mac mini and remount it again. Now I get the original 100 MB/S Read speed.

So, it looks like that after waking up the computer, the read and write speeds of still mounted shared network volumes are about 10x slower. Anybody else seeing this?

I have an M1 MacBook Pro but can’t confirm any of this as I typically don’t connect with ethernet.

One thing which stands out is how slow your speeds are with a wired connection, 100 mbs is really slow unless you have machine bottlenecks (a machine only capable of 100 mbs etc).

Have you tried it with wifi to see what speeds you get? I appreciate this isn’t addressing your specific question of ‘wake from sleep’ but I suspect there may be something else going on.

BTW, have you checked whether the disks on the Mac Mini are set to sleep? This could produce similar symptom and would typically show up any time you let the machine sit for a while.

The speed is 100 Megabytes per sec, not 100 mbps. And Mac mini is set to never sleep.

I believe (but could be wrong) that “Put hard disks to sleep when possible” is independent of the computer sleep settings. External drives are included and will spin down and sleep if they have no activity.

Sounds to me like the link renegotiates after wake form sleep and for some reason chooses 100 Mbps Ethernet over Gigabit. Have you tried forcing the Gigabit setting?

Settings > Network > Ethernet USB-C adapter > Details… > Hardware

Is your cabling and equipment all CAT6? It’s odd that it would attempt to negotiate at a lower speed if all involved equipment is rated for Gigabit.

Hardware is CAT6. I thought initially too that after wakeup the ethernet adapter defaults to 100 mbps. However, an internet speed tests confirms that I am still getting my regular 550 mbps. So it is a specific issue with LAN file sharing speed after wakeup. Other computers on my network (Intel Macs with built-in ethernet ports) do not show this issue.