M1 MacBook Pro Migration Issues

I purchased a M1 MBP last December, & just got it working, with minimal help from Apple, and most help from our departmental IT guy. But it got so frustrating that I had to put it down for extended periods when my life got busy. I’ll present a highly condensed narrative of what happened, & how I got to a fix.

The issue: as soon as I used migration assistant to move documents/applications from my MBP i5, it would consistently log me out of my account within an hour. An early trip to the local authorized Apple shop didn’t help; they couldn’t find anything in software or hardware.

Similarly, factory reinstall, the migrate again, no help.
Apple then recommended trying safe mode reboot, which indeed fixed the problem, implying that something starting up was causing the logouts. In System Preferences/Users & Groups/Login Items, I removed everything, but discouragingly, this didn’t help.

Our IT guy finally pointed out that there are additional startup items, hiding in:
I removed these folders one at a time. Of course, it was one of the four items in the last folder.

With Apple migrating to a new processor, I would have hoped that there would be a more systematic means of identifying these sorts of culprits. Instead, much time wasted. At least my M1 is now fully functional, though the time wasted still hurts.

It would have been interesting to know what was in those folders since it’s unusual for anything there to cause a Mac to shut down after an hour of use. Is your current Mac or new Mac a corporate asset managed by your IT department? It’s not out of the realm of possibility that some management software was pushed to a Mac to check its compliance with corporate security policies, and that a failure in those checks results in a shutdown.

Just four items in the critical folder whose removal fixed the issue:

  1. Spamsieve: it’s not this, since I’ve reactivated spamsieve, which runs fine.
  2. Dropbox: com.dropbox.DropboxMacUpdate.agent.plist
  3. No idea what this is: com.srib.psddaemon.plist
  4. Samsung SSD: com.samsung.portablessed.mon.plist

Spamsieve is the only file in the current folder: com.c-command.SpamSieve.LaunchAgent
My suspicion would lie with 3), whatever it is.

Hmmm… That #3 is certainly suspicious. I might have a clue. A bit of searching found this Removing Samsung Portable SSD T1 Kernel Extensions from your Mac | by Ralf Rottmann | Unapologetically Digital | Medium . It’s dated (from 2016) but It notes that the Samsung SSD software they’re referencing installs what seems to be the same kext and plist file

Definitely sounds like the culprit. I don’t know what it is, but its domain (srib.com) is currently owned by a domain squatter and looking at the Wayback Machine, it appears to have always been owned by domain squatters.

Removing the LaunchAgent will stop it from automatically running when you log in, but the software is still installed. If you still have a backup copy of the plist, you may want to look at it in order to find out what is is launching so you can delete it as well.

Interesting. In which case “srib” is probably referring to Samsung R&D Institute - Bangalore.

Bugs aside, Samsung should never have shipped anything with that name. Their products’ plists should all start with “com.samsung”, not some internal group name that doesn’t even have a valid domain.


I’m glad you got the problem solved, and thank you for posting.

I poked around those Library folders and found stuff that I think I can delete. If I move files to the Trash, then could I restore them if I found a problem? Would a program that needs a file there automatically create it, including any required containing folder?

Thanks for noting that.

Some of the files that I consider to be candidates for removal seem to be related to Cisco AnyConnect. Some time ago, I ran the Uninstaller that came with AnyConnect, and the Cisco folder disappeared from my Applications folder, so it was an eye-opener to find the files. I looked inside a plist, and it referred to /opt/cisco/, which contained more files and folders. (Actually, /opt only contained the folder cisco.) Is that (/opt or /opt/cisco) something that I could safely remove?

My day-to-day account does not have admin privileges, so I would need to authenticate. That’s not a problem. However, if I delete /opt, which is obviously at the root level, does it go into the Trash in my user account? In the unlikely event that I want to restore it, do I simply say Put Back and authenticate again? My confusion is because it’s at the root level and my Trash is, I believe, at my user level.

Thanks for any advice, and thanks again to @jh6u.

/opt is a Unix-standard location for “optional” software packages. That is, for those not bundled with the operating system. it was invented for AT&T System V Unix and has since been adopted by most other Unix-like operating systems. In the past, before the invention of package managers, its was commonly used for all third-party software.

These days, thanks to standard package managers, Linux systems typically install software to the same /usr/... locations that system software uses, since the package management system is able to install/update/remove a package’s files without corrupting the rest of the system.

(There is also /usr/local, which serves a similar purpose to /opt, but is intended for software manually installed by a system administrator, not as a standard location for third-party software installations. It is also supposed to be structured similar to the root directory - having its own bin, lib, etc and other similar subdirectories.)

Anyway, /opt/cisco is a perfectly reasonable place for Cisco to install Unix-like software, although I am surprised they didn’t choose to use a more Mac-like installation (e.g. in the application bundle and/or a directory under /Library/Application Support).

Anyway, feel free to remove /opt/cisco if you’re certain you’ve uninstalled all the software that depends on it. If /opt is empty after you do this, you can remove it too - an installer that needs it will almost certainly re-create it - but I’d probably keep it, since it is a standard location and other packages might use it in the future.

Thanks, @Shamino. I appreciate the education that you provide when you answer a question.

My confusion and dismay was because I had run the Cisco Uninstaller, and it didn’t clean up the Cisco stuff. Since the Uninstaller didn’t clean up properly, I’m not certain that I’ve uninstalled all the software that depends on it. However, I do know that I no longer use AnyConnect. Wish me luck.

It’s not a bug. It’s not a Launch Daemon, or Launch Agent.
It’s a feature.

On Monterey (and at least as far back as Mojave), look in System Preferences/Security & Privacy/General
Click Advanced button in lower-right corner.
There you’ll discover a hidden macOS feature:
Logout after N minutes of inactivity.

A few weeks ago, I got a call from a friend with a MBPro which he’s had for years. (I’m his informal, unpaid tech support…). Without so much as a by-your-leave, his Mac had started logging him off after an hour. He’d never heard of this ‘privacy’ feature. Nor had I. Somehow it had become spontaneously enabled. Perhaps it was cosmic rays…

Ms. Google to the rescue. She found an article somewhere that revealed this well-hidden privacy enhancement, and/or PITA depending on your perspective.


“and at least as far back as Mojave”

Tiger, but it’s not hidden there or in snow leopard. It is hidden in el cap.

I can think of situations where it could be a good thing to use (set to a very short time), such as the rash of laptop snatchings at coffee houses a few years ago. But hiding the option is silly. It’s not like they’re confusing or hard to understand options, and there’s plenty of blank space in the main panel to include the two hidden items like they used to be.