LittleBITS: watchOS 8 Birthday Wishes, Printer Predicaments

Originally published at: LittleBITS: watchOS 8 Birthday Wishes, Printer Predicaments - TidBITS

watchOS 8 wished Adam Engst a happy birthday recently, which was both a nice touch and a small surprise. He also discusses some quirky problems related to printer drivers.

I’ve had an Apple Watch from every even-numbered series and I remember seeing the birthday animation on several of them (maybe even going back to the 0th generation), It’s definitely not new and may even have been in the original watch OS. I believe that it uses the birth date from your Medical ID setting. So, if you hadn’t set that earlier, it would explain why you haven’t seen the animation.

1 Like

Interesting! I’m surprised I wouldn’t have noticed it before—I’ve had a Medical ID set up for ages. But perhaps it just never came through in such a way that I internalized it in past years.

Thank you for the article on printer predicaments. While I wasn’t running into issues with photo saturation, after upgrading to macOS Monterey, I began having trouble printing Avery labels from Contacts to our Samsung laser printer. Instead of printing addresses, it would cough up a digital hairball of postscript that would ruin the labels, and go through page after page of paper until I cancelled the print job.

Changing to a generic Postscript driver restored my sanity and my ability to print labels. Hallelujah.

2 Likes

I have a Brother MFC-J805DW which only seems to be found on my network if I restart it each time that I need to use it. I tried to make a generic postscript printer but I don’t get that option.Under Use: I only get Auto Select, Select Software, Other

Any thoughts on where that driver might be?

I’m using Monterey 12.0.1 on a fairly new iMac.

Thanks

H

Two possibilities:

  • Check to see if there is an updated firmware from Brother. I had a problem similar to this (Bonjour/AirPrint could not see the printer after it goes into sleep mode) on a different model brother printer, several years ago. A firmware update fixed it.

  • When creating the printer device in macOS, don’t auto-discover the printer via Bonjour/AirPrint. Instead, configure the printer to use a static IP address (if you haven’t already done so) and manually create a macOS printer that sends to that IP address. You should be able to use the same driver you were previously using (AirPrint? Auto Select?)

    Before Brother fixed their firmware, this was an effective workaround for me. macOS would send a packet to the (configured) IP address at the start of printing, which would wake the printer from sleep. (The Bonjour/AirPrint discovery mechanism would not wake it, probably causing the problem).

Regarding drivers, have you visited Brother’s driver download page? They say they recommend using AirPrint, but they also say you can download Brother’s iPrint&Scan app from the App Store. I don’t know if it will give you any more capabilities than the generic AirPrint driver, but it’s worth a try.

The spec sheet doesn’t say what protocols it supports, but that’s not surprising since this is an ink-jet printer. PS and PCL are rarely supported on ink-jet printers. Since Brother’s web site says to use AirPrint drivers, I think that’s what you will need to use.

1 Like

Hi David

I have done this and it still won’t wake it up. Driver and firmware are up to date. Maybe the next macOS update will fix the problem.

Thanks

H

Sorry to hear it. You should definitely contact Brother’s customer support to let them know. Even if they can’t solve your problem, you want to make sure they have a report, in case they were not aware of the problem. And if they are aware of the problem, the more people that report it should (hopefully) encourage them to make a fix a higher priority.

As a workaround, does this problem also happen if you connect to the printer via USB? If that’s stable, then can you connect it to a computer that is turned on 24x7 (e.g. a desktop Mac used as an in-house server) and enable printer sharing? It’s not ideal, but it may be a viable option while waiting for Brother/Apple to fix the bug.

Good timing on that article @ace . The info page you linked made by Phil Cruse helped me setup my Epson printer after doing a clean upgrade to Big Sur. I too got a very minimal Print dialog and remembered I had just read your article.
I installed the drivers and got the AirPrint driver when the Epson installation finished. I setup a new printer with IP address and found the driver manually. Now I got the Color Management settings.

1 Like