Keeping email on server

I get 100-200 email messages a day. I have a MBP Pro (Ventura 13.2.1) and an iPhone 12(IOS 16.3.1).

Often I’d like to wait to answer messages on the MacBook (better for typing), but recent IOS and MacOS releases seem to have broken the ability to keep email on the server. So whichever system does its next check for any pending email sucks it all down, making it unavailable to the other system.

I scanned the Apple Help web pages and didn’t find a way to restore the behavior. If I could make rules in IOS, I think I could create a shared iCloud mailbox and have a rule that moves mail there.

Note that I am using iCloud mail, Exchange and Gmail and once upon a time I had things set to keep mail on server until I explicitly deleted - at which point it would disappear from all my clients.

I only experienced that if the mail is set up as POP - then, when you read the message it drops of the server. IMAP stays on until you move it.


If you’re using POP accounts instead of IMAP, there’s a setting for each account in Mail that lets you keep email on the server. You can set it that way for your iPhone and on your MacBook have it download your email. That way you only have one main collection point. Of course you won’t have access to all your email from your iPhone that way, you’d need to switch your accounts to IMAP for that.


As others have said, Exchange and IMAP don’t remove messages from the server unless you delete them. However, you may be experiencing what had me befuddled for a while, there is a “filter” button in macOS Mail that hides messages you have already read. Perhaps you’ve activated that by accident. (Again, speaking from experience here!)


I have just the opposite problem, I want everything pulled off the server. Specifically, I want my desktop to pull it all off, and my iOS devices to leave it up there. This way, the desktop always has everything. This is easy to do with POP, I never have figured out how to do it with IMAP. Unfortunately, my ISP’s server quit serving POP to my devices Saturday afternoon. My wife’s Mac, iPhone, and iPad still work fine.

Nothing has changed on any of my devices, much less all three to account for this. Officially, our ISP does not support POP (but we’ve used it with no problem for the last nine months). But of course my ISP says we don’t support it, use IMAP (go away).

Anyone have any idea? It’s bizarre. No obvious differences in my configurations and my wife’s, nothing updated, and all three quit at once?

1 Like

The nature of IMAP is that each server’s folders are a cache to the content of that server.

If you want to remove a message from the server, then you need to move it to a local folder that’s not associated with any server (e.g. Apple’s “On My Mac” folder). You can configure your mail app to do this automatically, if you want it to happen for all messages.

Note, however, that once you remove a message from a server, any other clients accessing the server (e.g. your iOS devices) will lose access to it. Which might be OK if that’s what you want.


It may be the obvious: they deprecated POP a long time ago, claim they don’t support it, and if something broke in your individual email account they’re not going to fix it. It could be something as simple as a security certificate or setting that you had but your spouse does not (or vice versa), or it could be an act of the universe.

FWIW, my ISP happily supports both, and I mix them so that my office desktop machine is the “canonical” one that has copies of everything but does not pull them off, so that all my other devices can use IMAP and still see and act on what’s there.


Yes, I get that. In the end I created a “Rule” that moves the new mail to local folders. However, there is no indication anywhere that there was any new mail. The local folder will not open by default.

I still have two more devices to reconfigure for no good reason. Even for IMAP, Apples Mail account “wizard” has never created a working account configuration here.

That is exactly what I want. With POP, I had to check one box. With IMAP, I have to set many vague preferences, then make rules, and it still doesn’t really work the way I want.

My wife and my accounts were created within minutes of each and are virtually identical, other than the addresses and passwords. Just doesn’t make any sense.

But thanks.

And, now, as of ~8 PM last night, POP works.

Go figure…

1 Like