JavaScript Required

Hi friends,

I’m attempting to respond to an Apple Support survey that they sent me after a tech support phone call. However, I can’t respond, as in Safari v16.1, I’m getting this message:

This survey will not be accessible if the browser has JavaScript disabled. Please enable JavaScript in your browser settings to continue with the survey (Press F1 for Browser Help).

I’ve confirmed that in Preferences → Security, that Enable Javascript is checked. I’m running 1Blocker and StopTheMadness, and have disabled both of those in Safari. I’ve also disabled Content Blockers in Safari Preferences → Websites for the survey website in question. I can’t think of anything else that would interfere with the loading and functioning of Javascript, so I’m contact you very smart people in the hopes that maybe you can offer up some suggestions on how to resolve the issues. :grinning:


When things like this happen to me, I open the link instead in Chrome or Firefox and see if one of those work, rather than try to figure out why something isn’t working.

1 Like

Yep, but that doesn’t resolve the issue with Safari. :grinning:

Right, but that’s the point: unless you start seeing that message everywhere else, it might just be a weird issue that you’ll never see again and is a waste of time trying to “fix”. (E.g., it might be an issue with Apple’s site.)

Unfortunately, Apple’s site is just the latest instance of it. I’ve seen it before, but never stopped to resolve it.

Bizarre that an Apple Support request points you to a website that Safari cannot handle - for whatever reason.
For various reasons (including still using Mojave with its Safari security concerns) I have switched to Firefox. My only concern is that I lose the security/versatility of Keychain for logins.

Trees: Not sure about this, but, one might try re-installing Java for Mac. Here is a link to the Oracle site:
But, the site also recommends removing older versions which I’ve never done but will try to do prior to installing this new fresh version. My doing so worked perfectly. Your mileage might vary! Best, Patrick
PS: Whether or not this affects ‘Javascript’ I don’t know.

It does not in any way. Java and Javascript are not related in any way whatsoever.

1 Like

Well, thank you. I wish I could have helped better. Best, Patrick

You hadn’t mentioned that before.

So, again, I’d start with trying the link in Firefox and/or Chrome to see if the link works there without the same error message. If it does, then I’d try to isolate whether it’s something in your Safari settings for your account by creating a new account on the Mac (or use another account if you’ve already created one for this purpose) and see if a new account with default Safari settings has the same issue.


Vaguely recall this happening to me too. Actually, my default browser is Brave because of the security and the extension. But 5 to 10% of the time I have to open a site in Safari because some feature in Brave prevents the site from working. I’d switch my default to Safari if I could use the extensions I use on Brave (e.g., Amazon) and if it didn’t center favorites and tab bar items.

Errors about needing to enable JavaScript don’t necessarily mean JavaScript is disabled. It may simply mean that some script used by the page didn’t run. This could be due to a network error (e.g. failed to download the script, if it’s not part of the main page) or because it has been blocked by some content filter (e.g. an ad blocker or security software).

My default is Firefox and I experience the same thing, but perhaps not quite as often. I don’t know if it’s JavaScript or something else. However, I have not received any error message; the site simply does not function as it implies it should.

perhaps a double check of full disk access and similar in the Security and privacy- privacy section may help untangle the sometimes flaky Safari.

Especially with ventura and/or M1 or 2018 - 2020 intel macs- I have both versions in my mini and until Monterey and M1 rarely had such issues in any but Safari updates.

Oh for the old days of my apple plus with 48 K !!

Unfortunately, there are no permission issues. That was one of the first things that I checked.

The issue is not only happening in Safari but Firefox too. So there’s that.

Do you use a custom DNS server, rather than DNS from your ISP? Anything that might do some content filtering of some sort?

One oddity i had found on my 2018 mac mini when trying out ventura had to do with the following

I was trying to get my email - gmail set up on apple mail. I had been previously not using email on that mac but using it mostly for
a separate internal volume for document storage. When I tried to simply start the applemail application and add one of my email-gmail
addresses it was no go. So trying to access on safari or firefox was also no go. I had been previoulsy using from time to time
on that computer my NordVPN- but had simply turned it off- and to keep things simple had deleted it. But when I reinstalled it
and set it to be loaded on login but not activated, both safari and Firefox worked and I was able to simpoly add by gmail account.
Eventually after turning on all previous shut off security features the requirement for loading using- opening Nordvpn and/or their protection
accessories was no longer required to get email and safari and firefox to work normally. - Why I do not know.
"The best laid plans of mice and men aft gang aglay " or " to err is human, to really screwup takes a computer "