iPhones and iPads Now Require a Passcode on Every Backup/Sync

Thanks for the article, Adam. I thought I was the only one annoyed by this. I am no luddite but refrained from updating iOS because every update seems to add something unexpected. In the bad sense. iOS 15.7.1 did exactly that. I ended up losing two weeks of some minor data because of it.

I use iMazing and really enjoyed its automatic updates, so when I first needed to input my passcode I thought it was a bug. I am now used to it and set iMazing to backup in a specific time period when I know I will be available, but Apple could have let users know this new “feature” was part of the update. Oh wait, no, this is Apple. They do what they want.

2 Likes

Yes indeed.

And as my wife had to learn the hard way, that means even if you have an otherwise fine backup, if just one little part of it becomes corrupted, you are SOL. Lucky you if you still have the old phone and it works because then you can attempt an alternate backup (iCloud or iMazing), but if say that iPhone just got crushed by a truck, you would be completely effed. Not a nice design at all.

For those of us using older, unsupported systems there will never be a fix for AppleMobileBackup. But fixing iOS should be enough for those who use encrypted backups.

I just read that 11-page discussion and was reminded why I don’t usually go to that site for help. So much better here. :grinning:

Last night I decided to troubleshoot a sync issue that has been bugging me for months. If I had to do a backup each time I would still be troubleshooting the issue. By clicking Cancel and only doing a sync I was able to find the problem quickly.

Oh, the problem was “operator error.” Again.

1 Like

Oh, fascinating! I don’t sync via the Mac either, so I didn’t notice this in my testing of the backups. I’ll adjust the article to focus it on backups.

FWIW, I just tried this on my iMac with 13.1. I am not seeing this. I’m also not seeing it when I plug in my keyboard. (I usually keep that plugged in, and unplug only when I need to charge the mouse.)

This is intensely annoying when you have automated backups (e.g. iMazing), and as you said, it just trains the user to respond to the unsolicited PIN prompt with the PIN. “Oh, that must be the backup”.

It should trust the computer if you’re making encrypted backups.

I opened a case with Apple on this, and they haven’t responded to it yet, which I guess is a good sign, in that they didn’t just reject it as working as designed. Maybe everyone should report it.

I will not update my iPad to IOS 16 until this is fixed.

2 Likes

I get around the need for iCloud+ by using MEGA.nz. 20 GB of storage at the ‘free’ level.

Everybody has there own way of dealing with security and the iPhone.
I for one -do not use a passcode and do not have any banking or hi-profile personal apps. I only use the passcode when I am traveling outside my sphere of local areas. Works for me. I have ‘find my phone’ turned on-so if it is lost-I’ll just erase everything remotely. I just can not deal with punching in numbers -just to read a text or adjust my hearing aids. To each their own.

I’ve been fighting this “feature” (I consider it actually a bug) for weeks now. I asked about it on Apple Discussions but no one knew what was causing it even AFTER I told them it started with iOS 16.1. IF Apple DID deliberately release this without warning its customers and explaining why Apple took the this route (laziness or incompetence), then it is another piece of malfeasance against their customers. The fact that once I tell my iDevice to trust my iMac should be enough until the next major update of iOS (ie iOS 17). Fortunately when I tell iTunes to sync it does; it is only the backup function that requires the password. My iPad Mini 5 is still on iOS 14.4.2 so I 'm spared on it but both my Mini 6 & iPhone 12 are on iOS 16.1

2 Likes

Curiously, when I deleted all my local backups from Storage Settings (under “iOS Files”), they did not immediately disappear from the UI. Revisiting that UI, or using Finder, confirmed that they were in fact gone.

I’m not seeing this on Catalina with my iPod Touch. If I attach it to the iMac with a lightning cable and click on the icon in the Finder, it will sync automatically (with no backup). Also, no need that I can detect to enter a password. I do see a notice on the iPod itself, when I attach the iPod that, to use certain applications, I will have to enter my six-digit password.

If you’re not performing a backup, then it won’t ask you for the passcode.

As for why it’s not trying to make a backup when you click Sync, the only reason I can think of is if your device is configured to automatically backup to iCloud.

There used to be an undocumented system preference to disable automatic backups with sync, but I believe that preference was removed in Catalina, so that shouldn’t affect you.

Hmm. I think it is configured to automatically backup to iCloud. But I’ll have to doublecheck.

Right. If you’re automatically backing up to iCloud, then it won’t automatically make a USB backup when you sync, so it won’t ask for a passcode.

Unless you manually click the button to make a local USB backup. Then it will ask.

This is correct.

OTOH having recently switched to iCloud for backups, I’m stuck with loss of auto-sync to my Mac over night. Now when I plug the phone into power over night, it will indeed automatically back up to iCloud over my home wifi as desired. However, syncing to my Mac no longer takes place when plugged into power and connected to my home wifi (as is the Mac).

I have yet to figure out how to restore that behavior. Just because I back up to iCloud, does not mean I no longer need to sync the phone with my Mac. AFAICT right now, the only way to do that is to manually initiate by hitting the sync button in the Finder. Not ideal to say the least.

2 Likes

This bug also appears in earlier OSs.

I never update until the .3 release, so my devices

  • MBAir (Intel) macOS 12.6.2 (21G320)
  • iPhone XR iOS 15.7.1
  • iPad mini 6 iPadOS 15.7.1

all demonstrate the unwanted behavior, with iMazing.

I haven’t seen evidence anywhere that Apple considers this to be a bug. It’s perhaps an over aggressive security feature to prevent a person who has somehow managed to hack a trusted computer from then accessing the iDevice by backing it up to that Mac.

Apple may not consider it a bug, but many USERS do! I’m setting in my own house, with my iDevices connected to my iMac to which I’ve been backing my iDevices up and is a Trusted Computer. Once you have done your initial connection, sync, back up, complete with appropriate password(s), then you should not have to jump through hoops again until you either upgrade to a new MacOS or buy a new Mac.

3 Likes

Growing tired of the endless requests to unlock my iPhone and my two iPads just to accomplish the daily backups I’ve done for years with no problems, I complained about this (some weeks ago) to the iMazing folks, who (correctly) pointed me to Apple.

I sent a strongly worded feedback to Apple, but have heard nothing.

In the meantime, I’ve finally just given up making iDevice backups. Life is too short.

1 Like

Unfortunately you are preaching to the choir. It is just another notch in Apple’s journey to make their products totally closed systems to maximize profits. Another “fun” thing is one I discovered today, which is that Apple will no longer allow you to connect your iPhone to a Mac using Bluetooth. I just spent 4 hours trying to do it and failed despite a rigorous browser search for solutions that I tried including some terminal commands and deleting library prefs.

Recently I needed to reset my Outlook and Google cloud drives for some testing purposes. Both of these Apps have moved the actual data folders into the User Library into a folder named CloudStorage and will no longer allow users to choose their desired location for the data, only an alias. I spent an all nighter trying to do it which including deleting the contents of that folder. I was prevent from doing it by some hidden preferences as after I ‘deleted’ them it was impossible to empty the trash, Even booting from other drives and activating the root user failed to be productive. Given Apple’s myopic focus on trying to protect users from themselves they essentially removed the capability for me to manage my own machine. Understand that this was in my User Library not in any of the System Libraries. Even terminal commands and changing file privileges failed to work. After many hours I finally managed to do it, abet no sure exactly how I succeeded, but it was a combination of rebooting from my internal Apple SSD on an older macOS and with the assistance of CleanMyMac, I finally was able to be successful.

And for those that are frustrated with Finder changes and the latest Mac GUI, I invite you to check out this website to see how it should be done:

AskTog Home Page

This is the engineer that literally wrote the book called Apple Interface Guidelines, of which I still have a copy, and holds many patents on many of the GUI design features that we use everyday, It is a real eye opener and explains how a computer interface should be done and how to do it. Unfortunately is seems as though Apple has decided to toss all their copies into the trash in its latest iterations of macOS.

Enough said.

1 Like