iPhone SE not connecting to USB port

For several months, maybe a year, my iPhone SE (1st gen) stopped connecting to my desktop Mac, which is from 2014 and running Mojave. If I plug a lightning cable from the phone to a USB port, the phone won’t charge and iTunes doesn’t recognize the phone. Also, the phone doesn’t appear in the USB tree under System Info. Other devices are recognized and appear, such as a Flash drive. Unless I’m mistaken, the problem would appear to lie with the phone itself. Any ideas on correcting the situation. I don’t have enough room on the phone for the latest updates so will be stuck at 14.7.1 (although I’ve read mixed reports about iOS 15).

Some obvious considerations you did not mention:
Have you tested with different cables? Different ports on the Mac? Different Macs?
Have you tried cleaning out the port on the phone?


Mark W offers some solid tips.

I just replaced my 2016 SE because it was getting very finicky with Lightning cables and syncing/charging. Eventually only one cable in the house would work and only if the Lightning cable was plugged in a certain way (Lightning doesn’t have a good side or bad side but this phone insisted on it). The port was clean and the cables were good and worked with other devices (I tried maybe four of them).

Something similar happened to a relative’s iPad, too. The receptacle for the Lightning cable just wears out or gets misshapen due to stress on the cable or dropping or other damage. Unfortunately, this problem – assuming it’s your problem – is beyond economic repair.

Yes, I tried three different cables. No change in behavior.
I tried two different USB ports on the Mac. Both work with other devices.
I tried plugging it into my very, very old MacBook Air running 10.6.8 but it doesn’t show up in the USB tree there either.
I haven’t tried cleaning out the port on the iPhone (how?) because it connects fine to the charger plugged into the wall socket.

Thanks. The phone itself is in very good condition but, of course, it’s a few years old (5?) and it’s possible there has been wear to the port. I’m reluctant to replace because the phone itself works fine and new models are very expensive.

Totally understandable. My SE helped me make my decision by adding a growing yellow crescent along one side of the display and the LED sidelights becoming visible at the top of it. And the battery, replaced once during Batterygate but not far away from another exchange. And the eventual time the original SE will end up on Apple’s unsupported list. It’s had a good run.

But I can understand not wanting to spend hundreds on a replacements. It’s one reason I went for the second-generation SE rather than splash out on a 13 mini.

I personally have experienced an iPhone that wouldn’t sync until I cleaned the pocket lint out of the port. If I recall, I used a flashlight, and a paper clip, and scraped carefully a few times. Afterwords miraculously my phone would sync again (and also play music in my car via USB again). For me, previously the phone would charge, but it would not sync.

1 Like

An SMC reset can sometimes fix USB port problems on Macs. This should leave all data and settings unaffected so is worth trying.

But see this tip

Might try that. It won’t damage the contacts?

Could be but it happens on both Macs and other USB devices do sync.

I too have done the paperclip trick, but have switched to a toothbrush. It works but less risk of damage :slight_smile:


Tried that with a toothpick and pulled out some lint but it still was invisible to the Mac. Charges fine though when plugged into a wall socket with the charger.

I have used toothpick or compressed air

Make sure you have removed all the lint. I periodically clean the port on my phone and it’s surprising how much can be in there. It also gets compressed down by continually plugging in a cable, so can take a little loosening. The lint stops the connector from fully engaging and snapping in all the way. Charging seems to have a higher tolerance for an incomplete connection than syncing – as with @seth’s experience I’ve had cases of lint build-up where my iPhone will still charge but can’t sync/connect to my Mac.

I’ll try once more but I did it twice and did remove lint. Visual inspection shows it to be pretty clean unless there’s something I’m missing in there. Odd because the phone used to sync just fine. At one point, after an iTunes upgrade disturbed syncing (no longer worked), the OS required a small update so that iTunes would recognize the phone. That worked. Then there was at least another iTunes update and I haven’t been able to sync since them. I have no idea if these are related though. The problem may still lie with the phone itself.

1 Like

If you are certain that the port itself is damaged, a good independent repair shop may be able to replace the lightening connector.

Off the top of my head, you might want to contact iPad Rehab to see what they think and to get a price quote. Their on-line price list doesn’t list this particular problem, but from what other related repairs (e.g. “not charging”) cost, it will probably be something around $100 for the job.

(I haven’t personally worked with iPad Rehab, but I am a viewer of their YouTube channel and I think they are well qualified to replace a lightening connector, should that be what your phone requires.)

This isn’t what I’d consider cheap, but it’s less expensive than a new phone, so you might want to give them a call.

Not sure you want to try this yourself, but the last time I had a Genius Bar appointment it was for an issue with an intermittent connection with my smart battery case on my iPhone X, and the technician used an alcohol wipe pushed in with a thin piece of plastic to clean the Lightning port connector (and it did come out with some black on it.)


I could try that. I cleaned it out a third time, this time with a pin. Not sure it actually cleaned anything out though. In any event, the connector (all three of them that I tried) fits perfectly into the port and can charge the phone but doesn’t register on the desktop Mac. I’m stumped.

I am running Mojave. Yesterday I got a system message to update iTunes (to with the advice, I think, that it fixed an issue with connecting iPhones (I cannot find this update on the Apple website).
I hadn’t noticed a problem with my iPhone 8 or iPad but maybe it addressed a problem with newer models? If so it won’t help with an SE, of course, but is worth mentioning.

I have version 12.9.5 here. Haven’t seen an update notice though.