iPhone in car keeps dialling my own number

I have my iPhone linked to my car with Bluetooth. Recently the system has started randomly trying to dial my own number. It doesn’t connect, of course, but it is annoying that music is interrupted.
I have unsuccessfully tried some troubleshooting such as powering the phone fully off.
It is possibly associated with an iOS navigation app that sometimes overrides the music but it doesn’t happen all the time - I will do some more checks on this possibility.
Another option to try is resetting the iPhone but it is a nuisance to get everything connected again.
My concern is that it could be an app, iOS or the car bluetooth system that is playing up. I will have a hard time getting any of these three parties to acknowledge and/or fix the problem.

(PS I don’t want to use Carplay).

Is it actually dialing its own number or just displaying the number on screen as though it were? I ask because in our 2015 Subaru Outback (no CarPlay), using Siri (and some other things) cause the screen to go into “phone mode” even though no phone call is actually being made. It’s a little frustrating since it doesn’t respond to the hang up button on the screen. It usually clears after a minute or two.

Thanks for pointing that out. I’ve seen something similar as well.

Some apps (I think Google Maps is one) let you configure it so it announces turns via:

  • The phone’s own speaker. So you need to have the volume turned up and the phone nearby, like mounted on the dash.
  • Bluetooth, as BT audio. So your car stereo needs to be in the mode for playing BT audio (e.g. what you would use for playing music over BT).
  • Bluetooth, as a phone call. So your car stereo can be in any mode. The voice will interrupt what the stereo is playing. It may also change the display to look like you’re in a call when it’s talking. In my experience, it switches back a few seconds after it stops talking.

FWIW, I usually leave my phone configured to use the phone’s speaker and stick it on the dash with a vent mount or a sticky mat. I find that the phone’s own speaker/microphone is good enough for phone calls and it navigation directions don’t interrupt the music playing over the stereo (which is usually playing from my iPod Touch over USB).

The downside of this is that when I take a call, I need to push a button on the stereo (power or pause) to stop the music. But I rarely take calls when driving so that’s just fine.

The BT audio mode is probably best if you’re already playing your music from the same phone via Bluetooth. Then the phone will just mix the audio as appropriate.

All the audio modes can be maddening in a car. The big realization we had long ago and finally remembered on our first car trip since the pandemic a week ago was that when we plug in an iPhone so its battery doesn’t run down while mapping, some of its audio goes to the USB input on the car stereo, not to Bluetooth. I haven’t exactly pinned it down since I’m driving, but I think the music it’s playing will go to Bluetooth still, but the map app’s audio will go to USB. If we switch the car input to USB, everything goes there.

Here is a photo of my setup. The navigation app has a speed limit alert function that I like to use and so prefer to have it running whenever driving. It has worked well for more than 10 years (I helped the developers of its predecessor that originally ran on a PDA!).
The iPhone holder plugs into the 12V outlet and has its own USB socket so I avoid the issue of the car trying to communicate with phone via USB.
The problem of the system dialling my own number has only arisen in the past week or so. I cannot think of any change to the car, phone or apps that might have caused this but will keep investigating…

My son’s car (a 2013 Dodge Dart) has 3-4 USB ports, but when he plugs his iPhone into it, the car acts like he plugged in an iPod, and starts playing his entire music library, starting with “A”.


Even if audio is already playing.

I finally just bought him a USB charger for the lighter, and he uses Bluetooth, which is much more sane.

Seems like a car made in 2013 should have been aware of the differences between iPhones and iPods!

My wife’s car used to start with ABBA every time! Eventually I created a playlist called AA_popular that sort of fixed the issue.
Back to my issue. I have discovered that the Metroview app is to blame. It used to deliver a quiet chime whenever I passed a speed limit change. Now it tries to dial my number. I have sent a bug report to the developer but I suspect it was triggered by a recent iOS update as it has worked well for many years (and several cars)

That starting over with music is a known (and very random) issue. I have times I can go weeks playing through my song list, and other times where every time I start the car (i.e. I stop for gas), it will put me back to A (which for me is (the) Acid Queen by The Who), unshuffled. I am connected via BT and my deck has two ways to play through the phone that way. I think one is phone specific and one is not. I also have issues lately with voice control (Siri or a phone call) grabbing control of the deck and freezing the deck and the phone. At this point I’m not sure if the deck is having issues or if it’s my phone. It was a refurbished deck I bought in 2017 and the phone is an original SE still running iOS 12.

The restarting to A issue has happened in both cars, and occasionally when I ask the phone to play as I’m working around the house (but that is very rare). So I definitely attribute that to a phone issue.

Back to your issue - glad you figured it out. :slight_smile:


I thought I would try linking the phone via USB cable instead of Bluetooth. This activated Car Play. However the Metroview app on my phone then displayed “No GPS” so it won’t work in this configuration.
I am surprised that Car Play seems to disable access to GPS for apps on the phone.

Does it do this for other navigation apps? I’ve had no problem navigating with Apple Maps and Google Maps while connected via CarPlay.

As @Shamino says, I don’t think it does. I’ve successfully used Maps.me with CarPlay and it showed my location and navigated without problem (and of course Apple Maps works well). Maybe it’s a bug in Metroview, as they do list CarPlay as a supported feature of the app?

Edit: maybe the Metroview app gives that as an error on the phone because they expect you to use the CarPlay interface for the app instead?

I have started using the Metroview app in Carplay as an experiment. It works OK but has fewer features.
I hadn’t realised it actually works with Carplay as I couldn’t see its icon. It took some research to find out how to move it to the top of the apps list in the Carplay display so that it was easy to find and open:
Settings/General/Carplay … select the car … Customise … drag the Metroview icon to the top of the list. It could be a topic for a Take Control chapter!

1 Like