iPhone 13 mini/iOS 15 nuances, text notifications

  • I upgraded to a 13 Mini, coming from a 2016 SE (which was on iOS 12 - huge leap here)
  • My SO upgraded from a XR on iOS 14 to a 13 on iOS 15.
  • I also have a 2015 MPB running Sierra, and a new iPad running iOS 15.

I have a number of things I noticed in the change to iOS 15, but the biggest and worst issue is text notifications. I have my SO set as VIP and even so, I often do not get sound notifications.

One of my problems seems to be when DND is on (the phone) from 9pm to 9am, and I am working on my laptop. I rarely see the banners coming in, and the phone is not notifying me either, even though he is set as a VIP. I thought maybe the phone could “see” me and thought I could see it, so I turned it upside down and that didn’t help either. Sometimes it works right, but usually it does not.

He often texts on the way home to see if I need anything at the store. I rarely get a beep or notification then, laptop is nearby, DND is off.

Today I got a flat while on a bike ride. The phone was in my pocket and I had headphones on. He sent me THREE texts to confirm my location after he left and I only heard the last one. I have texts set to beep three times 2 minutes apart and I didn’t get one beep until the last text. I was 3 miles from home, DND was off, no iPad or computer to confuse the phone - WHY didn’t this work correctly?!

I’ve been using DND for a few years now and have had him setup as a VIP for quite awhile and he would always break through when on the old phone. This is especially frustrating as I have my parents setup as VIPs in case of emergency and I need this to work again.

Note: I have not gone to 15.1 yet, but it seemed to work better on iOS 12.x


For notifications while in DND, double-check that your husband is set up in settings / focus / do not disturb under people at the top, under allowed notifications.

I’d also check that settings / notifications / messages is set to immediate delivery rather than scheduled summary, and that time sensitive notifications is turned on. Also at the bottom double-check that under “customize notifications” that repeat alerts is set to the option you want.

I don’t think I have any suggestions for the rest. I have noticed in the past that my watch/phone don’t always get message notifications when my laptop is unlocked, so I’ve turned off message notifications in MacOS. That’s seems to have helped.

iOS 15.1 is definitely less buggy than 15.0.x was. Upgrade asap.

All of those were set as you said. The one thing I did notice was the 3 minute break-through was turned on, so I turned that off (I have a client who calls back immediately if his calls go to VM). I think that setting must be in two places as I am sure I had it set that way when I first got the phone.

But you know what? He is NOT a favorite in Contacts - and that’s where I initially had it set in iOS 12. I’m going to change that back.

On my computer, I have notifications set to just banners. I turned the sound off quite awhile ago as that same client complained about the noise when we were on the phone. I’m going to turn that back on to see if that helps with alerting me when I’m working, and just turn the volume off if I’m on the phone.

I’ll get the update done this week and see if it helps.


Scratch that on Favorites in Contacts, it’s completely different than before. When I make a change I can’t see it. I’ll read up on that.