iPad/iPhone/Mac problems with personal hotspots?

Background: I experienced a serious internet-service outage recently, which lasted at least 36 hours, possibly a bit more. I realized from this experience that I rely rather heavily on having the internet work well for me and my wife.

Ok, here is my question:
I have a Mac-Mini (2020, M1 chip), running Ventura 13.6.6.
I also have an older MBP (2019, Intel chip), also running 13.6.6.

While the internet-outage was occurring, I thought I would try my personal hotspot on my iPad (with cell-signal capability), in order to enable temporary internet service for at least one of my Macs.

The Mac-Mini would not work at all, with respect to connecting with the personal hotspot, however, the MBP connected fine.

Does anyone know of any problem or problems which would prevent the Mac-Mini from connecting with the personal hotspot ??


I’ve used an iPhone hotspot with a MacBook Pro and an iMac without any problems in the past. If I recall correctly (it’s been awhile since I’ve done it), it is easier to use a hardwired connection (Lightning/USB C <=> USB A/C) than a wireless connection.

1 Like

I have an older 2012 Mac Mini and I had some issues when trying to connect to my phone’s hotspot. My problem was that I have a Blu-ray recorder right next to the Mini and I think it was interfering with the antennas so I moved it over a few inches and that helped. But sometimes it still didn’t see the phone in the wireless list so I think that the signal is not that strong and then I could be getting some interference from various wi-fi devices in the neighborhood.

Are you using wi-fi or the bluetooth choice on the phone? As the previous poster mentioned, connecting with the USB cable is the best way for a foolproof connection.

I have a MacBook Air (M1, 2020) running Big Sur and routinely connect to an iPhone hotspot while traveling. With nothing to back me up, I doubt if it is your hardware causing the problem.

I experience that infrequently but all too often. I don’t believe it is from nearby devices; it has happened (again, infrequently) in multiple locations, and will often resolve itself if I turn Personal Hotspot off and back on. With no evidence to support my supposition, I assumed it was the iPhone (which does work most of the time) tripping over some bit in its innards.

In my experience, Wi-Fi works much better than Bluetooth. I have not used a USB cable, but will plan on trying that.

I have had hotspot issues in the past couple of months with my 2015 MBPr running Sierra. I figured it was the old machine but it does work sometimes.

Twice last week though I used my phone and saw it was connected to something via hotspot but I have no idea what. So I’ve turned it off.

Verizon is my provider.


The problem would seem to be with the Mini, since the MBP did connect successfully to your iPad’s hotspot. Could you elaborate on the failure? Did the iPad hotspot network name not even show up on the Mini? Or did it show up, but you couldn’t select it? Or you could select it, but then…you get the idea. Just trying to figure out where in the connection process the Mini failed to cooperate.

This has been my experience as well. I no longer try to do it wirelessly.

It’s worth sharing that since iOS 16 (I think, it may have been earlier than that), there is also support for tethered Internet sharing over Ethernet. If you have a separate cable/DSL modem and Wi-Fi router as your WLAN setup, and a USB-C Ethernet dongle available, you could just plug that into your iPhone, swap out the WAN port on your Wi-Fi router from your modem to the Ethernet adapter.

Interesting idea - Thanks.

Thanks for the reply. The hotspot showed up in the Wi-Fi area, and I tried to invoke this option, and everything went as expected, except the websites simply did not want to load.

I am ok on this for now. I will try a few of the suggestions received so far.

Thanks to everyone for the replies and ideas.

I am ok on this for now. I will try a few of the suggestions received so far, especially to try using a USB/wire approach.

I suppose it wouldn’t hurt to look at Apple-dot-com Support as well, to see what they have to say about using hotspots.

If you’re sure that you were connected but nothing would download, you need to check the DNS settings on your Mac as it sounds like you weren’t getting a correct IP address. If the Mac was connected to ethernet, it might have been stuck on a local IP.

Thanks. This may be a real issue for me. I will check into it.

My first attempt would be to hardwire (Ethernet) the iPhone to the desktop Mac, the Mac mini in this case. Use that as a tether. Then have the desktop Mac share that connection over wifi so other Macs, MacBooks, and even your other iDevices can use that connection.

Settings > General > Sharing > Internet Sharing > i button

Choose Share from iPhone to Wi-Fi.

If you have trouble reaching a website, try testing by using its IP rather than its name (if you happen to know a good example). Otherwise, just see if choosing another DNS helps. Google has a public DNS at and

Thank you Simon for the notes/advice.

I did manage to get my Mac-Mini connected to my iPad, and use my iPad hotspot on the Mac-Mini, via wire/USB connection. This approach seems to work well.

I have not yet tried to expand the internet services to other devices in my local network, via sharing from the Mac-Mini.