iOS 15 Mail app Gmail send over wifi error

Hi, anyone other having problems sending mail on iOS (15.4.1) from Gmail ?
IMG_D74D0683F473-1
Translation: Failed to send the email
Connection to the sending serveur “smtp.gmail.com” failed. Other sending servers can be configured for mail accounts in Settings > Mail Accounts.

What’s really strange is that my mail will be send, once I turn off wifi?!

There’s no VPN actif. I tried the different Gmail troubleshooting options (CAPTCHA reset, delete and reauthenticate as described on iGeeksBlog) as well as the Apple Mail Support setup for Gmail. Nothing changed or, more precisely, I can’t modify the port of the smtp server to 587 nor add a second one in my Gmail account setup. If this is helpful, I used the Add new account > Google > google.com authentication site in order to create my mail account.

My Gmail account setup is:



(you may have to use Translate to get the english terms, sorry for the inconvenience)

I’m not having trouble; my SMTP server settings resemble yours.

Do you have some sort of different DNS setting for WiFi by any chance? Settings / WiFi, tap the information icon on the right of your access point name; are there custom settings under “configure DNS”?

This sounds like it may be an issue with your LAN or your ISP.

When Wi-Fi is off, your phone will send the message over the cellular network. And this clearly works. So Google’s server is clearly also working.

As @ddmiller wrote, check your LAN settings to make sure you are able to connect to smtp.google.com.

Also check whether your ISP allows connections like these. I remember reading, years ago, about service providers that (in some attempt to prevent spam) would only allow outbound e-mail to go through their own servers and would block connections to any third-party servers. If your ISP is doing this, then you may need to configure your outbound mail to use your ISP’s SMTP server instead of Google’s.

If that’s not an option, maybe Google offers some alternate port numbers that might work. I see you’re using port 465, which is Google’s port for SSL access. But SSL is considered insecure these days. Google supports TLS protocol on port 587. See what happens if you change the port number from 465 to 587.

FWIW, my phone is using port 465, which works fine via my ISP, Comcast. The headers of my outbound mail show that TLS version 1.3 is used for the communication.

See also Check Gmail through other email platforms - Gmail Help

2 Likes

Thanks and no, the DNS number is automatically distributed.

Great explanation, Thanks David! I’ll check this and report back if this resolved my problem. Furthermore, I will test tomorrow the behaviour with a different ISP in a friends home. Maybe I can narrow down the problem.

With a standard oAuth gmail setup on iOS, you can’t change that port number. And I think Google has deprecated the ability to connect to SMTP with anything other than oAuth 2.0.

Well, I just checked, and that will start happening May 30.

1 Like

Alright, this is an important information since the Gmail App Password was the only way I was able to configure manually port 587 with smtp.google.com.

David’s 2nd advice

helped me finding out that my ISP actually preconfigured the ports:

  • POP3: 110 et POP3S: 395
  • IMAP: 143 et IMAPS: 993
  • SMTP: 25 et SMTP Auth: 587

Back home, I’ll have to dig into my routers web control panel and will hopefully be able to open port 465.

Lastly, I can exclude other settings problems with my iPhone. Staying at my friend’s home tonight, sending with Mail App and Gmail works fine over their wifi connexion.

Thanks to @ddmiller and @Shamino for your quick and effectif help. I could change my router’s configuration and open up port 465 in order to use Gmail’s OAuth 2.0 API. Sending mail over wifi with my iPhone works again.
– file closed –

1 Like