Intermittent iOS text Message alerts

Hi friends,

For the last couple of months, I’ve only intermittently been receiving text alerts in Message on my iPhone and Apple Watch. My iPhone will be sitting next to me with the ringer on, volume level at maximum, and alerts enabled. When I happen to pick it up sometime later, I’ll see that I have several new text messages, but I will have received no audible alerts on my phone or watch. Yesterday, I texted a friend, and when he didn’t respond like he normally does, I called him. He also states that he’s been intermittently receiving text message alerts on his iPhone as well.

Both my iPhone 14 Pro Max and Apple Watch 8 are running the very latest updates to their respective OS.

Is anyone else having this issue? Do you have a fix? Or, is this something that was introduced in one of the latest iOS 17.x updates that Apple will have to address and fix?

Cheers!

Same here. And it goes back much further than you report. Sometimes audible alert + watch vibrate, sometimes only audible alert, sometimes only watch vibrate, often nothing.

Very frustrating.

Semi-hijack of the thread.

I have the same problem, but with phone calls. I have the phone set to silence unknown callers, but it seems to silence all callers. (I can’t remember the last time the phone rang for a non-FaceTime call; the phone does ring for FaceTime calls.) Any ideas on what I should check (Notifications is set to allow and a sound is chosen) and if it could be related to the lack of Message alerts plaguing others?

Same problem but only seems to not alert me when I am sitting near my laptop (which is also getting all the texts via iCloud)

Yes. Sometimes it works, other times not - no idea why but quite annoying. On occasion my watch will ‘ding’ but my phone won’t. I see the same inconsistency with my Mac.

I believe I posted this already, but this is as the watch and phone are designed. Only one or the other will get a notification - never both. Generally if the phone is locked and watch is unlocked and on your wrist, the watch will sound and/or vibrate the notification. If the iPhone’s display is on and the phone is unlocked, then the phone will sound and/or vibrate the notification and the watch will stay silent.

1 Like

Thanks for the info. The watch and phone vibrations are easy to miss. Is there a way to force them to sound instead of vibrating?

  1. Turn sound on (in control center on the watch, or watch app, sound & haptics, turn off silent mode; with the side switch for any phone other than iPhone 15 Pro/Max. Since I don’t have a 15 Pro I’ll leave it to you to learn how to make sure sounds are turned on).

  2. Watch app, notifications, messages. Set to either “mirror my iPhone”, or that it’s set to “custom” and make sure that allow notifications is on and sound is on.

  3. iPhone, Settings, Notifications, Messages. Make sure that allow notifications is on, immediate delivery is on, critical alerts and time sensitive is on, tap sounds and make sure that it’s not sent to “none” or to a silent ring tone.

1 Like

Thanks for the info. I’ll give it a try.
David

Same problem here. I get notification of some texts, not of others. No rhyme or reason. I’ve brought it up and been advised to re-pair my watch with my phone. (A major hassle if you’ve never done it!) I have done it and still have the same issues. Sometimes it works, sometimes it doesn’t.

Sam

I’ve been having this issue for years. After observing it for a while, I think I know what’s going on.

Apple is trying to be smart about where notifications are presented. It tries to display on the currently active device, that includes the Mac. If I am using my Mac, the notification displays on the Mac. If I am using my phone, the notification display on the phone. if I using my watch, it displays on my watch. If I am not using any device, it displays on my watch. Mostly.

The first problem, from my perspective, is that Apple is not very good at determining the active device. I will often get the notification on my Mac, many minutes after it goes to sleep. Same with the phone. I miss these notifications. This happens dozens of times per day. And not just from messages. This affects most notifications from most apps.

The second problem, for me, is that I don’t care which device I am using, I want all notifications on my watch. This is not possible. There is no setting to make this happen. I figured I would just turn off the notifications on my Mac, and then they’d come to my phone or watch. Wrong! If notifications are off on the Mac, and I am using my Mac, I get no notification at all. Nothing, Nada. Nowhere. This is just stupid.

I should be able to determine where I want my notifications to display.

Is anybody seeing similar issues?

2 Likes

Yes, I’ve long thought this. All of my notifications on the one device that is with me almost 24 hours a day, more so than my phone.

Here’s hoping that Apple gives us that choice someday.

I could live with this but my preference would be for Apple to stop trying to figure out what I’m doing and simply send my user selected notification to each of my devices. I could turn on or off as I choose.

IOW, let the user decide.

2 Likes

On New Years Eve I worked for about 4 hours on my Mac. I also had my watch on and as I was using the keyboard it would have been ‘awake’ most of the time. My phone was next to me but locked.

I received several messages but no notifications on any device. My Mac is set for Alerts which ‘should’ stay in the notification centre until dismissed. I didn’t get any Alerts.

Last night was only new year’s messages but I’d like to think if something important came along my notifications would work correctly. I don’t use any Focus or Do Not Disturb settings.