iForgot Apple ID reset not working?

Is anyone else having trouble with resetting a locked Apple ID?

On Friday my Apple ID was locked “for security reasons”, which happens all the time. But this time I couldn’t unlock it with https://iforgot.apple.com, and I know of no other way to unlock. I got various errors such as:

  • This Apple ID is not valid
  • No captcha shown
  • Entered captcha correctly but it asked for it again
  • “Your session has timed out.”
  • Unable to reset online

On Saturday I called Apple support. The only suggestion they had was to use a signed-in device to change the password – which worked, but it blew away my generated app-specific passwords.

So today I tried to use appleid.apple.com to create new app-specific passwords, but that requires you to sign in again, and my applied id locked again, and of course I can’t reset it.

Apple System Status is all green, so if there’s an outage, Apple either doesn’t know about it or is not admitting to it.

Earlier today my iPhone insisted I type in my password. Instead, I went to my Mac and – same problem. So I typed in the password and it responded that the account was locked for security reasons. Logged into appleid.apple.com, typed in password, answered security questions and then it was unlocked.

Just another data point…

I just rebooted my router, deleted the apple.com site data from Safari, and tried again. After entering the captcha I got error “Cannot Verify Account”, “We apologize but we are unable to verify your account information online”.

But the results seem to be variable. Sometimes I can get further, but never to completion.

Another data point:

  • Thought could be interference from Sophos Anti Virus web protection, so tried last night with that turned off. Still didn’t work
  • Then tried it by changing (almost) every variable: I used a practically extension-less Edge browser on a Windows 10 computer, where the networking routes out through a Zscaler proxy. Only commonality is it is using the same DNS servers. And guess what? It worked as expected, first time!

Of course it could be that Apple fixed a problem since last night. Next test will be when it gets security-locked again – will using Windows work?

I did see something weird on appleid.apple.com. To first access the page you can sign-in using your Mac’s password. Then when you try to generate an app-specific password, it says you must authenticate with your Apple ID password, which is as expected. But, it doesn’t ask for the password. It gives you a choice: take a picture of a QR code using an iPhone, or use a “security key” (meaning, a physical authentication device). Note there is no other choice.