iCloud syncing of Messages to MacBook is problematic

My wife has an Intel MacBook, an iPhone 13, and an iPad mini 6. All are up to date.
She uses iMessages a lot to communicate with other Apple users (on their Macs, iPads and/or iPhones).

Delivery of incoming messages to her Mac is problematic - they frequently vanish into a bit bucket somewhere. The messages will appear on both the iPad and iPhone, and those devices will notify her of the arrival. But not the Mac, unless it is open and awake. If it’s asleep, new messages often never appear in the Messages app. As a result, a particular conversation when viewed on the Mac can be missing some messages, while the entire thread will be displayed on both iPhone and iPad. On occasion, she’s opened Messages on her Mac to continue a conversation that’s been underway, and sent an irrelevant (or non sequitur) response since the thread is missing important context due to previous messages that never arrived.

This is driving her nuts, and driving the Tech Support department batty. I’ve tried everything I can think of. Force-quit the Messages app and relaunched. Restarted the Mac. Signed her AppleID out of Messages and then signed her back in. Disabled iCloud syncing for the Messages app and re-enabled. Ensured that iCloud is enabled for Messages on both the iPad and iPhone.

The faulty behavior suggests that the culprit might be iCloud and its interaction with Sonoma. It’s my understanding that messages addressed to her when the Mac is sleeping get cached in her iCloud, and then delivered to the Mac when it next goes on-line. Sometimes they do, but usually they don’t.

Similarly, if I delete a message thread on her iPad while the Mac has the Messages app front-most (and awake), the thread vanishes from the Mac within a few seconds. But if I do the same thing while the Mac is asleep and then wake it up, the thread that was deleted on the iPad remains. The deletion doesn’t get synced to the Mac via iCloud.

I conclude that Sonoma (14.5) has an iCloud defect that fails to properly sync to the cloud when it awakes from sleeping.

With the same OSs, I have not experienced this. Just a WAG - does she inadvertently have Focus turned on? (I really wish it used a switch rather than just an icon to show its status.)

She does use Focus, once a week when she goes to play bridge. I created a scheduled focus for her for the designated day/time/duration to prevent iPhone notifications from disturbing the players (some of whom get quite aggravated if/when cellphones go beep-beep-beep during their bridge deliberations).

I think the next thing I’d try is logging her out of Apple ID completely and the log back in. It’s such a pain in the neck, particularly if you also use iCloud Photo Library, as it makes the Photos app resync completely with iCloud, which can take a long time, but that would be the next thing to try.

Also, of course, on her iPhone, settings / messages and make sure that text message forwarding is turned on for the Mac.

Something similar happened to me and I resolved it after discovering that somehow “Do Not Disturb” got turned on on my MacBook. I turned it off and the problem went away.

@bwhite I checked for DND on the Mac, but it’s not set. Thanks for the suggestion.

@ddmiller Doug, I have considered turning off iCloud completely but have not yet done so since it has such significant implications (resyncing photos…). It is on my list of things to try next.

As for the iPhone settings, I confirmed that text message forwarding to her MacBook is enabled. However, it’s my understanding that setting only impacts the disposition of incoming SMS (‘green’) messages that are delivered to the iPhone over the cellular network. She has very few non-Apple friends sending her SMS from their Android devices. The missing messages she’s experiencing are all iMessages (‘blue’). I don’t think they are impacted by the iOS Settings/Messages/Text Message Forwarding configuration. However, I could be wrong on that.

I can’t reproduce the behavior on my MacBook Air (an M1) with my iPhone. Both have the same version of OS that are on my wife’s devices. So perhaps I’ll have to log her out of her AppleID entirely, and live with the consequences.

Thanks

@david0 OK, here’s my WAG…

I notice you said your wife’s Mac is an Intel model, whereas yours is Apple Silicon. Could it be that iCloud-to-Mac syncing works better when Sonoma is running on AS?

I can imagine that the AS port of macOS is receiving more Q/A love than the Intel port these days….

I was just about to say this; my AS Macs behave pretty well with Messages. Not trying to be “just buy a new Mac” but if your wife has wanted an excuse, the Air’s are amazing devices.

For just another data point, I have to say that I just checked my Intel iMac running Sonoma, which had been sleeping, and my Messages app was synced just fine.

@ddmiller - Thanks for doing the test on your Intel iMac.

I just tried another experiment, exploring the hypothesis that iCloud syncing is in general problematic on my wife’s MacBook. If it’s messing up syncing with messages, perhaps it’s not handling contacts properly either. So I opened the Mac, brought Contacts to the front, opened her iPad and launched Contacts there. Added a new contact card on the iPad. Within a few seconds, the new contact appeared on the Mac. iCloud syncing did what it was supposed to.

So I closed the Mac. On the iPad, I deleted the newly-created contact. Waited 15 minutes (to ensure that syncing from iPad to iCloud servers had happened), then opened the Mac. The Contacts app was still active and front-most. The new contact card was still there. I waited 5 minutes, to give the macOS process that deals with iCloud syncing to do whatever it needs to do. Na-da. The deletion of the new contact did not synced.

I figured 5 minutes was sufficient time for macOS syncing to happen, so I quit Contacts on the Mac and launched it again. Within a few seconds, the deletion got synced and the contact card vanished.

I then scanned through her (long) list of contacts on the iPad and found one that was way out of date. Deleted it. Within a few seconds, it then vanished on the Mac.

Conclusion: iCloud syncing of contacts on her Mac works OK if the Mac is awake and the Contacts app is active. But syncing seems to fail if changes are made while it’s asleep. This behavior may or may not be related to what I’ve observed with her messages. Hard to tell.

Next step in troubleshooting: I might try creating a new user account on her MacBook, configure it with her iCloud credentials, and see if messages (and contacts) get synced to/from it properly or not. Or perhaps do as @dhb suggested and get her a new MacBook. She does have a birthday coming up…

Another idea until replacing the Mac happens is to have her close the Messages app when she is done using it. (Cmd-Q is, of course, an easy way to do that.) It sounds like for your test that Contacts synced fine if it was newly-launched after the computer was sleeping.

As for Contacts syncing, just to test this (and to see if it maybe fixes Messages sync when sleeping), open the Contacts preferences, go to Accounts tab, click the iCloud account, and change from automatically to something timed, like 5 minutes, 15 minutes, etc.

I’ve had problems with two MacBook Air, one Intel, one M3, but only with messages from Android devices. Often I can neither send to nor receive from an Android device on a Mac, when nothing has changed in Messages settings (or any other settings). The only way I’ve found to fix (?) the problem is by restarting the Mac.

Have you tried going into the settings for the Mac Messages app and clicking the Sync Now button under the iMessage tab?

Yes, Alan — it hasn’t worked. Only restarting fixes it, and not always on the first try.