iCloud Photos not available when the system library is on a network volume?

This is only marginally on topic, but worth mentioning.

My daughter had the brilliant idea of me just using a share from my Synology NAS as the destination for her local sync of everything rather than attaching her old drive. I think I have enough storage for all that and it’s much tidier.

But when I tried to do that I got this annoying error. What a pain in the butt. What is the concern? Speed? Occasionally going offline? I have had all these problems with local external drives, and they’re not debilitating. Is the file system unable to ensure file integrity? But I use it for Time Machine without issue…

This is just crippling.

It seemed like your daughter’s brilliant idea. Too bad that it did not work. It would be interesting to understand why. I’m glad that I went the external SSD route.

The file system may be able to ensure file system level integrity. It can not ensure application level integrity of the data. Let’s say an application needs two write operations to two different files to complete a logical transaction, and the second write fails. The two files may be consistent from the file system level but from the application’s standpoint something’s amiss.


Thanks for the reply.

Sure. But then that same “application level” problem exists when using a local drive, right? So why place this restriction on using a NAS?

Perhaps Photos is being a bit paranoid. Or that there are some file system features that are not present on a NAS file system’s implementation that iCloud Photos is requiring.

Right, my previous point.

But this is still odd because now I’m digging back a few years into my memory, when I WAS storing my iCloud Photo Library on this same NAS. Ultimately, the performance got to be too slow, so I moved it to a local, external NVMe Thunderbolt drive recommended here on TidBITS. That was less slick, but inifinitely snappier. But my use case has changed. That’s no longer my main Mac, that external drive has been repurposed, and I only want the photo library on that Mac for backup purposes. So the NAS is ideal.

Anyway, I don’t know what has changed between then, when it worked on the NAS, and now when it won’t, besides OS updates on the iMac (and the Synology NAS). Very strange.