iCloud Desktop - Character Limitation

I just had to troubleshoot a problem my mom was having, and I was somewhat surprised by the cause. The problem she was having was that when she tried to save an Excel file to her desktop, it was giving her an error that she didn’t have the authorization to write to that location.

Apparently, at some point recently her computer had been set up to sync the desktop with iCloud. This is not a feature I’ve ever used. I was suspicious about that–and eventually figured out that the message was because she was trying to save the file with a slash (/) in the name. I know the slash is the actual directory separator on the Mac, but my understanding is that historically MacOS has tried to hide this from the user and allow slashes in file names. (But it does not allow colons, which were the directory separators in classic Mac OS. If you create a file with a slash in the name, using ls in a terminal window will show the colon instead of the slash.)

Well apparently somewhere in the iCloud sync mechanism the system fails to do the necessary magic to support this, and instead of producing a useful error message (“Don’t use a slash in your file name”) it just tells you that you don’t have the authorization to write to the location.

The other fun discovery is that once you’ve turned on iCloud desktop sync, when you turn it off your desktop is suddenly empty. Your iCloud drive contains a “Desktop” folder whose contents you can move back to your local folder, and there is a warning when you turn off syncing. but it’s not a terribly friendly way to behave.



Yes that is a bad error message. No help at all.

You can find a long discussion about that here: iCloud Drive ate my Documents folder

1 Like