How to Uninstall the Discontinued CrashPlan for Home


(Adam Engst) #1

Originally published at: https://tidbits.com/2018/11/12/how-to-uninstall-the-discontinued-crashplan-for-home/

Since Code42 Software discontinued its CrashPlan for Home service, there’s no reason to let the CrashPlan software continue to run in the background on your Mac. Here’s how to remove it.


(Peter Hornby) #2

Suppose, like me, you have taken Code42’s advice and upgraded to CrashPlan for Small Business. Did that upgrade process include the removal or migration of CrashPlan for Home, or do the two apps (one new, one now superfluous) exist in parallel, in which case your instructions will be very useful.

Pete


(Adam Engst) #3

Honestly, I don’t know for sure, since I didn’t upgrade. Do you have two different CrashPlan apps in your Applications folder now?


(Peter Hornby) #4

Thanks, Adam,

I’ll let you know when I get home and can take a look.

Pete


(Paul Schinder) #5

I did upgrade. All that’s in my Applications folder is “CrashPlan”, last updated Sep. 19, 2018, so well after the switch. There’s no other application, so my guess is that they simply updated the Application.


(GV) #6

You should have only one CrashPlan app, version 6.8.3. That’s what is running your CrashPlan for Small Business data uploads. If you select Open Code42. . . using the Finder Menu Bar icon and then About Code 42 under CrashPlan For Small Business, it will provide the version number, etc.


(Dani Bensky) #7

This did not work at all for me, as both scripts just lead to beeps. I have the CrashPlan app in my applications folder but cannot get rid of it. It its Get Info window the “Locked” check box is grayed out. Any suggestions?


(Adam Engst) #8

Did you try the Terminal command in the article to remove the immutable flags?


(Doug Miller) #9

I know that the Crashplan for Home dmg install included a “To uninstall, double-click the trash can” icon on the bottom. If you still have the install file for Crashplan, you can try opening the .dmg file and look for it. If not, I can share a dropbox link to the last version I had.


(Dani Bensky) #10

Adam,
Thanks much for the reply. When I run Terminal command in the article I get the following;

Last login: Sun Nov 4 14:27:11 on console

Gulong-MBP-2016:~ dan$ chflags -R nouchg /Applications/CrashPlan.app chflags -R noschg /Applications/CrashPlan.app

chflags: chflags: No such file or directory

chflags: -R: No such file or directory

chflags: noschg: No such file or directory

Gulong-MBP-2016:~ dan$

However the app is in fact there:

Any further thoughts on how to get rid of this would be appreciated. Thanks for your time.

Dan


(blm) #11

There should be two chflags commands. The first is:

chflags -R nouchg /Applications/CrashPlan.app

The second is:

chflags -R noschg /Applications/CrashPlan.app

Try running them as two separate commands and both should work and you’ll be able to remove CrashPlan.app after that.

You could also run them as a single command with a semi-colon after the first, which is what I think the article’s getting at, although the semi-colon’s lost in the article, which you might want to fix Adam.


(Dani Bensky) #12

When I ran the first one, nothing happened. When I ran the second, I got a message that I am not allowed to do that [My account gives me administrator privileges]

Last login: Wed Nov 14 21:10:30 on console

Gulong-MBP-2016:~ dan$ chflags -R nouchg /Applications/CrashPlan.app

Gulong-MBP-2016:~ dan$ chflags -R noschg /Applications/CrashPlan.app

chflags: /Applications/CrashPlan.app: Operation not permitted

Gulong-MBP-2016:~ dan$

After running these there were no changes to the Get Info window of the CrashPlann app. Am I doing something wrong?

Thanks again for your help.

Dan


(Al Varnell) #13

Then use them by trying:

sudo chflags -R noschg /Applications/CrashPlan.app

-Al-


(Dani Bensky) #14

Al,
That worked. Thanks much! This was driving me nuts.

Dan


(Adam Engst) #15

Thanks, fixed. I couldn’t test this for real, so it wasn’t clear if what I was copying was correct or not.

And it’s good to know that sudo may be necessary.