How to Stop Drop-downs

Is it possible to stop the various drop-downs that want me to subscribe to various notifications? These things are becoming more ubiquitous and really annoy me. I have never accepted one but clicking the selection to refuse the offer doesn’t seem to stop them from appearing the next time I visit that site.

I’m running AdGuard and have the Safari set to block pop-ups but these don’t seem to help.

This example is of one of the less irritating drop-downs since it relatively thin.

If you are asking about Mac Safari, I would try this:

Safari Settings (on Ventura - Cmd-, is the hotkey in Safari), go to the “Websites” tab, click on Notifications, and turn off the check box at the bottom, “Allow websites to ask for permission to send notifications”. I believe that the setting is in a similar place (in Safari preferences) on older MacOS versions.

If it’s just something that CNet is doing - well, that’s when I start looking for a site that has the same content without annoyances like that. (But I just went to cnet dot com and didn’t;t see these; I am using the ad locking app Wipr).

After I posted I noticed the Notifications setting you refer to. That box was checked but I unchecked it, deleted the CNet cookie, and revisited their web site. Sure enough, there was the drop-down.

To trigger the drop down it seems you usually have to at least scroll partially down a page. They don’t seem to occur otherwise. And it’s not just CNet. Macworld is another good example:

Aha, now I see this too on Macworld. It did take scrolling up and down all the way. I’ve tried a few things with my ad blocker, (I also use Stop The Madness extension). Nothing in those settings seemed to stop these.

I did finally get it to stop (without clicking on the banner). I think just refreshing about three times does it.

(One of the other things I changed in Safari website settings was in AutoPlay - I changed it to Never autoplay as a default.)

Anyway, what a PITA.

Although it’s 10 years old the bookmarklet Kill Sticky still works, at least as far as Monterey. It’s not always 100% effective and sometimes also kills scrolling, but I use it frequently to get rid of those annoyances.

https://alisdair.mcdiarmid.org/kill-sticky-headers/

1 Like

I use the 1Blocker Safari extension and found the Block Annoyances set of filters appears to stop the CNET and Macworld drop-downs you posted screenshots of. Even with all of 1Blocker’s filters enabled, however, it doesn’t stop all of the annoying things the CNET website does.

The built-in protections in the Brave browser also seem to stop those drop-downs.

For sites that are as hostile as this (if I don’t give up and decide they’re not worth my time), I set them to always open in Reader mode. That should get rid of all the popups and other annoying intrusions. You can do this either by click and holding on the little ‘Reader’ icon that appears to the left of the URL in the address bar and then choosing Use Reader Automatically:

image

Or, you can click the gear icon (website preferences) in the toolbar if you have this enabled (which I recommend) where you can tick the User Reader when available box as well as adjust other settings for that site:

You can add this button to the toolbar using the standard Mac Customise Toolbar… feature in the View menu.

I have this set for medium.com and it’s fantastic – anytime I click a link that opens an article there, I just get the article without all the rubbish littering it. :grin:

2 Likes

At least sites like Cnet have Reader views that eliminate ads & drop-downs for articles. I guess the issue is that you have to load the normal page in order to select Reader View and during this time the annoying drop-downs get their chance.
As Jolin reports, Safari can be set to automatically open pages with Reader View:

Turn on Reader View for all sites

  1. Open your Settings and select Safari.
  2. Scroll down to Settings for Websites and tap Reader.
  3. You’ll see your currently open pages and can turn on the toggles to automatically enable Reader View for those you want.
  4. Turn on the toggle for Other Websites to enable the Reader for all other sites automatically.

Copied from

BUT… this means that helpful pages like this one do not display correctly (discussions are lost).