How to get AirPrint to work

Lots of people can’t get AirPrint to work when they are running the latest macOS version of Sonoma and the latest version of iOS on their iPhones.

I was one of them, but I solved the problem by changing one setting on my 24" M1 iMac.

That setting is the macOS setting for Printer Sharing. Once I turned it off, I could AirPrint from my iPhone 12 to my Epson ET-2650.

This worked even with my iMac and iPhone VPNs turned on.

Here is the step-by-step:

  1. On the Mac, go to System Settings/Appearance/Accessories & Internet/Sharing/Printer Sharing and turn OFF the slider.
  2. On the iPhone, in my example printing a note in the iOS Notes app, from the note you want to print, tap the Share Icon, tap Print, and for the Printer, select the printer that does NOT have Mac or iMac in small print below the name of the printer. In my case, I selected “EPSON ET-2650 Series” (not the other two printers in the Recent Printers list.)

Before I figured this out, I tried the directions in several reputable Apple-oriented website articles, but couldn’t make it work.

Now, it works perfectly. By the way, I use Printopia with Sharing turned on. Printopia contained the instruction: “macOS built-in printer sharing is active. Disable it if not required.” Once I turned it off, I could use AirPrint.

1 Like

Ahh, thanks for sorting this out, Mark Weinberg!
I’ve followed your instructions on my old 2017 iMac Retina (limited to Ventura), and re-installed AirPrint, and — voila! — we can print from various iApple devices around the house to our two networked printers, one a laser, and the other an inkjet.
I had switched to Apple Printer Sharing and removed AirPrint, figuring it was redundant. Now I know it’s the other way around in my case.
TidBITS Talk is wonderful!

I’m happy this worked for you. This probelm was driving me nuts until I stumbled on the solution. I got the idea from a Mac application called Printopia that let’s you “print” from your iOS device to various destinations on the Mac such as downloads, Preview, and so forth. In the program’s window, Printopia told me to turn off the System setting for printer sharing, and suddenly I could AirPrint.

Ahh, yes: take what I wrote above and substitute ‘Printopia’ for ‘AirPrint’. I followed your lead on this, and Printopia works for me while Apple ‘shared printing’ does not …