How do I stop an external DVD from automatically opening DVD player app?

(Jonathan Robinson) #1

Hi
This is driving me nuts and I would really appreciate some help.

I am going through and ripping some DVD box sets on my iMac (10.14.3). I am using an external Samsung USB DVD/BluRay player. Each time I insert a DVD the DVD player.app starts and the disk starts playing full screen. I then have to wait a few seconds before I can quit it before letting MakeMKV read the disk.
In >System Preferences>CDs and DVDs I have everything set to ignore but I am assuming these are legacy setting for old machines with internal optical disk drives.

Can anyone suggest a way to stop DVD player from launching?

Thanks

0 Likes

(David Rostenne) #2

Hey Jonathan, have you tried setting it to open MakeMKV instead of ignore?

0 Likes

(Jonathan Robinson) #3

Thank you so much - this worked! Not sure why is wasn’t “ignoring” it but this works for me.

0 Likes

(David Rostenne) #4

You’re welcome! It was probably a case of needing to change the setting to get the computer to really notice you want something different and then it worked… try changing it to ignore and see if that sticks now.

Computers are weird :wink:

Cheers,

Dave

0 Likes

(John Burt) #5

I don’t have a DVD handy to test this right now. Once a DVD is in and you are back to Finder, check the Get Info window for the DVD to see if the default app can be changed for all items there. Just an idea.

0 Likes

(StuartJ) #6

I did what you did and it didn’t work; make changes in system preferences. What DID work was changing the M4V files player settings to one different than the DVD player. Now it plays with the Quicktime player and I’m a lot happier. The movie was and is in M4V format.

0 Likes