Help please. I have Old CD-ROMs that can't be read…need suggestions

I have 6 CD-ROM loaded with vector images designed to be used in PS, Illust. etc. My MacBook Pro/Catalina doesn’t recognize the discs when I try to mount them nor is disc utility able to mount them even though it “sees” them. They contain commercial images of architextural details, antique toys, picto graphs and a few symbol fonts, that I bought when I was doing some design work (more than 10 years ago). I would love to be able to save some of these to my hard drive. Anyone have any suggestions for a piece of software or a service that might be able to help me? I would very much appreciate any clues at all. Thank you! Chuck Crawford

They were probably formatted using the old HFS (“Mac OS Standard”) file system, which Apple dropped in macOS 10.15 (“Catalina”). Your options are:

  • If you have an old Mac that can read them (this would be anything running macOS 10.14 (“Mojave”) or older), use that Mac to read the files.
  • You should also be able to run macOS 10.14 (or older) in a virtual machine or an emulator. You may need to give the VM/emulator direct access to the optical drive or create a disc image for it to use.
  • In the Linux world, there is the hfsutils package that can access HFS-formatted media. It is a set of command-line tools and is pretty awkward to use, but you can use it to copy files from an HFS volume to something else.
    Hfsutils has been ported to macOS via MacPorts and Homebrew.
  • Some Linux distributions include an HFS file system that can mount an HFS volume directly.

See also hard drive - Reading HFS standard and MFS on Catalina - Ask Different

My recommendation, if you need anything more than trivial access, is to set up an emulator or VM running any version of macOS from 6 through 10.14. Mount the CD from there. Then use it to copy all the files to local storage. Once that is done, you can burn a new CD in ISO-8859 or HFS+ format, which modern versions of macOS can support.

8 Likes

Is your optical drive having problems w/ other discs? I live in a very dusty area, and consistently, read fails are fixed by blowing out the drive. Then there is the usual suspect: Cleaning the disk with a soft cloth, wiping out from the center.

Many disks of clip-art, fonts, etc. were ISO-9660 rather than platform specific, so there is hope it is just dust.

2 Likes

Unfortunately, and contrary to what many thought when compact discs arrived, those discs are not eternal. Over time, they can fall prey to dust, scratches, even sunlight if left exposed for a long time, and become increasingly unreadable.

Give the disc a good clean and try again, but if that doesn’t work I’m afraid you’re probably out of luck.

(Worth noting that if you have any recordable or rewritable discs, those are even more likely to degrade over time. I used to work in CD/DVD/Blu-Ray duplication, so know this from bitter experience.)

4 Likes

I found an article about how to use hfsutils to copy the contents of an HFS volume to your local Mac:

Following this lead, I tried to copy files off of an old Apple developer CD (the March 1995 reference library, FWIW).

Step 1: Install hfsutils

I used MacPorts:

$ sudo port install hfsutils
--->  Fetching archive for hfsutils
--->  Attempting to fetch hfsutils-3.2.6_1.darwin_20.x86_64.tbz2 from https://packages.macports.org/hfsutils
--->  Attempting to fetch hfsutils-3.2.6_1.darwin_20.x86_64.tbz2.rmd160 from https://packages.macports.org/hfsutils
--->  Installing hfsutils @3.2.6_1
--->  Activating hfsutils @3.2.6_1
--->  Cleaning hfsutils
--->  Scanning binaries for linking errors
--->  No broken files found.
--->  No broken ports found.

And confirm that there is an installation:

$ man hmount
HMOUNT(1)                                                            HMOUNT(1)

NAME
       hmount - introduce a new HFS volume and make it current

SYNOPSIS
       hmount source-path [partition-no]

DESCRIPTION
       hmount  is  used  to introduce a new HFS volume. A UNIX pathname to the
       volume's source must be specified. The source may be a block device  or
       a regular file containing an HFS volume image.
...

Step 2: Get the device name

I inserted the CD and used the command-line diskutil tool to get the device information:

$ diskutil list
...
/dev/disk3 (external, physical):
   #:                       TYPE NAME            SIZE       IDENTIFIER
   0:        CD_partition_scheme                *783.1 MB   disk3
   1:     Apple_partition_scheme                 681.9 MB   disk3s1
   2:        Apple_partition_map                   1.0 KB   disk3s1s1
   3:                  Apple_HFS Dev.CD Mar 95   681.5 MB   disk3s1s2

So the partition I want to mount is /dev/disk3s1s2. You can see the same thing with the graphical Disk Utility:

Step 4: Mount the volume in hfsutils

$ sudo hmount /dev/disk3s1s2 
Volume name is "Dev.CD Mar 95" (locked)
Volume was created on Mon Jan 16 10:43:13 1995
Volume was last modified on Wed Jan 25 18:03:03 1995
Volume has 13074432 bytes free

Step 5: Get a directory listing

The hcd command changes directories. The hls command shows directories:

$ sudo hcd

$ sudo hls -l
f  APPL/dsi1    789111    488608 Jan 25  1995 Contents Catalog
f  ttro/ttxt       812      9259 Aug 18  1994 DEV.CD LICENSE
d          3 items               Jan 25  1995 On Location Indexes
d          2 items               Jan 25  1995 Periodicals
d          7 items               Jan 25  1995 Programs & Marketing
d         24 items               Jan 25  1995 Subject Index
d         12 items               Jan 25  1995 Technical Documentation
d         11 items               Jan 25  1995 Utilities
d         10 items               Jan 25  1995 What's New?

The -R option can be used to recursively descend through the directory tree:

$ sudo hls -lR | less
f  APPL/dsi1    789111    488608 Jan 25  1995 Contents Catalog
f  ttro/ttxt       812      9259 Aug 18  1994 DEV.CD LICENSE
d          3 items               Jan 25  1995 On Location Indexes
d          2 items               Jan 25  1995 Periodicals
...

:Technical Documentation:Inside Macintosh:
f  TEXT/ttxt       332       596 Jan 24  1995    Where is QuickDraw GX?
d          2 items               Jan 25  1995   Inside Macintosh Collections
d          6 items               Jan 25  1995  IM Addenda
d         10 items               Jan 25  1995  IM Errata
d         15 items               Jan 25  1995 Advanced Color Imaging (Draft)
f  ONLN/HLX2    275106  13193587 Oct 25  1994 AOCE Application Interfaces
f  btre/HLX2       286   4558848 Jun 20  1994 AOCE Application Interfaces.idx
f  ONLN/HLX2     84718   6067404 Oct 25  1994 AOCE Service Access Modules
f  btre/HLX2       286   1957888 Jun 21  1994 AOCE Service Access Modules.idx
f  ONLN/HLX2     95787   7030260 Oct 25  1994 Devices
f  btre/HLX2       286   2195456 Jul  5  1994 Devices.idx
...

Step 6: Copy some files

I’m going to copy over the Inside Macintosh: Devices book. It is two files of type ONLN and btre. These are for Apple’s DocViewer application, which only runs on Classic MacOS and has almost certainly never been ported to Mac OS X, but I’ll see what I can extract.

I will copy the files using “MacBinary” format, which is the recommended way to preserve the resource forks.

$ sudo hcd ":Technical Documentation:Inside Macintosh:"

$ mkdir ~/tmp

$ sudo hcopy -m Devices Devices.idx ~/tmp

Step 7: View the results

In the Finder, I can see the MacBinary representations of the files:

Double-click on the MacBinary files to unpack them:

Step 8: Try to open the files

Double-clicking the Devices icon fails, because there is no installed app that recognizes the format, but I can right-click it and open it in TextEdit, which is showing an unformatted text version of the contents:

Screen Shot 2022-05-11 at 12.46.01

There is a lot of binary data at the end of the file (I assume this is formatting and images), but at least this proves that the file was copied from the CD.

If I wanted to spend more time working on this, I could copy the “Apple DocViewer” application folder from the CD, transfer it to an emulator running Classic MacOS and use it to open the document, which I expect would work just fine.

Step 9: Unmount the volume

$ sudo humount

Then you can eject the disc.

12 Likes

David, thanks so much! Particularly for your obviously considerable efforts with hfsutils! Although I rarely use the TidBITS Talk facility, when I have I’ve been literally humbled by the response. I will work your suggestion, if I can, and let you know the outcome.
Humbly, Chuck Crawford

2 Likes

Thanks Will! No, the drive works with current formats no problem. ISO-9660: I remember this from the dim/distant past. You’re right, that is a possible help; I think finding an older mac and drive might be my most direct path. And thanks to David Shamino, I have a work-around on the command line. Thank you!
Chuck Crawford

Thank you Alan. You are so right about the “forever” discs. Forever has come and gone! I worked most of my life in photo and CE retail. We often discussed advising our customer to update their photo CDs to the next tech and also save them to hard drive. We tried to warn people, but most of us aren’t wired that way. We get something accomplished, like transferring movies to VHS, so when DVD comes along it never occurres to us to up date…we already took care of those old movies and we’ve moved on! Cheers!
Chuck Crawford

Very interesting! Thanks again. Reading through the responses I’ve gotten has reminded me that somewhere in a dark hole in my office’s vast closet, there may be my old 17" PowerBook! If I remember accurately (which seems, frankly, unlikey ;-) it worked when I put it away. I’m on that tomorrow! So nice of you to take time to help me. Thanks again David!

P.S. While having HFS drives is likely solvable I see from your contributions. Just not sure if these CD-ROM discs fall into the same category. I’ll find out soon enough…

I tried using VMware Fusion with an old System 7.5 CD upgrade disc from 1994 to see if it could be read and it does work in a Snow Leopard VM and a Mojave VM also. So if someone already has an older OS running in a VM, that would be the easiest way to mount these old discs.

Back in the old days when nearly every machine had an optical drive, my experience wasn’t so much that the discs would go bad but rather they could be read on some machine but not on others. So as another option, it might be worthwhile to pickup a $40 (or so) cd reader from Other World, Amazon, or the like, to see if a new device could access your CDs.

A quick run through a stack of old CD’s here showed that if the CD was HFS, Disk Utility would report that much, but not mount it. If the disk did not mount, but couldn’t recognize the file system, something else seemed to to be going on.

I’ve been battling this issue with DVDs I get from medical facilities. On my 2011 MacBook Pro running High Sierra (10.13) I could read both the medical CDs and DVDs. Disk Utility says the CDs are in ‘Universal Disk Format (UD)’ and the DVDs are in ‘MacOS Standard’ (probably HFS) format. When I was running Catalina (10.15) or Big Sur (11) on my 2019 MacBook Air I could read the CDs fine but the DVDs would give me the same error you’re getting (Disk Utility sees the disk but can’t mount it). To work around this I would open the DVD on my High Sierra MBP and create a new disk image (see below) that I could then open in Catalina on my 2019 MBA. However, I was quite surprised when I found I could directly open the medical DVDs without problem after I upgraded my 2019 MBA to Monterey (macOS 12). I am guessing that Apple included the HFS drivers in Monterey or some other magic that wasn’t there in Catalina or Big Sur. (I skipped Mojave.) If you don’t have an old Mac for the process below, see if you can find somebody with Monterey on their Mac who should/might be able to read the discs for you.

This is the process I used to create a disk image that was readable on Catalina:

  • Use an old Mac that can read the original CDs/DVDs.
  • Double-click the disc to open a Finder window containing the files on the disc.
  • Use Disk Utility>File>New Image>Image from Folder…, then choose the window with the files on the disc, click ‘Choose’. Choose Encryption = none, Image Format = compressed, specify a name for your new disk image, specify where you want it to be saved. This will be a Catalina-readable disk image.
  • When the new disk image is created, eject the disc, double-click the new disk image to be sure everything copied OK.
  • Use a USB thumb drive to copy the new disk image to your Mac running Catalina where you should be able to read it.
3 Likes

Thank you Nala(?)! Very useful information. It’s clear to me that I need to access an older Mac. Most interesting that updating to Monterey did the trick. I’ve been meaning to update for a long while, but so often that becomes a hassle, or worse, so avoidance is my “tactic.” You’ve now given me a reason to make the move. Thanks! I appreciate the time you took to reply.
Chuck Crawford

The easiest thing to do if you don’t have an old Mac is to install a Virtual Machine running something like Mojave which can still access those discs. The installers are available from Apple and you can get a free license for VMware Fusion Player once you create an account so it is a no cost solution. As I mentioned earlier, it works in Mojave and Snow Leopard virtual machines.

1 Like

Another option is to run MacOS 9 in emulation to access the CD-ROMs. Edward Mendelson has packaged up the SheepShaver emulator with a boot disk including useful utilities, and scripts to integrate with modern macOS systems so all you have to do is download and double-click the ‘app’.

This has the advantage of not requiring an Intel-based Mac (it’s a universal application), and also being fairly quick because of the much lower requirements for running MacOS 9.

Yes. A simple diskutil list command will show you whatever macOS thinks is in the CD drive, if it is readable. An HFS disc will show an Apple partition table and an HFS partition. Other format discs will show other things.

Are you sure? That sounds backwards. DVD and BD media uses UDF. CD-ROM does not. Older Mac CDs typically use HFS (“MacOS Standard”), while newer CDs use ISO-9660 plus some extensions for Mac-specific features.

There’s no technical reason why you couldn’t make an HFS-formatted DVD, but I’m surprised you’re seeing them. I didn’t think anyone was actually doing that.

Does this image work with physical CDs? The last time I played with SheepShaver, I could only access disk images, not physical media.

1 Like

The discs I’m reading (both CD and DVD) contain MRI, CT, X-rays, etc. images in DICOM format generated from a medical imaging company on a Windows machine. I have no idea what Windows medical software they use to create the discs so I’m not surprised that the Mac-readable volumes are ‘non-standard’ for Macs. I’m using an ASUS USB external disc drive to read the discs. I checked one of my DVDs and the Terminal command diskutil list produced this limited info (there’s no volume on the disc, only the disc):

/dev/disk2 (external, physical):
   #:    TYPE NAME      SIZE       IDENTIFIER
   0:    MRI_Disk_1       *1.0 GB     disk2

Disk Utility produces this info:

Volume type : Physical Volume
BSD device node : disk2
File system : Mac OS Standard
Connection : USB
Volume capacity : 1,016,754,176
Used space : 1,016,754,176
Media type : DVD-ROM

Checking one of my CDs with diskutil list produces:

/dev/disk2 (external, physical):
   #: TYPE NAME                       SIZE       IDENTIFIER
   0: CD_partition_scheme          *155.5 MB     disk2
   1:    CD_ROM_Mode_1  DRay3536    135.4 MB     disk2s0

Disk Utility produces this info:

Volume name : DRay3536
Volume type : Unknown
BSD device node : disk2s0
Mount point : /Volumes/DRay3536
File system : Universal Disk Format (UDF)
Connection : USB
Volume capacity : 135,440,384
Used space : 135,440,384
File count : 61
Disk number : 2
Partition number : 0
Media type : CD-ROM
Parent disks : disk2

I can confirm this approach. I had some 10-12 year old CD-Rs with data (photos) on them and they refused to even mount on my iMac running Big Sur. Just before giving up on them, I tried them (using the same external USB Superdrive) on my Sonos music server, an ancient Mac Mini running 10.8 (Mountain Lion) and they worked just fine.

I haven’t had a chance to try this. I thought I’d used SheepShaver to access old physical CDs several years ago, but it’s possible I’m misremembering. I tried a lot of things back then as I was trying to copy files with old Finder comments (stored in DesktopDB) which proved tricky.

The advantage of the MacOS 9 ‘appliance’ I linked to is that it’s quick to try as there’s essentially no setup, just download and double-click. But you’re right that it might not work as I envisioned.

1 Like