Grey boxes instead of pictures in Photos

I’m having trouble with an older photo library in Photos Version 7.0 (460.0.120). I opened it not long ago in the Photos that came with OS12.3 and everything was fine, but this time all I see are grey boxes in place of the photos:

Every photo is a gray box, and I’m assuming that the orientation of the photos is properly reflected. I tried again with the backup of the file but got the exact same result. My other larger library opened with no problem. I opened this library by holding down the Option key when I opened Photos and selecting it from the list. My initial round of googling suggested I try editing the photos one at a time, but this is what I got when I clicked the Edit button for one of them:

Screen Shot 2022-08-20 at 1.05.56

Has anyone else experienced this? Any idea how to fix it?

Ted. Ouch, that is frustrating. There may be an Apple Updater app but not sure. If necessary, you can still save your images, per Glen Fleishman. Hope this helps if it becomes necessary to do so. Best, Patrick
If the upgrader just won’t work with the old library, the only real solution is to crack open the library and extract ones photos.

  1. Control-click the iPhoto Library.
  2. Choose Show Package Contents from the contextual menu.
  3. Drag (to move) or Option-drag (to copy) the Masters folder to the Desktop or to another drive.
  4. Launch the latest version of iPhoto 9 and import that Masters folder. Or launch Photos and do the same.

Unfortunately, you’ll lose a lot of information associated with photos and video that’s stored within the library, such as metadata, potentially some edits, albums, and other organizational elements. But this is better than losing the high-resolution versions of your media.

1 Like

Would PowerPhotos be of any help in solving this?

Dear Patrick,

You taught me something critically important, the ability to view the underlying files using “Show Package Contents” in the photo libraries. It worked like a charm, so thank you!

Let me add that I checked the package contents for other photo libraries, and while many files are in the “Masters” folder, there are also files in the “originals” folder. (I cannot tell if there are any duplicates, the naming convention differs between the two: In the Masters folder, the names appear to be the ones provided by the camera, while the names in the originals folder are all base-16 numbers, all composed of 32 characters and 4 dashes, although duplicate files have an additional number.) FYI.

1 Like

Dear Alistair,

Thanks for your suggestion. Although Patrick gave me a solution to the problem, I’ll keep PowerPhotos in mind if Photos gives me more trouble.

Sounds like there’s some database corruption. Try opening Photos and immediately holding down Command and Option. That will give you the option of repairing your library.

1 Like

Dear Ace,

Thank you for your suggestion. That would have been the best solution if many of the photos in the library had been edited or the library contained a bunch of folders. However, since it was simply a warehouse holding original photos, I just created a new library and dragged and dropped the photos from the folder in the problematic library that Patrick told me about. It was a very simple, Mac-like solution. It’s worth noting that I’m also keeping the older library, in case something comes up missing later.