Free version of Fusion from VMWare

VMWare is offering a free version of Fusion Player for personal use. One does need to fill out a form, ironically it requires a company name. But you need to validate your e-mail address. I am using a ‘hide my e-mail address’ offered through Safari. But I never get the e-mail, oops, it was in Junk, why? However I have gone in circles trying to download it for ‘personal consumption’. When I hit the download button it wants me to log back in, then you’re right back where you started. Are there any tricks? I do see the place to buy the pro version for $199, and the Player version for $149.

The e-mail sent has link for contacting support. Click it, and I go to page where there is an obvious ‘contact support’ , clicking that takes me to the log in page again, and again you are right back where you started.


I posted regarding the free account a long time ago and when I acquired that, it was very easy to download. You have to set up an account as that is required. Maybe you’ve tried it but this is the page I bookmarked before:

Thanks for replying jk2gs. Tried the link you gave, nope, everytime it wants you to log in, and that take you back to the top level page. Navigating to the download page, again wants you to log in. But you can’t contact them to let them know there is a problem, as that route does exactly the same thing! I did delete my cookies for the page, maybe I need to clear all caches.

I did mine a year ago so I don’t recall the specifics. There are blogs on the site so you could try searching there for help.

Be careful with that particular link. It may forward you to obtain a Fusion 12 personal use license.

To get a Fusion 13 personal use license, use the following link:

You will need to be registered for a VMware account. For some reason VMware wants you to fill out a company name, title, number of employees, etc for a personal use license. . Just make them up, they don’t matter.


That’s the version I have which is what I use with Catalina.

phillman5 probably wants Version 13.

I used Cocktail to clear caches, that seems to have cleared up the problems I was having, I also cleared VMWare cookies.

Thanks All.

1 Like

Another issue I see a lot in the past year or so, is that if you’re using an adblocker, you probably need to use the “reload without contact blockers” option that you get when long-pressing on the reload icon in Safari. That can eliminate a myriad of issues like you’re experiencing, in my experience.