FIX: A software update is required to connect to iPhone - Fails to install

After a MacOS install or update the message “A software update is required to connect to iPhone” often appears. For some users after downloading the install fails with the simple useless message that the install failed. This issue has defied solutions for many with countless workaround posted. The first time I called Apple Support about this they were clueless and offered the standard clueless solution - erase your Mac and reinstall.

While many things are possible that could trigger this issue, the one thing that is super easy to fix it has never to my knowledge been published that always works for me. Here it is:

  • Open macOS System and choose System Preferences
  • Click on File Sharing
  • If anything is on, temporarily turn them off by clicking on their checkbox. If nothing is checked, this is not the issue.
  • Unplug and then plug in the iPhone
  • The software update message should pop up again. Click Install and be patient.
  • The software should download and install without issue
  • When completed, recheck the checkboxes you unchecked in File Sharing

That’s it.

Follow-up: After writing this I posted the issue on the Apple Discussions board with a link to Tidbits and this posting. Apple deleted it. They would rather have users with this issue continue to try to figure it out for themselves than have them get the solution from another reputable source.


I’ve never had this problem before, but it just cropped up in the last week or so, and I’d been ignoring it because I don’t sync anything to my iPhone or iPad over USB. Nevertheless, errors bother me, so when I saw @jweil’s post, I decided to try it.

I had just restarted, so I knew that wasn’t sufficient to resolve the problem, but when I turned off Media Sharing, Contact Caching, and AirPlay Receiver in System Preferences > Sharing and tried again, Monterey was able to install the necessary software update. Good one! I’ll do a short article about this soon.


Pleased to help. Have a wonderful holiday season.

THANKS!!! I’ve been struggling for weeks with this one… Can’t believe how you found this, THANKS!!!

So pleased it worked for you and for any others it may have helped. It goes back to one of my favorite quotes which is “When it comes to technology, we all are paying for the opportunity to be volunteer beta testers for the products we purchase, as providers rarely do the necessary testing to provide a solid reliable product before release in the myopic and narcissistic interest of maximizing profits for their executive management team and shareholders.”

2 posts were merged into an existing topic: A Fix for MobileDeviceUpdater’s “Installation Failed”