Finder won't show mounted external drives

I have a 2019 iMac 21.5, and I just upgraded to Ventura. I have two external USB drives (GUID Partitions). The drives are mounted, as Disk Utility confirms. Carbon Copy Cloner recognizes them, and backups run fine as they did before upgrading. However, the drives do not show up in the Finder, neither on the desktop nor in the sidebar even though the Finder settings are set correctly (and I’ve toggled them on and off). Running Disk First Aid does not help and reports that the drives are fine. Relaunching the Finder does not cure things, and neither does restarting. Unplugging and reattaching does not help. Is there a way to get the drives to show up in the Finder.

So just to confirm, when you say “the Finder settings are set correctly,” you mean that Finder > Settings > General has the “External disks” option checked, and Finder > Settings > Sidebar shows the USB drives in question in the Locations section, and their names are checked?

Thanks. Yes Finder > Settings > General has the “External disks” option checked.
Finder > Settings > Sidebar does NOT show the USB drives in question in the Locations section. The option to show them is checked but they don’t appear.
I plugged in a third usb external drive and that one shows as normal on both the desktop and in the Finder sidebar.

1 Like

Sorry I’m probably not helping directly, but it also occurs to ask: Can you open a Finder window on either of the problem drives? For example, Finder > Go > Go to Folder… and either enter a direct path (e.g., /Volumes/, or pick it from the “Go to:” list in the dialog (assuming it shows up)?

1 Like

While searching for ideas, I ran across this article. You can set the “hidden” flag on a volume just like you can on a file. Doing so will make it invisible to the GUI.

Could it be that this flag somehow got set on these external volumes?

You can check by typing:

$ ls -lO /Volumes

Any special flags associated with the file will be displayed between the group and size fields. It will be a dash (-) if no flags are present, otherwise it will show them.

If the hidden flag is set, this should remove it::

$ sudo chflags nohidden /Volumes/MyVolume

(replacing MyVolume with the name of your disk). Then restart the Finder to see the change (Ctrl-Option click it in the Dock. Then select Relaunch.)

2 Likes

I have experienced this. I mistakenly clicked on a drive in the Finder sidebar and accidentally dragged it out of the sidebar when I didn’t intend to do that.
Then the drive would not show up anymore in the sidebar.
After a few attempts to make it show up, I realized what had happened.
I don’t remember what I did to cure the issue. Probably I searched online for “show drive in sidebar”?
I might have dragged the drive icon from the desktop to the sidebar.

Have you tried dragging the drive back into the sidebar from the Computer window in the Finder? As described in solution 1 on this page:


Pasting the steps from the above page here in case it disappears one day:

  1. Open up a new Finder window on your Mac by clicking on the Finder icon in the OS X Dock.

  2. Press “Shift + Command + C” to go to the top level of your Mac. Here, you’ll see all mounted hard drives and network shares. Simply locate the hard drive that is missing from the sidebar, and drag it back.
    Enable-Missing-Hard-Drives-Drag-To-Sidebar

Thank you all. Unfortunately none of these methods fix the problem. To recap: the external drives do not show up on the Desktop nor in the Finder sidebar. (So can’t be dragged from anywhere as they are not anywhere).
I also tried shutting down, detaching the drives, restarting. re-attaching the drives. No cure. However, now Disk Utility no longer has a grayed-out Mount/Unmount tab, and I can unmount and mount the drives. I ran Disk First Aid again and all is fine, it says. Also Carbon Copy Cloner recognizes the drives and can reveal their contents in the Finder. But that is the only access I have to the drives’ content.
The drives were attached when I did previous system upgrades. The current problem reared it’s head when I installed Ventura.

Check out @jzw’s post above again. Desktop and Finder sidebar are just GUI proxies and things can be missing there even though they’re still mounted and ready to go.

But if a drive is mounted you would always expect to find it at the top level of your Mac. Open a new Finder window and hit shift-cmd-c (Go > Computer) or in any existing Finder window just hit cmd-up until you reach the very top level. A mounted drive (that isn’t hidden) will show up there.

If the drive doesn’t show up there but you’re sure it’s mounted, what do either of the following say about it:
Terminal: ls -al /Volumes/
System Information (in /Applications/Utilities or via opt-click in Apple menu where About This Mac… resides) > Storage
System Information > Hardware > USB

1 Like

I tried going to the top level of my my Mac several times and the drives will not show up. I know they are mounted as I have access to their contents thru Disk Utility and Carbon Copy Cloner. I realize it’s a GUI problem. Could the drives have somehow gotten hidden, and if so how to fix when I can’t get a Get Info screen? System Info shows the drives as mounted. I have tried to attach a screen shot.

So, as above, what flags does Terminal report for these two mounted volumes?

ls -lO /Volumes/

This is unlikely, but since none of the obvious suspects are working…

Run the following command in Terminal. It may require you to download Command Line Tools for Xcode, but if so you will be prompted to do so and MacOS handles the download and installation for you.

GetFileInfo -av "/Volumes/Backup One"

This will print a 0 or 1 on the next line in Terminal. If it’s a 1, that means the Finder’s “Invisible” bit is set. To remove it, run:

SetFile -a v "/Volumes/Backup One"

If you get some sort of permissions error, you might need to run this as root:

sudo SetFile -a v "/Volumes/Backup One"

Terminal says it can’t install Command Line Tools for Xcode.

Thanks. The sunlink flag is the “system-undeletable” flag. When applied to a file, it means the file can’t be deleted, even by the system. I’m not sure what it means when applied to a volume or its mount point.

But that’s probably not the cause of your problem My CCC backup volumes (and my system’s root directory) also have this flag and I can see them in the Finder (on Big Sur). I think it’s part of the mechanism Apple uses for combining System and Data volumes into one hybrid file system (and would therefore also be present on backups).

See also:

Can you take a screenshot of the error message it displays?

Screenshot 2022-12-16 at 12.38.27 PM

Two things you can try:

  1. Run the following in Terminal: xcode-select –install

  2. Download the installer from https://developer.apple.com/download/all/?q=xcode%20command

Downloaded installer worked. Ran script you gave above. Result is below. Zero not 1

iMac21:~ Rob$ GetFileInfo -av “/Volumes/Backup One”
0

1 Like

Very puzzling. It might be worth contacting Apple support.

1 Like