Finder sidebar feature gone in Ventura?

I just updated my 16" MacBook Pro 2019 from Monterey to Ventura 13.4.1. Mostly smooth, and I’m back at work.

BUT a sad surprise was that one of the features I’ve relied upon for years appears broken. Posting here to see if this is a known fact or do I need to fiddle with some system settings or permissions.

The broken feature is the ability to drag a file on top of an app alias in the Finder sidebar (“Favorites”) and have that app open the dropped file. When I try this now, I just get a circle with a slash through it as I hover over the alias, as in “no can do ma’am.” It works fine if I use the Dock for dragging/dropping instead (far more inconvenient for me), but not in the Finder sidebar.

I have a number of utilities that work best by drag-dropping onto their icons, and often use it to quickly focus on a particular app instead of a huge menu of Open With choices. For example, drag-dropping any number of filetypes (XML, EPUB, IDML etc) on top of a BBEdit icon.

I told this to a few people who’ve been using the Mac as long as I have and I guess not many people use this feature. You just Command-drag and drop any app into the Favorites section of the sidebar and the Mac makes an alias of it, just as it does with folders.

That still works in Ventura, but not the drag-dropping a file on top of the icon to open it.

Any help?


I’m running a Mac Book Pro 2021 with 13.4.1. I didn’t have any app aliases in the Favorites section of the finder sidebar so I made a quick one for PDF Expert by clicking on applications and then command-dragging it to the favorites section. It flawlessly allowed a drag and drop of a PDF file and opened that file.

Maybe you can remake one of the app alias to see if that fixes the problem.

Hi, and welcome.

I just tried it here (MacBook Pro 16 inch 2019 macOS Ventura 13.4.1) and dragging a text file to the BBEdit icon in my Finder sidebar Favorites works fine.

My guess would be that somehow your application alias got broken during the update.

Have you tried deleting the icon from the sidebar and repeating the command-drag of BBEdit and see if it works?

1 Like

ah! okay. Yes I’ve repeatedly removed and re-done the aliases I’ve been using. Hrm. Restarted the computer and everything. Anything else to try?

I just tried testing it in my test admin account which is plain vanilla, but it doesn’t work there either! Frustrating! I get the same no access icon when I try to drop a file on an app alias.

Tried creating a new test admin account in Ventura, but same (non-working) results! It will not let me drop a file on an app shortcut in the Finder sidebar.

I have to walk away from this for now. I’m not sure what else to try.

I’m seeing the same thing on my MBA with 13.4.1. I did get a Preview alias to work once, but was never able to get a BB Edit alias to work, and now I can’t get the Preview one to work anymore, either. Relaunching Finder (e.g. Force Quit) didn’t get it to work, either.

(That said - this is the first time I’ve ever done this.)

I have the same setup as you.

I have never put an application alias in the Finder sidebar before (I use the Dock instead), but when I do, I get the same results as you.

My guess is that it has something to do with permissions. Is “rebuilding permissions” still a thing? Or maybe I should try selecting everything in my Apps folder and changing all their permissions.

If I right-click on my BBEdit app alias in the Finder sidebar and choose to Get Info, under Sharing & Permissions it says “You have custom access.” And for me (my account) and Staff, Permissions is set to Read & Write, and for Everyone it’s set to Read Only.

Those of you who have it working, could you take a moment and let me know if your Permissions are different than what I just described (for one of the app aliases that works)?

I think it’s the same here.

Just for kicks, if you open BBEdit and then choose File>Open… and then try to navigate to and open the same file that you’re trying to open by dragging in the Finder, does it work that way?

Conversely, if you pick [Apple menu]>System Settings… and select Privacy & Security>Files and Folders then look under BBEdit, are Desktop Folder and Documents Folder enabled?

I’m running from an administrator account also; that might make a difference.

Thanks, Ron. I’m on an admin account too.

Yes, BBEdit can open that file type from its File > Open menu. It can also open it by dragging and dropping a file onto its icon in the Dock, and to its icon in the Finder toolbar at the top, my less-than-ideal workaround for now (I also have shortcuts to Sigil and eCanCrusher, an EPUB extraction utility):


I too get the forbidden sign. It appears as soon as the file I want to open enters the sidebar. I have used BBEdit to test. Clicking on BBEdit in the sidebar launches it, so that functionality works.

Ventura 13.4.1 MacBook Pro M1 Max.

BBEdit works that way for me in 13.4.1 on an MBA M2. I wondered if the issue was that the file type was set to some other default application, but it worked for the jpg I tried which is set to Preview as a default.

One more data point, in case a pattern might emerge: MBP M1 Pro, Ventura 13.4.1. Logged into admin account. I put a new alias to Preview in the Finder sidebar Favorites group, and then dragged a .jpg file onto it. Preview launched and successfully displayed the file.

Same here.

I usually never have apps in the Finder sidebar, but I tried it just to see.

Put Preview in sidebar (M1 Pro 14" MBP, 13.4.1) and was able to drag PDFs and PNGs onto it just fine with the expected result. Also tried it with an older copy of MS Word and was able to drag both .doc and .docx onto that without trouble.

Is it possible this is an issue related to BBEdit? I don’t have that (anymore) myself so I can’t test.

Thanks Simon. Weird.

It’s not limited to BBEdit, no. It similarly doesn’t work with Preview, InDesign, Books, etc. But in all cases those work fine when in the top Toolbar area of Finder windows, or in the Dock, or on the Desktop.

I’ve not found one instance where it works in my Favorites sidebar.

Could it be I’m still on an Intel machine? That would be bizarre.

Just to check, I restarted in Safe mode: Same problem. I ran Disk Utility, the disk is healthy.

I have the same issue on an M2 MacBook Air. As I said above - it worked once with a PDF dropped on an alias of Preview. It hasn’t worked since. It never worked with an alias to BB Edit. I’ve tried removing and re-adding an alias - that hasn’t worked, either. Logging out / in or restarting hasn’t fixed it. Clicking the alias opens Preview (or BB Edit). I can drop onto any folder target in the Favorites area of the sidebar. I just get forbidden when I try to drop on one of these aliases as well.

I just tried on my 2019 intel iMac - same thing. It never worked.

Thanks. I’m going to have to walk away from this for now, with no answer I guess. I know for sure it worked 100% of the time until a few days ago when I upgraded to Ventura.

I appreciate everyone’s help! Good to know, sorta, that it does work sometimes for some people.