Finder Issues in 13.2

Does anyone else find it hard to unmount disks? Both network shares and USB-C disks will refuse to disappear from the desktop, no matter how many times I press Cmd-E. If I use the Terminal I can sometimes see the disk has been unmounted, but it’s icon is still on the desktop. The only way to get rid of that is to relaunch the Finder, but since 13.2 if I try to do that the Finder does not start up again and I have to restart the whole Mac. Simply logging out gets stuck and then I have to hold down the power button to force a shut down. This morning I completed to backups to external disks and CCC was supposed to unmount them. The icons stayed, and Terminal said the disks were gone, so I just unplugged them. Later today I was taking pictures with a USB microscope and saving them to the desktop, but they didn’t show up. Saved them again, and I was asked if I wanted to replace them? So again I relaunched the Finder, and again it did not restart. Shut down and restarted, at which point the photos were on the desktop and I got a [disk] was not ejected properly notice from one of the backup disks this morning!
And tonight I had another wi-fi failure. Refused to connect to any wi-fi router. Turned wi-fi off and on again, no better. Logged out and in - no change. Restarted, and all worked again. Now to be fair that is a trick this M1 MBA has been pulling since it was new, not just since Ventura.
I’m about ready to go back to Pathfinder!

What command are you using to determine this?

I would use Disk Utility. Either the GUI one or the command line one.

It’s been my experience that the Finder does not show accurate information about whether or not a disk has been mounted. In my case, if I eject a drive, the icon goes away from the Finder pretty quickly, but the drive remains in use (its activity light is blinking a lot) for almost a minute. Disk Utility doesn’t change its indication (volume name goes from black to gray) until all that activity stops - which is when it is really safe to disconnect.

In your case with the Finder hanging on restart, I’ve generally seen this when there is a misbehaving storage volume or interface. Typically if a drive is not working right. I’ve also seen it when using a USB expansion card (this was on an old Mac that had slots) wasn’t entirely compatible with the system.

The symptoms you’re observing are not normal. If your computer has been doing this since it was new, then you may have had a problem from day-one. Maybe it’s your backup drive (if you always leave it connected). If the problem happens even when you boot without the backup drive, then I’d consider reinstalling macOS (after making a backup, of course) to see if that changes anything. If not, then you may want to contact Apple support (especially if it’s still covered by warranty or AppleCare).

I use:
diskutil list

I downloaded Forklift 3 last night and it seems to have no issues kicking off a disk on demand. It not only disappears from a Forklift window, but disappears from the Desktop too (unlike Pathfinder, Forklift leaves the Finder running and makes no attempt to replace the Desktop with one of its own.)


Path Finder will leave the Finder running and does not create its “own” Desktop unless you make some changes in the prefs - it is not it’s default behavior.

I know, I used versions 7 and 8. The Pathfinder desktop was useful, though I had to leave the Finder running for Time Machine to work.

I have this problem, and it dates back to previous OS versions, and occurs on an M1-based Mac AND the Intel iMac Pro (so it’s not an Apple Silicon problem, or just a Ventura problem).

The difference I’m seeing is that it ONLY occurs with servers mounted while using my work VPN.

Force-quitting the Finder (which won’t relaunch until the next step), then using Activity Monitor to force-quit anything with the letters VPN in it restores the Finder without the need for a restart.

I know the server I’m connecting to is running Windows server software, and the problem is Apple’s implementation of SMB protocol. But there doesn’t appear to be anything that can be done.

As has been mentioned, Finder is particularly sensitive to file systems that take a long time to respond.

Maybe mounting a remote file system over the VPN is introducing enough latency that it starts misbehaving in the same way it does with a flaky local storage volume.

When you say you are mounting servers while using the VPN, where are the servers located? On the corporate network (accessed via the VPN) or are they local (on your LAN)?

If it’s the latter, you might be seeing network timeouts as macOS tries to send packets to the VPN, gets timeout responses, and then tries to send them to your LAN.

If the server is local, then how is your VPN configured? Many corporate-access VPNs block access to all other networks (including your locally-connected LAN) when the VPN is connected. Although I would expect this to prevent mounting the volume altogether, not letting it mount with flaky behavior.

Or is this a local server that’s mounted before the VPN connects? If so, the act of connecting the VPN may result in blocking access to your LAN, so the server is no longer reachable, with all packets getting dropped and the file sharing protocols producing timeout errors.

If your VPN can support a “split-tunnel” mode, where packets not meant for the corporate network are sent directly to the destination (without going through the VPN), see what happens when you connect in that mode. (Note, however, that many corporations explicitly disable this capability because it is often considered an exploitable security hole, so you may not have this option.)

I connect via VPN to servers located off-site. We’ve tested this extensively and contacted Microsoft directly. It’s definitely a problem with Apple’s implementation of SMB. My Windows box, connecting to the same servers using the same VPN setup doesn’t exhibit any issues at all.

The latest Windows OS server update improved things quite a bit, but the problems still occur - just less frequently.

My problems continued with that M1 MBA, with the Finder locking up and refusing to relaunch. I tried running EtreCheck Pro, and it would freeze up during the ‘Checking Hardware’ stage, then refuse to quit, at which point the Finder would freeze up and a forced restart was needed. I wondered if a new version of EtreCheck was needed and asked the developer, who kindly looked at the report from the one recent time when it did run right through. He felt it would not be a hardware problem and suggested disabling the Finder extensions. The only ones enabled are those installed by the OS - Markup, Contacts suggestions, etc.
At this point I was having these freezes/kernel panics several times a day and I switched to using an older MBP 13" 2017 (very smooth with a CCC Data backup and the Migration Assistant). All has gone well until writing this post - as I switched to System Settings to look up the extensions, everything froze, screen dimmed, but no multi-lingual announcement of the panic. Forced restart and now I carry on, though no offer to send a report to Apple because “Your computer was restarted because of a problem.”
I suppose I should try to wipe the M1 MBA and reinstall the OS, then laboriously upgrade it back to Ventura, but the last time I had to do all that (my wife’s Intel MBA, it would not proceed beyond a certain point in the install and the machine is useless - I documented all that here) so I’m not hopeful. No doubt Apple will be delighted, as I’ve ended up ordering an M2 MBA.

While I’m waiting for the M2 MBA, and finding out how slow the 2017 MBP feels, I decided there was nothing to lose at this point by re-installing macOS from the Recovery Disk. It offered me Ventura, which was nice, and said it would take 13 hours plus, which was not. In the end it took about six, and so far it has behaved. Network disks dismount instantly now, and I haven’t yet had and freezes/panics.
Looks like it will become a spare for my son to inherit when he next needs a replacement.