Failing screenshots

Apple’s built-in screenshot has been failing to work on an increasing number of websites. More and more often the usual Command key combos just generate a link to the webpage instead of saving an actual screenshot image.

I’ve tried a couple of apps from the App Store, but they fail in the same way – or don’t really work at all. If you know of an app that fixes this problem, I’d be grateful if you would post it here. TIA.

Please post links to a few of those problematic web pages so others can check to see if they have the same problem.

1 Like

exactly. Please give us some examples because I have not encountered this, ever

What version number of macOS?

And what keys are you pressing to create the screenshot? It would be helpful if you could list step-by-step what you are doing and what results after each step.

Like others, I’ve never seen this (and don’t know how the screenshot system would even know what the URL of a window on the screen is). You’re not using Safari’s share feature to try and share a PDF of the page by any chance?

iMac 10.15.7. Firefox 97.0. Here are the first three sites I went to; all behaved the same way, i.e., no successful image grab.

Hmm. I see that the two of the three images appeared in my last post. But none showed up on my mac as a screenshot. I think there’s a clue-thingie there somewhere. And BTW, Cmd(4).

Here’s what happens: 1) Cmd(4), 2) small version of the image appears then disappears in the lower right of my screen, 3) notification at the upper-right of screen that the link to the internet address of the image has been copied to the clipboard, and 4) no screenshot image appears.

Just used Brave web browser; same result as with Firefox

notification at the upper-right of screen that the link to the internet address of the image has been copied to the clipboard

It sounds like you have some third-party screenshooting software installed, something like CloudApp, SnagIt, Loom, etc. It may be an open application in your Dock but more likely it has an icon in the menubar.

I don’t know why you would get the URL for a webpage in the clipboard instead of what the notification says you should have, a URL to the image saved in some cloud location.

These are macOS’s screenshot commands; Shift-Command-3 to for the entire display, Shift-Command-4 to get crosshairs and draw a rectangle (or press spacebar to select the window underneath your cursor).

small version of the image appears then disappears in the lower right of my screen

macOS’s screenshot feature does do this and the files are saved to your Desktop by default.

1 Like

I using Monterey and couldn’t get any window to be captured using shift-command 4 (I have the image open in Preview). However, I normally do all screenshots using shift-command-5 which allows the flexibility to do a full screenshot, a window, or an area of the screen. It also clearly lets you change the Save option (all via a pop-up at the bottom of the screen). I had no problem capturing any window using it. Note that the default is whatever you did last; so, if you are taking a series of screenshots, it takes no more effort than using shift-command-4.

Try XNIP in the Mac App Store. Faster, easier, and more powerful than Apple’s combination of keys. Includes annotation, file naming, and blurring of personal information plus a lot more. Use it constantly. Not expensive, one time purchase. 5 STARS.

Pretty sure I found the problem: DropBox is hijacking the screenshots and routing them to its folder. A workaround might be an alias on the desktop to its screenshots stash.

Didn’t know about Shift-Cmd-5 or XNIP. Thanks to both of you and to everyone who offered advice.

Case Closed.

3 Likes

That explains it! Apparently you can disable this behaviour in the Dropbox “Import” preferences by unticking a box labelled “Share screenshots using Dropbox”.

I just use Shift-Command-5.
All of my options are there. I pick what I want. Done.

Thanks again for all the suggestions.