External HDD taking very long to eject


(Simon) #1

I have two identical 2 TB disks I use for TM backups. They’re both seated in identical USB3 docks. One’s at work, the other at home. I’ve analyzed both with DiskUtility and both disks apparently are fine. But the one at home takes ~20 s to eject while the other ejects within 1-2 s max. There’s no open files and TM has completed entirely by the time I eject. No drive light’s flashing either so I assume the disk should eject fairly quickly. But it isn’t. Both disks have lots of free space, about 1.1 TB. Any ideas how I get the home disk to eject a bit faster?


(Al Varnell) #2

Disk Utility does a reasonable job of evaluating and fixing directory and partition problems, but is woefully inadequate at finding hardware/firmware issues until total failure occurs.

Either of these two utilities (and probably a couple of others) will give you better idea of whether or not the drive is “failing” by doing an analysis of the S.M.A.R.T. parameters instead of just reporting the results of the last self-test:

Neither are free, but they do have trial periods. If the drive is USB connected, you will probably have to install the SMART SAT driver that I believe is now included with both.

-Al-


#3

G’day Simon

I use 500GB Samsung T5s (formatted APFS encrypted) for my Time Machine and Carbon Copy Cloner backups. They all eject instantaneously.

I’ve also got a couple of 16GB Kingston DataTraveller 100 G3 USB 3.0 sticks. One of them is currently formatted APFS encrypted and the other is Mac OS Extended (Journaled). They both take “an eternity” to eject – 5+ minutes is not unusual. Then the “couldn’t be ejected because it’s in use” message comes up (even after quitting all apps well before hitting the eject button). Click on Force Eject and it takes another couple of minutes. I’ve reformatted them in various configurations to no avail. Reading from/writing to them also feels only marginally quicker than USB 2 speed. However, put them in a different computer and they read/write quickly and eject fine.

No problems with any other USB sticks I happen to use on my iMac.

All of which leads me to suspect that particular make/model of USB stick just doesn’t want to play with my 2017 iMac. Could be a similar compatibility thing between your drives and your computer.

Cheers, Gobit


(Simon) #4

Thanks, Gobit. The formatting, the disks, and drive docks are all identical so it strikes me as odd that there’s such a difference.

Like you, I have also experienced thumb drives that are rather slow. I’ve always just assumed that’s a sign of a cheap drive. Although I recall in one case the thumb drive did perform better when formatted as FAT instead of HFS+.


(Tommy Weir) #5

There’s also CheckMate a menubar utility which monitors drive health from Micromat, the makers of TechTool Pro


(Simon) #6

I have to admit I’m a bit skeptical that it’s the HDD hardware. The HDDs are both almost new, they’re quality stuff from a reputable brand I’ve been using for many years with no issues. With the disk that takes so long to eject there’s zero odd behavior otherwise.

I was wondering if there’s some kind of caching or indexing going on that macOS thinks is necessary for some reason on one disk, but not the other. But both disks are set to be ignored in TM and in Spotlight so I don’t really believe that should be causing it.

I also know the disk is actually doing something while I’m waiting for it to unmount. The drive light is flashing and I can hear the head moving while I’m waiting so it’s obviously trying to read or write something. I’m just curious what that is. Maybe something I should try is lsof.


(Al Varnell) #7

OK, but trying to do something can also mean a failing disk. Takes only seconds to check after installing one of those utilities I mentioned.

An easier way to find out what’s going on than lost is “What’s Keeping Me” (donationware)

http://www.hamsoftengineering.com/products/wkm/wkm.html

-Al-


(B. Jefferson Le Blanc) #8

I recommend you try the work disk on your home computer and your home disk at work. Don’t assume that because they are identical that they are, in fact, identical. Also switch out the docks. If your work and home computers respond the same with both drives—and docks—this will eliminate the drives and docks as the source of the problem. If it’s not the drives, then the trouble lies with your home computer.

If the problem appears to be at home, you can reset the PRAM. Sometimes the I/O functions get confused. Restart with the Command, Option, P and R keys depressed; hold them down until the computer starts again. This may take a little time so don’t get impatient. The PRAM reset will, among other things, reset the electronic circuits for your USB and Thunderbolt ports, which may improve drive performance.

If the problem persists, restart in Safe mode and test again. Hold down the Shift key and keep it depressed. Older versions of the Mac OS would give you a message that the computer was starting in Safe mode so you could release the Shift key. The manOS offers no such clue so you will have to hold down the key till the progress bar is roughly two thirds across. Safe mode does some behind the scenes component tests and maintenance and excludes all third party startup items and gives you a relatively bare system. It will eliminate third party extensions and background processes.

If you still have a problem, What’s Keeping Me may help you narrow down the problem further. But if the slow eject continues you may want to take it into an Apple store to let them troubleshoot it for you. Your Mac may still be under warranty if you bought Apple Care. Don’t let them put you off by saying the long eject times are normal. They are not. Be pushy it you have to. It will also help if you can tell them all the tests you’ve tried before bringing it in. If you made a good-faith effort to solve the problem yourself they may be more inclined to help you, especially if no warranty applies.


#9

Dead logic board – bizarre sequel, long story.

Last Sunday I turned my iMac on, it boots up and the log-in screen appears. Keyboard and mouse both function perfectly. Enter my password, desktop appears, both keyboard and mouse stop working. Bluetooth icon in menu bar has wavy line through it. A few minutes later wavy line disappears and keyboard and mouse start working again. End of the day I shut down.

Monday, the same thing happens. Hmm. Attach keyboard via Lightning cable and an old Apple Optical Mouse via USB. Restart, log-in screen appears, keyboard works fine as does Optical mouse. Red laser light on mouse is on. Enter password, desktop appears, Bluetooth icon has wavy line, keyboard stops working, mouse stops working, red laser light on mouse goes off. Some 3 – 5 minutes later, red laser light comes back on, mouse and keyboard start working fine.

Hmmm:

  • Log in to my trouble-shooting user – same problem – wavy line through Bluetooth icon, USB connected keyboard and mouse only start working again 3 – 5 minutes after desktop has loaded.
  • Trash Bluetooth preferences – no change
  • Run Disk Utility First Aid – makes no difference
  • Run Apple Diagnostics – apparently there’s nothing wrong
  • Boot into Safe Mode – same problem
  • Boot into Recovery Mode – neither wired or Bluetooth keyboard nor mouse work even after 15 minutes
  • Reset NV RAM, then SMC – makes no difference
  • Try to boot from Carbon Copy Cloner created clone on portable SSD connected via Thunderbolt – will not boot (worked fine a week earlier when I tested it). Boot from internal drive and after 5 minute wait for keyboard and mouse to start working again, attach the SSD – it mounts fine and I can access al the files on the drive.
  • Redownload macOS and install over the top – to no avail.

First time I’ve seen something like this in 20 years of using Macs. Time for the call to Apple Support.

Service Adviser has never come across this before either and escalates to Product Specialist straight away. He’s never seen this before. Has me boot into Recovery Mode again. Can’t do anything once in Recovery Mode because neither keyboard nor mouse will work even after waiting 10 minutes. Product Specialist books me into Authorised Repair Agent (sadly still no Apple Stores in New Zealand).

Engineer scratches his head, this is a completely new one to him. Leave the machine with him to run his diagnostics. Get a phone call a couple of hours later – he can’t run his diagnostics because he can’t boot from anything externally nor use Target Disk mode. Engineer orders replacement logic board.

Engineer rings this evening. He’s replaced the logic board and everything’s working fine again – I can pick up the machine tomorrow.

We’re all still bamboozled at the how and why.

Cheers, Gobit