Did Apple break Find My on Big Sur?

I’ve noticed that for a few weeks (months?), I have not been able to use the Find My app on my Mac (running Big Sur). I can find all my devices on my phone (running the latest iOS), but when I use my Mac, I get the following error:

Screen Shot 2023-05-15 at 12.03.17

And almost all of my devices and friends report “location unavailable” on the map.

Ordinarily, I’d assume this is a server problem, but my phone has no problem. And this has persisted for quite some time.

My working theory right now is that Apple changed the back-end of the Find My server in a way that breaks Big Sur, and they chose to not upgrade the Big Sur app to remain compatible.

Does anyone here know for sure? Maybe a press release or other Apple announcement?

Yes, I need to upgrade this Mac. I’ve been planning to upgrade to Monterey since December, but I haven’t gotten around to it yet. I’m still uncertain about whether I want to run Ventura at this time.

Find My seems to work on my MBA M1 running macOS Big Sur 11.7.6. At the very least, I do not get the error message you posted, and I do see my Items and some Devices. (Interestingly, one Mac reports “No location found - Online” even though it’s in the next room and connected to the same network, and an iPad reports “No location found” but it is not in use, although Wi-Fi is on.)

I hope this helps.

I’m a bit confused that “almost” all your devices and friends report location unavailable if Find My is unable to connect to the server. Would your Mac make direct contact with some devices or friends?

The Mac find the location of my phone. But I think it’s a cached location, since it is reporting the last location date as April 18th.

Everything else (people, devices, including the Mac itself, and my AirTags) report “No location found”.

I have Big Sur on a remote computer; this one is not logged in to an Apple ID itself. I just connected - Find My from the web worked perfectly fine.

Find My is working perfectly in Big Sur on my iMac18,3, for all people, devices and items. All update immediately with time now.

I tried a bit of packet snooping with Wireshark. All of the data exchanged is encrypted (HTTP/TLS), but I was able to determine the destination IP addresses and servers for each and how each connection ended.

For what it’s worth:

  • One SSH/TLS session (configuration.ls.apple.com, accessed via an Akamai server) opened and closed normally. It received some spurious packets after the session closed, which my Mac (correctly) rejected by sending TCP-reset packets for the port.

  • Several sessions (p116-fmfmobile.icloud.com, p116-fmipmobile.icloud.com, gateway.icloud.com, p116-caldav.icloud.com, p49-mailws.icloud.com and gsas.apple.com) all opened during the time of my test and didn’t close afterward.

    I assume these sessions were created by various background services. From the names, these look like two Find My servers, a calendar server, a mail server and two whose purpose isn’t obvious from the names (gateway and gsas).

  • Two sessions (both to gsa.apple.com) moved a bit of data and then received an encrypted TLS alert from the server. The session was then immediately closed. I suspect this might be the cause (or at least a symptom) of the problem, but I have no way of knowing what the alert was, since TLS session content is all encrypted.

Does anyone here know what that gsa.apple.com server might be for?

On a hunch, I decided to sign out from my Apple ID, reboot and sign back in again. Find My is working again.

I may never know what was wrong, but at least it’s working again.

Thanks for those who pointed out that this was not a software incompatibility issue (as I suspected), which made me start looking for ways to fix it.

I’m glad it’s working now.

That’s a hunch that often does not occur to me. Thanks for the follow-up; it will help me remember to reset things (logout and login; restart; sign-out and sign-in) when anomalies occur—which they do, all too often.