Deleting Files (and Emptying Trash) Doesn't Free Up Space

MacBook Pro (15-inch, 2017), 16 GB RAM, macOS High Sierra (10.13.6), 1TB drive

I’m puzzled. I’ve used Macs for a long time (Apple IIs before that) and don’t recall having this problem … ever. I have put off upgrading from High Sierra for long enough. I don’t think I have ever been this far behind on upgrading. At any rate, I know that I need to have at least 35GB of free space on my drive and I really want more.

Over the last few weeks, I’ve worked to move files to an external drive, to get rid of files, to delete 32-bit apps. I was doing some of that manually, but then had a chance to install CleanMyMac with our church’s 5-station license. That was completely unhelpful. At one point, CleanMyMac said it was clearing out 25+ GB of stuff and I ended up with less free drive space than before.

Last weekend, I decided to work really hard to get this done. I copied 27.45GB of document files onto an external drive, did a random check to make sure they copied correctly, then deleted those files from my laptop. I only gained about 10GB of free space.

Later, I copied 126.45GB of “home movie” files to the external drive, deleted and trashed those movies from within iTunes, emptied the trash and it made absolutely no difference in the amount of free space on my internal drive.

Yesterday, I copied 4.72GB of movies to an external drive, then deleted them from iTunes. I started with only 6.99GB of free space on my hard drive; after emptying the Trash, I only had 7.73GB of free space. I ran Clean My Mac to clean out “Junk Files” and then CleanMyMac/Maintenance/Free Up Purgeable Space and ended up with only 7.09GB of free space. This morning, the Finder is showing 8.43GB of free space.

I have logged out and logged back in, I have rebooted multiple times, I used CleanMyMac to try to clear out iTunes junk. All to no avail. I should have 150-200GB of free space on my drive, but it’s stuck at a much smaller amount.

I really feel dumb. What am I missing that I should be doing? It appears that something must be writing files back to my hard drive or Trash isn’t actually cleaning out files.

I don’t have an overall solution but some of the applications have an internal “deleted” folder that your photos stay in for as much as 30 days before they are gone. That is so you can recover a delete moment. You have to go into the deleted folder and remove them a second time

Take a look at your drive with something like GrandPerspective or OmniDiskSweeper. That should show you if there’s a large blog of something that’s eating your space.

Hmmm… Is the computer using APFS? (it should be on an SSD drive with High Sierra). I wonder if they are Time Machine local snapshots that are taking up space?

See Glenn Fleishman’s article here: How to delete Time Machine snapshots on your Mac


This is the most likely culprit. Time Machine makes hourly snapshots of your internal file system (if it is formatted APFS). So deleted files will still be consuming space in those snapshots.

The Time Machine snapshots automatically age-out, so only the most recent 24 hours (one per hour) are retained.

So after deleting those files, you may expect to see the free space become available 24-25 hours later.

If you need the space immediately, you can manually delete the snapshots instead of waiting for them to be deleted on schedule.


The Time Machine backups may be a good place to start.

iMazing (iOS backups) can eat up space in a similar way as it backs up iOS devices similar to how Time Machine does for macOS. Using About This Mac > Storage > Manage… is not always helpful as it will often lump TM and iMazing backups into the “System” category. If you started making backups on the boot device and then move to an external, there may be old backups left behind, claiming storage space.

If you use iMazing, just be sure you only delete backups from WITHIN iMazing or things could get interesting.

Thank y’all for the suggestions. It’s taken me a bit to get back to this thread, partly from time constraints and partly from working through your suggestions. Unfortunately, nothing has changed. Let me run through what I’ve done — this is a bit long. I’m running High Sierra (want to upgrade, which is why I’m trying to free up space) on a 1TB drive in a 2017 MBP:

  • As I initially said, I had deleted 131GB of movies and home movies from iTunes — copied them from my internal drive to an external, deleted the movies from within iTunes, and emptied the Trash. After doing that, I gained about 10GB of hard drive space. I cannot figure out what happened to the other 121GB of space that should have been freed up.

  • Using Glenn Fleishman’s article and some others that I found, I searched for Time Machine snapshots — using “tmutil listlocalsnapshots /” from Terminal didn’t show any Time Machine snapshots at the time. There was one from, I think either TechTool Pro or Carbon Copy Cloner, and I deleted it — no change in free space.

  • I did check and empty the “Recently deleted” folder in Photos, but there wasn’t a whole lot there. I didn’t find that for iTunes.

  • I had used GrandPerspective before to try to locate large chunks that could be deleted — that’s what clued me in to how much space “Home Movies” were taking up. I ran GrandPerspective again and the Home Movies don’t show up, but I still don’t have that space free. Right now, GrandPerspective shows that my Photos library takes up the biggest single chunk. That still doesn’t account for the space that should have been freed up by deleting Home Movies.

  • One thing GP showed me was that an old (2019) _CCC SafetyNet folder was taking up 43GB and a file called InstallESD.dmg was taking up 6.1GB. After some research, I decided I could safely delete those. That was a process:
    — I moved both the SafetyNet folder and the Install ESD file to the trash
    — The Finder wouldn’t delete those by emptying the trash (I didn’t expect it to do so, but tried). CleanMyMac wouldn’t delete them either, despite the claim that it would overcome any OS objections.
    — I restarted into Internet Recovery mode, disabled SIP with a Terminal command, and then restarted onto my hard drive.
    — I was able to empty the Trash, supposedly deleting those files (they were cleared out of the Trash).
    — I restarted again into Internet Recovery mode, enabled SPI, and then restarted normally
    — When I started that process, my hard drive showed 11.94GB of free space. After deleting those files, the Finder (and Disk Utility and About This Mac —> Storage) showed 11.81GB of free space!!!

In all my years of using Apple II and Mac computers (since 1986), I have never had this much trouble or this kind of trouble.

  • After a little more research, I decided to restart back into Internet Recovery mode and to run the First Aid portion of Disk Utility. I got an error message: “error:snap_metadata_val object (old 0x11bca0z): invalid extentref_tree _old(0x0)” — I’m having a bit of trouble reading my own handwriting on that error message and am not 100% sure about the very last part, “_old(0x0)”. Disk Utility then said, “Restore original state found as mounted. Operation Successful.” When I restarted back to my hard drive, nothing had changed as far as free space.

Is it possible that that error points to my problem? If so, any idea how to correct it?

The real puzzle to me is why deleting multiple GBs of files makes no difference in free space and, sometimes results in less space than I had before deleting the files.

This entry at stackexchange discusses a similar problem. They also had the same error (note that it is “oid” not “old”). Their are several useful suggestions but the best ideas require erasing and reformatting the drive then reinstalling system and data files.

CCCSafetyNet? Do you use Carbon Copy Cloner? I wonder if you have turned on safety net for your boot volume (which is not the default for CCC)?

If you are using CCC, see Leveraging Snapshots on APFS Volumes | Carbon Copy Cloner | Bombich Software - maybe that will help. There is even a description in that document that talks about available disk space not going down when you delete files and then empty trash. (Though that document also suggests that the _CCCSafetyNet folder(s) would be deleted when the disk was converted to APFS, so maybe not.)

I do use Carbon Copy Cloner and early on in trying to figure this out, I wondered if CCC was keeping copies of deleted files. In Preferences, “Enable snapshots on APFS-formatted, SSC-backed volumes” is selected, but when I click on my internal drive in CCC’s sidebar, CCC Snapshots is OFF. I did find a 3-year old CCC Snapshot folder that I deleted … with no change in free space.

Thanks a bunch. Great discussion on StackExchange. I ran the “df -h /” command in Terminal and it showed roughly the same free space as did the Finder and other utilities.

However, the shocker was when I ran the du command — “sudo du -cxhd 1 /” command. That showed that I am really only using 501GB of space on my 1TB drive!!!

I dread doing it, but erasing, reformatting, and reinstalling seem to be my only options.

If I erase and format the drive and then restore from a CCC full backup, will that simply reintroduce whatever error(s) exists? (I’m guessing “Yes”, but hoping for an easier solution than dealing with reinstalling applications and data and losing certain information like “Open Recent…”.

TechTool Pro has long had an option to save deleted files in a hidden directory. Make sure that is disabled in the System Preferences->TechTool Protection->Trash History.

What happens if you run the same commands on the CCC full backup? That should give you some idea if the clone has the correct or incorrect size.

I should have made a final comment a month ago. It turned out that there was a corrupted file. I ran Disk Doctor while in recovery mode and it couldn’t repair the disk (I don’t remember the specific error). I ended up erasing the hard drive, installing Monterey (that’s why I was trying to free up space in the first place), and then restoring all my data. In the end, I had the 400GB of free space that I knew I should have had.

Thanks for all the help.


Thanks for letting us know. Do you recall what the corrupted file was or what program it was related to? Glad you were able to get it all working again.