DATE to go back to install El Capitan

Hello: I ran into a problem on an imac. Was running Yosemite. I wanted to install Mojave but couldn’t til I installed El Capitan or other OS. Got a message that packages were no longer available.
Could you please tell me what date to set the clock back to make this work? Thank you
Evidently, I can’t even start the imac from Yosemite any more. It goes to El Capitan install and around in circles that cannot install.
For now, I am stuck.

I don’t think I’m following exactly what you have done here. Are you trying to use an older copy of the El Capitan installer that you stored away or did you follow the steps outlined in and downloaded the corrected version as directed in Step 4?

When it starts up in the El Capitan installer, can you not just quit the installer?

The date to use an older copy is Oct 23 or earlier, but not sure how you will be able reset it.

1 Like

Yes. You’re fine in understanding my issue. Now that the iMac won’t boot correctly back to Yosemite, I’m stuck. I tried starting up with the option key, and the start up disk window shows nothing. Thank you for the date. I went to the link you gave me. My mistake was not changing the date before I copied an older copy of El Capitan. I had been successful in previous iMacs because I changed the date prior to installation.

So it sounds like the installer somehow executed it’s first stage which copies itself to your boot drive and that’s the only thing currently blessed to launch. I’m surprised that it was allowed to do that, all. The expired ones I tried wouldn’t even execute that first step.

You can probably boot into Recovery and use Terminal to deleted those files, but I’m not confident enough that I know what and where they are to instruct how that could be done. And deleting things in Terminal still dangerous, even when you know exactly what to do. It is probably worth trying to boot into. Recovery, Quit and see if you can select Yosemite as your startup drive.

You’re are correct Al. The install began and then I got the message that basically, couldn’t go any further. In the past this issue never occurred. I have used the option key to start again. When this is done, there are 3 options to choose. At the moment, I can’t recall the exact words so when I try again, I will ask you for your opinion. The one option I tried would take me to the apple store for verification. Prompted by Apple, I would type in my friend’s Apple ID and password. Then when it came to the 2 step verification, I have not been able to go further due to my friend’s timing since the code goes to her iphone. I did see the “recovery hd” and when I clicked on that icon, I got message that it was “locked.” I am hoping that when my friend and I are in sync with the verification purchase, I am able to install the correct El Capitan. Thank you for your feedback. It helps alot.

You’ll want to boot into macOS Recovery, Tori, not start up with the Option key down. That just gives you a choice of boot drives.

Read this article for details about macOS Recovery:

and then this one for the different keyboard combinations for getting specific versions of macOS:

1 Like

Hi Ace. When I tried that, no start up drive showed up in the window. Strange thing that it would continuously boot with El Capitan only and then gave me message that there was an error with packages?? That’s why I asked what date, if I can boot from another drove, then change the date. Am I making sense? I’ve never had this problem before having done plenty of Same procedure. Al gave me a link to a newer El Capitan download which I am doing now. .

The recovery option - when I clicked on the icon said it was “locked”

Hi Al: I am working on this today. Thank you for your help. I couldn’t boot up to Yosemite again. So, I used another start up on a flash drive and I deleted the OLD El Capitan to see if I could restart in YOSEMITE on the drive. I restarted and STILL I got that message that El Capitan packages were not there! Darn!

Should I ZAP THE P RAM? opt, command, P R
What do you all think?

Al, Thank you. I did download the NEW el capitan that you sent to me via the link. Am I correct to assume that THIS COPY will allow me to get over the packages issue and install EL Capitan to this mac?

When you boot into Recovery, you get a window that lets you restore from backup, reinstall macOS, get help online, or launch Disk Utility. You should be clicking Reinstall macOS. Is that the point where no drive shows up?

If all else fails, and assuming you have a backup of the data on this system, of course, you could use Disk Utility to erase the disk, and then reinstall from scratch and restore from backup.

I believe it will, although as I think I said before, I’ve never experienced your issue nor known of anybody who has.

Thank you Al and Ace for your assistance. I got thru the process by changing the date in terminal. I am relieved and thankful. I had not run into this issue before having done many updates on several macs installing older OS systems.