DAS RAID 1 - Read/Write speeds

Hi friends,

I bought an OWC Gemini RAID, and populated it with 2 - 18TB Seagate EXOS drives, in RAID 1 for redundancy. The DAS has Thunderbolt 3.2 and is connected to my Mac Studio. Checking System Report I see that I’m getting 40GB/s via the ports. When I run Black Magic Speed Test, I get 286 MB/s write speeds, and 152 MB/s read. This seems so unusual, as I’ve always gotten much faster read speeds than write, and I have no idea why that wouldn’t be the case in this instance.

When I run Black Magic on my 6 year old G-Tech RAID with 2- 6TB drives, I get 210 MB/s write, and 207 MB/s read using Thunderbolt 1. How can the read speeds be faster on the older G-Tech drive using Thunderbolt 1!?

I contacted Seagate and they didn’t have an answer, and punted me to OWC, which is where I started originally. The first person at OWC blamed Seagate. The 2nd person at OWC is investigating, and will be getting back to me tomorrow, as they didn’t have any specs on their drive in RAID 1, claiming that most people use it in RAID 0.

Any ideas on why I’d get such unusual read speeds on the OWC Gemini?


@TallTrees Do you know the RAID chipset inside?

According to OWC’s web site:


  • Thunderbolt (2): Intel JHL6540
  • Media Reader: Genesis Logic GL-3227
  • USB (2): Fresco Logic FL1100EX
  • Ethernet (1): Intel i210
  • SATA Controller: ASMedia AS

And what speeds do these two support? (you probably need to investigate at INTEL and ASMEDIA’s website)

According to OWC, in RAID 0 I’d be getting speeds upwards of 900MB/s with SSDs, and 500MB/s with spinning drives. They don’t have any specs on RAID 1, but generally it’s about half the speed of RAID 0. This morning OWC told me that my speeds are within spec, but have no explanation for the huge difference in read/write speeds.

I can’t explain the diff either, but I can add this:
You HD is presumably this one? https://www.seagate.com/files/www-content/datasheets/pdfs/exos-x18-channel-DS2045-4-2106GB-en_GB.pdf

We need to take into account that drives have different speeds for

  • read/write from disk (the platter) to the SATA interface
  • and then onward from SATA to (in your case) TB.

TB offers quite some headroom, in RAID 0 both drives talk to the TB interface, hence you get much more in RAID 0.
The Seagate data sheet mentions “Max sustained Transfer Rate OD” OD stands for outer disk. Seagate also names Random Read/Write 4K QD16 WCD in IOPS. Random is a realistic scenario, QD16 = QueueDepth 16 maybe not when you transfer big files. WCD is Write Cache Disabled, if it’s ENABLED you get much lower random write performance. Is maybe the write cache enabled in this DAS system?

Maybe this helps you to get closer to an explanation of the discrepancies you see.

1 Like

In RAID 1, you should expect write speeds to be roughly equivalent to that of a single drive, because every block you write needs to be written to both drives. Assuming the RAID controller can actually write to both drives at once (any controller that isn’t garbage should be able to), then you get the performance of a single drive.

When reading, however you should see speeds about double the speed of a single drive, because the controller should be able to read different blocks from different drives. For example, if you’re reading a file that is 30 blocks, it should be able to read 15 from one drive and 15 from the other (buffering it in a RAM cache so your app sees it as a single sequential read of 30 blocks).

But there are many different brands and models of RAID controller chips, and some definitely perform better than others.


Agreed, which is why I’m genuinely surprised at the disparity that I’m seeing with this particular OWC Gemini RAID. I swapped out the 2 - 18TB drives and popped in 2 - 4 TB Western Digital RED drives, and got similar discrepancies using both Blackmagic and AJA System Test.