Contacts treating numbers with country codes as different

An issue that’s been driving me crazy for quite awhile now in Contacts is that a recent iOS update/upgrade changed things so that any given 10-digit phone number is treated as a completely new number if it has the +1 country code prepended!

For example, these two numbers are treated as unique numbers!?!:
(101) 555-1234
+1 (101) 555-1234

Why on earth did they do that?? I believe it only occurs in iOS/iPadOS, but I haven’t tested it extensively to confirm. I’m not running Ventura on my Mac yet either…

Those two are different numbers and should be treated separately. If you’re calling from the +1 region (US and Canada), then there is no effective difference.

But if you’re calling from another country, the first example will try to dial that number for the country where you’re located, while the second will ensure that it is placed as an international call to US/Canada.

Yes, of course, but for users in the US, it’s simply ridiculous that I have to have both in that person’s contact card! And it never did that before, that I can remember. Or is it that the cell carriers now all default to adding the +1 to every number? Whatever the case, it drives me nuts having to fix it all the time…

1 Like

I travel out of the country enough that I’ve put the +1 in many of my contact phone numbers.

When I traveled to Europe a few years ago, it did that. I had lots of “duplicates.” When I got back to the states, numbers would fail to call if they had the +1 in front of them.

It’s not a new problem. I can’t remember what triggered it. I used a foreign sim card, so did installing that add the +1? I didn’t make many (any?) calls while in Europe as I mostly just used data. It was such a rare thing for me that it wasn’t worth figuring it out.

The mobile service providers don’t do anything. The place the call using whatever digits you provide. The presence or absence of +1 in your address book depends entirely on how you created the entry.

Really? Sounds like your service provider had (hopefully doesn’t still have) a critical bug in their system. I’ve been prefixing my address book entries with +1 for years and Verzion has never had a problem with it.

2 Likes

I beg to differ, David. As far as I can tell, all callers that aren’t in my contacts come in with the +1 prepended. I have no way to affect that. I’m on Verizon in SW Colo, FWIW. The same appears to go for the Messages app, so long as they’re 10-digit numbers to begin with. So the problem comes when calls/texts come in from someone already in my contacts, but without the +1. Those aren’t recognized as coming from the person in my contacts, simply because I haven’t gone through my almost 4K contacts and added the US country code to everyone in the US!

This is hugely annoying, and seems like an unnecessary ‘glitch’ (and one that didn’t exist only a year or so ago too).

The caller ID number you see on incoming calls is 100% determined by what the sender’s network (whether land-line, mobile or VoIP) provides. Individual/residential customers typically get some default (which may or may not have a +1 prepended). Businesses that run their own PBXs may configure their systems to send other values, again with or without a +1 prefix.

And scammers have long been able to forge caller ID to show anything.

As for what goes into your address book, as I already wrote, it depends on how you are creating the entry. If you tap on the button to add a number to your contacts from the call history, then it will default to the caller ID for that call (unless you edit it, of course).

Most of my contacts were manually added. Mostly through Google’s web page for Contacts, but some via Apple’s Contacts app on my phone or Mac. If I type in a +1 prefix, the entry will have it. If I don’t, then it will not.

If the caller ID format for incoming calls has recently changed, that would be a function of their service provider. Your provider is simply going to pass along whatever the call-originator provided and that’s what iOS is going to display if it doesn’t find a match in your contacts.

I’m not sure why we’re not understanding each other here David. Of course I get that what’s in a contact I created is how the number will be dialed; that’s not the issue. The issue, as I described in my last post, is that a call coming in from one of my contacts won’t be recognized as that person simply because it has the +1 prepended! This did NOT happen in the not-too-distant past. Now I have to either have both numbers in my contacts (with the +1 and without) or go through and add the +1 to every US-based contact. I simply should not have to do that!

In short, here in the US, why can’t my phone recognize a caller who is in my contacts simply because the call is coming through with the country code added (and I don’t have the country code added in that person’s contact card)??

Does having “Dial Assist” turned ON on your iPhone (Settings > Phone) do anything?

Here in the UK, our numbers are:
local: 7123 4567
national: 020 7123 4567
international: +44 20 7123 4567 (sometimes written as: +44 (0)20 7123 4567 or +44 (0) 20 7123 4567)

(No one really dials/lists numbers using the local these days, so ignore that one.)

In my Contacts list, phone numbers for 2 UK hotels and one French one. For the UK (London) phone numbers, the formatting is +44 (0) 20 9999 9999. For the French (Paris) phone number, the formatting is +33 (0) 1 99 99 99 99.

As I was writing this, I checked the Wikipedia articles on phone number formatting for the UK and France. The French system is pretty consistent with the area code consisting of the one digit (after the leading zero used for local calling), but the British system is crazy with anywhere from 2 to 5 digits after the leading 0 being the area code, and the individual portion correspondingly decreasing from 8 to 4 digits, with formatting changing depending on the length of the area code.

This sure makes parsing phone numbers a real challenge, dwarfing the issues presented in North America.

True. Larger cities tend to use smaller codes (eg. London 020 or Birmingham 0151 [fixed, see below!]), with smaller cities/towns/villages using larger ones (eg. Brighton 01273 or Peterborough 01733), plus special numbers. But then we have the same number for all mobile’s (i.e. 07xxx), so it’s swings and roundabouts on easily identifying the type of number you’re calling!

  1. 01 or 02 - geographical (an actual place, local rate)
  2. 03 - non-geographical (local rate)
  3. 07 (always 5-digits 07xxx) - mobiles
  4. 0800 (sometimes 0808) - freephones
  5. 084, 087, 089 (eg. always 4-digits, 08xx) - non-geographical medium priced (typically <£0.50/m)
  6. 09 (always 5-digits 09xxx) - non-geographical premium priced (typically >£0.50/m)
  7. 118 (always 6-digits 118 xxx) - directories

05 used to be freephones (now defunct), 04 & 06 never used, other simple numbers 999 or 112 emergency, et al.

As a UK citizen, you pretty much know the pricing by the number (1. to 4. typically included in talk plans, while 5. to 7. charged extra).

Now you have learnt all that? Good! ;-)

1 Like

You’re right about UK numbers, which come in a myriad of forms. London numbers are nearly always written incorrectly: 0203 147 2916, for example, rather than the correct 020 3147 2916 (probably because we’re used to 3-digit 4-digit local numbers in larger cities).

Fortunately, formatting doesn’t really matter much. The French make life interesting for anyone not accustomed to their idiosyncrasies by giving the digits of their phone numbers in pairs as numbers, so 74 99 23 15 would be spoken as soixante-quatorze quatre-vingt-dix-neuf vingt-trois quinze.

(Minor point, Jim: Birmingham is 0151. 0161 is Manchester.)

FWIW, I’m not seeing the same behavior as you. All the unknown callers (around 80) in my Recents list have the +1 prefix in the recorded Caller ID string. So either the phone is adding those to the received Caller ID string (and as you said, this seems to me to be a recent change), or those prefixes are actually in the Caller ID string. However, for me, all inbound calls that do match a contact are being matched successfully, and none of my contacts’ phone numbers have the “+1” prefix.

I should add that all of my recent phone activity has been exclusively US phone numbers. And my carrier is AT&T.

I have Dial Assist turned on. I supposed I could try turning it off…

Not that it’s important, but you still frequently see local numbers listed in more ‘remote’ regions (eg in the past year I’ve seen this in Skye and Orkney, previously in parts of the Highlands).