Contacts Smart Group NOT Working (SOLVED)

I have the following Contacts Smart Group

Birthday Soon
Birthday is in the next 1 day

It finds some cards with birthdays within the next day but not others. For example, today is March 2 and it finds three Cards with birthday on March 2, two of which have years and the other has no year. However, there are actually six Cards with birthdays today, meaning that the Smart Group is not finding three.

If I change the condition to Birthday is set, these missing cards are found.

This Smart Group used to find all birthdays within the next day. Why did it stop?

Is there a way to reset a Smart Group? I tried deleting Birthday Soon and creating a new Smart Group with a different name, but the new one also does not find the same cards.

Thank you for your help.

SOLUTION May 9, 2024 9:17 PM

Solved by:

  1. Rebuilding the Spotlight index, and
  2. Changing ‘is in the next’ to ‘is within.

As you can read in this Apple Community Discussion thread, rebuilding the Spotlight index seems to have helped, but some Contact Cards are still not found by my Smart Group.

Can you think of any other things that I can do to reset this Contact Smart Group?

Thank you.

Yesterday, March 4, two people with birthdays on March 5 were included among the Cards selected by my Birthday Soon Smart Group.

Today, March 5, the Cards of neither of these people with birthdays on March 5 are selected by Birthday Soon.


I don’t have an answer for you, but I read your Apple Discussions post, and the error when starting your shell interests me:

Last login: Fri Jan 5 12:12:44 on ttys000

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit
Argus-2:~ nello$ 
 [Restored Mar 3, 2024 at 3:46:46 AM]
Last login: Tue Feb 27 09:49:50 on console
date: illegal time format
usage: date [-jnRu] [-r seconds|file] [-v[+|-]val[ymwdHMS]]
      [-I[date | hours | minutes | seconds]]
      [-f fmt date | [[[mm]dd]HH]MM[[cc]yy][.ss]] [+format]
-bash: Saving: command not found

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit

This means your shell’s startup script (~/.profile or ~/.bashrc, most likely) has a bug in it. It appears to be trying to call date (to read or set the clock), and there’s a mistake there.

The subsequent line (Saving: command not found) also bothers me. That means the word “Saving” (probably text you meant to output or write to a file) is being executed as if it was a shell command. Again, this strongly implies an error in one of your startup scripts.

If you’re executing an auto-generated script, it may be that the code used to do that auto-generation may have errors and started generating code with errors.

I had the wrong operator; I should have used is within, NOT is in the next: