Contacts not syncing when using Wi-Fi or USB cable

Very frustrating bug, as there has been no indication that Contacts have not been syncing during my weekly backups.

Back story–years ago I tried using iCloud to sync contacts and it was a disaster, numerous duplicates, missing contacts etc. so I gave up and have been manually syncing my Contacts between iPhone & laptop (currently an iPhone 13 mini and a MacBook Air M1) during my weekly iPhone backup, using either wifi or a direct USB/lightning cable to connect the phone & laptop. It’s worked perfectly well for years.

(edited some confusing language that wasn’t helpful)

I recently realized that despite completion of Step 4 in the 5 step backup process–“Syncing Contacts”–no syncing is actually occurring. I’ve done new test contact cards on both laptop and phone to double check, and each time after “Syncing Contacts” has completed, neither database has changed. What was created on the phone Contacts app stays on the phone, and what was created on the laptop Contacts app stays on the laptop. :rage:

Any ideas what’s going on and how I could fix this?

I’m confused…you are not using iCloud for syncing, right? So I’m not sure why people would give advice to sign out of iCloud if it isn’t playing any role in your syncing problem.

Sorry, yeah I see how that’s confusing. All the recommendations I can find on Apple’s help sites involve doing something that involves using iCloud to sync. All I was trying to do was emphasize that iCloud isn’t involved here…my apology.

I also rely on a wired connection to sync contacts between my iPhone (currently iOS 17.4.1) and Mac (currently macOS 13.6.6).

Have you checked the sync settings? To do this on my setup, after connecting my phone via USB, I select the New Finder Window menu command in Finder’s File menu. Then in the sidebar, under Locations, I click on my phone. Then in the Info tab on the screen that also contains the Sync button, I have the "Sync contacts onto ‘phone name’ " checkbox checked and the “All groups” radio button selected for Sync.

Note that there is an option to force the phone to replace its entire Contacts file with the Mac’s Contacts file (“During the next sync, information on this iPhone will be replaced with information from this Mac.”).

Yes–all the steps you’ve noted are in play on my setup, using iOS 17.4.1 and MacOS 14.4.1.

I’ve tried unchecking the “Sync Contacts onto iPhone” button and then re-checking it in hopes of resetting whatever preference file that controls this, but no change.

As I said, I’ve been syncing my Contacts this way for years with no problem. I can’t say for certain but from looking at the un-synced cards on each device, I’m fairly sure this happened when I upgraded (semi-forced!) from Big Sur to Sonoma.

I’ve managed to export each set of contacts as a .pdf so I can eventually make sure I have all contacts match, but that’s a bit more pain than I hope to go through for now.

Well, I went online with Apple Support 2 days ago, the agent seemed to understand exactly what my problem was but after going through the standard steps (up to date OS’s, verifying I was using manual sync correctly) she said that while she wasn’t completely certain, most likely it was due to the latest versions of the operating systems expect that Contacts will have iCloud syncing set to be On.

So, after going through my 2 databases (using export to pdf) and comparing, then backing everything up…I turned on iCloud for Contacts.

It’s working fine, so far. A few duplicates to clean up & merge, but as far as I can see nothing has been lost. And it’s definitely easier to have them syncing more or less instantly behind the scenes.

My inner Luddite is staying quietly behind the scenes for the time being :innocent:


Halfsmoke, you actually DO have Contacts syncing over USB under Ventura? Is Calendar syncing working also?

I haven’t had either working reliably under either Ventura or Sonoma.

What port are you using on your Mac, ThunderBolt, USC-C, USB-A, etc.? (Haven’t seen any difference between ports here, but curious…) Thanks.

Intel Mac=>USB-A=>powered USB hub=>USB-A-Lightning cable=>iPhone 13
Intel Mac=>USB-A=>powered USB hub=>USB-A-USB-C cable=>iPad Air (5th generation)

Thanks. I wonder what significance Intel Mac might have?