Colormunki Display not seen on 2019 MacBook Pro

Hi there, I’m a professional photographer and it’s hugely important to me that I keep my displays color calibrated. I do this by using an x-rite Colormunki Display, which has a USB-A connector on, and thus I have to use an Apple USB-A to USB-C adapter, as this allows me to calibrate my Mac Studio and 2019 MacBook Pro. Both computers are running the same MacOS (13.0.1) and the same version of ccStudio. When I connect the Colormunki Display to my Mac Studio, the software sees the device and I can profile the display. However, using the same hardware, when I connect it to any of the 4 USB-C ports on my MacBook Pro, the software does not see the device. When I then go to System Settings → System Report → USB, I see the Colormunki Display listed on on the bus. I’ve even tried using a different Apple USB-A to USB-C adapter, but I get no joy.

Any suggestions on why the ccStudio app might be failing to see the Colormunki Display on my MacBook Pro, and what I can do to resolve the issue?

Just a SWAG, since I have never used any of the products you mentioned, but does the ccStudio app install any kernel extension? If so, perhaps it hasn’t been installed on your laptop?

Go to System Preference → Security & Privacy to see if there is a button asking for your authorization to install a kernel extension. See also Kernel extensions in macOS - Apple Support

If there is no kernel extension involved, perhaps there is a background app that needs to be running. See Open items automatically when you log in on Mac - Apple Support to view the set of login items. If the Mac Studio has a login item for ccStudio, then make sure the MacBook Pro has the same login item.

Could it be a license/activation issue? If you require two licenses to run ccStudio on two computers, do you have them? If so, do the two computers require separate license keys? If so, are they using the right ones?

If none of the above helps, I would contact the support people for ccStudio (or a user forum, if they have one) to see if this may be a known problem and if there may be a fix/workaround available.

When I use my Colormunki it’s using its own application to do the calibration not anything from Adobe.

Has something changed since I bought mine?

Not sure where you got the notion that I was using any Adobe products. x-rite sold their color calibration to a company named Calibrite, and they now make and maintain the software and hardware.

Have you tried to reinstall the driver and have System Prefs open to OK the driver installation (and allow install from outside of the AppStore)? It is running ok on my Studio (like you) and I just tried to install it on my 2020 MacAir and it ran OK. Do you usei1Studio?

David, thanks for all of the various solutions. I appreciate your time and effort!

One of the first things that I did was to check the permissions in Security. I’ve had this problem off & on for a several months. When I was running Monterey, I might have to plug/unplug once or twice for the MBP to recognize the Colormunki, but it would ultimately work. With Ventura, I’ve yet to be able to get it to work on the MBP, but it works just fine on the Mac Studio running the same versions of the OS and ccStudio software. I’ve even removed and reinstalled ccStudio, after downloading the latest version.

Checking the permissions on both computers, I don’t see an ask for the software to be added to any of the security panels.

The only background app/service is a reminder that runs in the menu.

I have an email into Calibrite (the manufacturer) in the hopes that they can help with me with the issue.


Ray, since x-rite sold the products to Calibrite, I’ve been using some version of i1Studio, and it’s worked reasonably well, even on my MBP. Today, while poking around on Calibrite’s website, I saw that they have a new application called ccStudio that supports the Colormunki Display, so I download it, removed i1Studio, and installed ccStudio. It appears the be the same thing as i1Studio, but with a different name. It still doesn’t see my Colormunki, even after a reboot. Weird!

Sorry. Every time I see the letters cc together…

I found this article: Calibrite: Learning → Technical FAQs (English) → Device Connection Issues.

Their suggestions are:

  1. (Re-) Install the XRD device drivers

  2. There is a known problem with some computers and USB 3.0 ports. The hardware device is USB 2.0 and there seems to be a problem connecting it to a USB 3.0 port on some computers.

    They suggest using a powered USB 2.0 hub as a workaround. Alternatively try using a USB port on your monitor.

1 Like

David, thanks for looking this up, and pointing it out! That’s very, very kind of you, and I appreciate it!

I’d previously uninstalled, downloaded, and reinstalled the ccStudio software (which also installs the drivers), but got no love. I just tried it again, and got the same results.

The Colormunki has been working with this MacBook Pro for years, so it’s very frustrating to me, that it would suddenly and inexplicably stop working. I guess I’ll have to see if I can find a powered USB 2.0 hub. Or, I guess I could also try plugging my MacBook Pro into my Mac Studio Display, and trying the software that way.


I plugged my MacBook Pro into my Mac Studio Display, and then plugged the Colormunki into it. I can see the Colormunki Display on the USB bus, but the software still doesn’t recognize that the device is plugged in. So very strange!

May be time to buy a new device.

Definitely time to contact their customer support. You may be seeing a problem they haven’t encountered before. If they have good support, then hopefully you’ll be able to work with one of their engineers to diagnose the problem so they can fix it.

I reached out to them yesterday morning via email (which unfortunately is the only way to contact tech support), but have yet to receive a response. I’m waiting with bated breath! :grinning: