Chrome not putting downloaded files to my desktop

Recently, when I download a PDF file to my Desktop, Chrome indicates it has downloaded to my desktop but the file is not there. The file can only be read in Acrobat Reader but it never appears on the Desktop. How can this be remedied?

Are you sure Chrome is configured to download to your desktop? Most browsers default to the “Downloads” directory within your home directory.

Go to Chrome’s settings and double-check the download location. If it’s not set to your Desktop, you can change it to that location.

See also:

True. I checked that many times and it always says “Desktop.”

is it downloading to your iCloud desktop or your local desktop? I found that it was downloading to my iCloud desktop and then change it to my local as I didn’t need the items in iCloud.

Ah ha, That could be it. Now to figure out how to reconfigure iCloud desktop to local Desktop. Thanks!

I’ve seen this sort of behavior occasionally since Mojave, at least. I will be able to find the file using various approaches (Spotlight, EasyFind, etc.), but it will not actually appear in a Finder window until a restart or a few minutes have elapsed. Even opening a new window is not always sufficient. (I do not use iCloud’s “optimize storage” feature.)

Good question.

For those looking for it, the “local desktop” is /Users/username/Desktop

The “iCloud desktop” is where you end up if you click on the iCloud Drive icon and then double-click the Desktop icon within, which (at least for me) is /Users/username/Library/Mobile Documents/com~apple~CloudDocs/Desktop

Another thing that just occurred to me. The Finder sometimes gets out of sync and may not show every file saved to the Desktop. You can try restarting the Finder (Ctrl-Option-click Finder in the Dock, then select Relaunch).

You might also try opening the Desktop as a Finder window. Open a Finder window and then click “Desktop” from the left-side margin or (if you have that link disabled), Select Go->Desktop (Cmd-Shift-D) to view the desktop folder’s content.


When this happens to me it’s because Hazel moved it after Crome downloaded it but I don’t suppose that you have Hazel installed.

I’ve experienced this a few times too, where something won’t appear on the desktop itself, but does appear in a window set to show the Desktop folder. I usually restart and it goes away.

I am using iCloud Drive’s Desktop & Documents Folder syncing, so it’s possible that’s related. When I save a file from the iPhone to the Desktop folder, I sometimes have to open the Desktop folder in Files to nudge iCloud Drive into showing it on the Mac. Since all my saves are part of shortcuts, I just add a step to open the Desktop folder in Files which triggers the nudge.

FWIW, I am not using iCloud Drive’s Desktop & Documents Folder syncing, but I still see this problem occasionally.