Catalina users, are you seeing external hard drive disconnects?

A friend is having trouble with his Time Machine drive being unexpectedly disconnected in the middle of the night for no apparent reason. The problem is new in Catalina (didn’t happen in Mojave), and it occurs whether the drive is in a USB 3 or Thunderbolt 2 enclosure. Some others are seeing similar disconnects with external hard drives (not necessarily Time Machine drives), as documented in this Apple discussions thread. This is the first I’ve heard of it, so I doubt it’s particularly widespread, but is anyone here seeing this problem?

I am seeing occasional failures of ™ backups, cause unknown. I’ll find a notification on the screen in the morning of a failure, and when I check Time Machine, it is running just fine.I am backing up to an external USB 3 2.5" drive. I also run a SuperDuper clone operation every night to another USB 3 2.5" drive, and have had no problems with that, so I don’t know what is causing my Time Machine failures.

MacBook Pro (mid-2012) with Catalina 10.15.5 Beta.

What about the ominous setting to sleep hard drives? Any connection there perhaps?

Sys Prefs > Energy Saver > Battery/Power Adapter > Put hard disks to sleep when possible

I’m seeing periodic (not often) disconnects with error msg when using mojave’s latest version

Interesting. My 13" MBP is on Mojave and when at a desk always attached to at least one external HDD over USB3, especially over night. Never seen such a disconnect so far.

I’d be surprised, since my friend is highly technical, but I’ll ask.

I’ve probably seen a handful of inexplicable disconnects over the past few years, but never enough to attribute to anything other than randomness.

Is it typical to leave things ‘on’ overnight? I always shut down last thing of an evening.

In terms of randomness, it may or may not be related but the Mail app automatically closes any open messages at the stroke of midnight… but that was happening before I made the switch to Catalina.

Absolutely. My iMac is running 24x7, and is either in use, doing something like a backup in the background, or sleeping at all times.

I did some calculations a while back and it seemed that it wasn’t even a major power savings to shut the computer down rather than let it sleep, since it uses so much more power starting up.

I have never noticed such behavior, and I’m often at the keyboard at midnight. I do leave most of my Macs running overnight for remote backups and such.

Oh, don’t get me wrong. I wasn’t trying to say it was caused by that. I was just wondering if perhaps this is a bug that only manifests when this preference is set one way or another. I don’t think I ever recall seeing such a disconnect (apart from power outages), but then again, I have set the sleep disk pref on.

I had an issue a few years ago with virtualization software on my Mac that was occasionally in conflict with the system over mounted external volumes. Constant disconnects until I updated the VM software. If VirtualBox or VMWare is present or used to be, and there’s an outdated kext still lurking on the system, I’d double-check that since a hardware issue seems unlikely. The update to Catalina might have exposed some outdated software.

List 3rd party kexts with this terminal command:

kextstat | grep -v

Catalina 10.15.4 alerts that the drive was not properly ejected when the iMac was awakened from sleep, could cause damage etc. This has been going on since 10.15.2. Reformatting of drive and Reinstalls of System and Software from scratch, no Time Machine restore has not solved the problem. Only solution is to never sleep the drives period. Apple support has been contacted many times with no solution. Problem also noted by several Drive Maintenance developers.

My friend reports that he’s looked into this (with pmset too) and it’s not related.

How are you achieving that? My friend said that the Keep Drive Spinning utility did not solve the problem for him.

System Prefs… Prevent computer from sleeping when display is off. 2) Turn off PUT HARD DISKS TO SLEEP WHEN POSSIBLE. Disable ENABLE POWER NAP. This is not a flawless solution but is better by far than using the Default Settings!

Just a reminder: there are TWO settings regarding putting hard drives to sleep in the same System Prefs panel on laptops (for battery vs. a/c power). I’m one of those guys who typically leaves the charger cable plugged in on the time, but after reading this thread and the referenced topic in Apple Communities, I went into my own Sys Prefs and discovered that “Put Hard Drives to Sleep When Possible” was toggled “on” for battery power. I changed it.

This also brings up the “power nap” issue. I’ve not used it but I wonder how reliable it is.

I’m curious, does this affect only iMacs? Has anybody been seeing this bug on a MBP for example?


Is the definitive writer on everything “Time Machine”
100’s of in depth articles.

Here is just one.

And a search on his website:

I experience this on a MacBook running Mojave.

When I have a dismountable volume attached and I expect not to interact with the MacBook for a time, I try to remember to put the pointer in the No Sleep corner. Of course, this is a screen and CPU setting and not a hard disk setting, but it solves my problem (when I remember to do it).

I just checked and “Put hard disks to sleep when possible” is checked for both Battery and Power Adapter.

Hands up here from me. I’ve had several Time Machine back-ups fail given the disconnection of the drive. Which needless to say was not disconnected. Nor was it full. It has worked the past week or so, I hadn’t thought it was Catalina related (though I have other issues there) and was looking askance at the WD drive the iMac backs up to.


I wrote this on 4/2 and for whatever reason I didn’t see it in Tidbits-Talk.
Here’s some filler info for the message below - My 4TB G-Drive attaches a Display Port to Thunderbolt 2 at 10 GB/s. My 2 TB Iomega connects via a type-A USB connector to USB 3.0.
My first thought that I was getting an electrical spike or dropout. I tested the outlet and the wrong lights appeared. Maybe a wire heater heated up and was shorting. (I rewired all the outlets and switches a couple of years ago but stuff happens.) Attaching an extension cord to another outlet returned TM to normal.
I finally got around to disassembling the outlet but all wires were intact.
The outlet behind the wall, which I believed shares the same wire, was tested and deemed intact. Perhaps it was the timer for the two connected lamps. The original outlet has been put in play. It has been a few days now with no TM dropouts.
Perhaps Apple has slipped a fix overnight to correct the issue.

Original from Apr. 2, 2020

I have 2 TimeMachine disks connected (not mirrored but in parallel) tin which both claim to be ejected improperly.
I run them 24 Hrs per day.

Now, I know better than that to pull the plug. I always take a drive offline with the eject button in Finder. (You cannot hot-swap a hard drive. Waiting for buffer images and disk writes may be in flight. (The eject button simply “tells” the drive you want to eject but it continues until all pending writes are completed.)
These eject messages were appearing after a morning wake uping up from sleep mode (via the power button).
Now it’s happening during the day, maybe after I’m been away for a while (screen had gone to black).

The Finder shows the drives are mounted (eject button shows). Disk Utility showed nothing (i.e., not mounted).

Any ideas?
regards Mike