Catalina problems with Messages and Notes

Messages

Since I upgraded to Catalina, certain messages that I get on my iPhone don’t show up on my iMac. Specifically text messages from financial institutions, local governments, shipping companies, Amazon etc. come through fine on my phone, but don’t show up in Messages on my iMac. All text messages from my family et al. appear on both my phone AND on my iMac running Catalina. I have I have tried all the standard fixes on the Internet: checking and rechecking the iCloud accounts and the Apple IDs, restarting, turn things on and off. All my contact info with those whose text messages show up on my phone but not on my iMac are correct (obviously as they successfully appear my phone).

(Messages problem solved. Thanks to Mark Williamson—see below.)

Notes

My daughter tried to share a note. My wife, who has not upgraded to Catalina, was able to open the note. I have upgraded to Catalina, and the note won’t open for me. I continually get an alert that says “Sorry, this note cannot be opened right now. Please try again later.” I have tried all the standard fixes on the Internet: checking and rechecking the iCloud account and the Apple ID, restarting, turn things on and off. But nothing works.

1 Like

Interesting problems—are others seeing these? They feel potentially related to iCloud, which adds a black-box factor.

Have you played with the Settings->Messages (not Settings-[Apple ID]->iCloud->Messages) setting on your phone? When I was having similar problems getting messages to show up on my computer, I was finally able to solve it by going to Settings->Messages and toggling iMessage setting off. For good measure, I shut the phone down and restarted it. I then went back to Settings->Messages and turned the iMessage setting back on. All was well.

Note: I did this only after many hours of frustration playing with iCloud settings on the phone and computer and settings in the Messages app on the computer.

I did as you did with settings in messages as well as iCloud settings. Tried several times. I’ll have another try but am not hopeful.

Did you verify that your phone was still enabled to forward text messages to your Mac? Sounds like iMessages are coming through but SMS messages are not.

Bingo. Thank you. It was not a Catalina problem. At the same time I switched to Catalina I switched to a new iMac as well. Of course iMessages did not know I had a new device. So while Text Message Forwarding was enabled for my old device, it was not for the new iMac. Now it is, and iMessages and SMS messages are coming through. Very stupid of me. I’m still trying to figure out my problem with sharing Notes, and I hope I not being equally dumb regarding that.

I’m confused. I just checked my iPhone Settings->Messages, and Text Message Forwarding is enabled for 1 Device. I click on Text Message Forwarding and learn that the one device is my iPad. I see no way to add my Macintosh. But, I do get text messages (SMS and iMessage) on the Macintosh. What goes on?

Beats me. When I went to iPhone Settings->Messages, my new iMac appeared (as did my old one) under Text Message Forwarding. I enabled the new iMac and then both SMS messages and iMessages appeared on both phone and iMac. I was on the same WiFi network and logged in with the same Apple ID. I can’t explain why my iMac showed up though.