Can't reset PRAM

(Robert Tallitsch) #1

My Mac Pro is having difficulty opening programs; lots of spinning rainbow wheels. I have repeatedly tried to reset my PRAM (holding command, option, P R) but no second startup sound, even when using Safe Mode. Suggestions?

Mac Pro (late 2013)

Mac OS 10.14.3

16 GB 1866 MHz DDR3

3.7 GHz Quad-core Intel Xeon E5

(Adam Engst) #2

Might be worth resetting the System Management Controller first, which is just a matter of shutting down and unplugging it from the wall for 15 seconds.

(Robert Tallitsch) #3

Tried that first - no joy

(Adam Engst) #4

Do you have a firmware password set? It could be the battery on the motherboard too.

(Robert Tallitsch) #5

Not sure what you mean there. I do have a password set for when I boot my computer, but in times past the computer never asked for my password until the PRAM was reset. Now, when I restart holding down command-option-P-R I only get one startup chime and then the apple logo and the progress bar. No second chime.

(Adam Engst) #6

It’s unlikely you’ve set a firmware password, but it will apparently prevent PRAM resets.

Might be working your way up to calling Apple and see what they say.

#7

This might not be related, but I did have a problem with my ancient MacBook Pro a few days ago. It was acting weirdly, so I tried zapping the PRAM, and it just kept resetting and chiming. Nothing I did could stop it, after a while the battery died, and I thought it my poor MacBook Pro was really forever dead. The next day I took it into another room for my husband to try to fix it, and after just a few minutes of charging while not connected to any peripherals it was OK. I plugged it back into my large screen and mouse and it was fine, but when I plugged it in to the ancient Seagate drive I use as a secondary backup, it went haywire again. It might be worthwhile to check if any peripherals are causing problems.

(Allen Gainsford) #8

Is it possible that it’s an issue with your keyboard, somehow?

(Robert Tallitsch) #9

NO - keyboard is working just fine

(Robert Tallitsch) #10

Did that - all are working fine

(Al Varnell) #11

Randy Singer has a page dedicated to such things Macintosh OS X Beachballs!

(frederico) #12

It sure sounds like your keyboard just isn’t sending the keys, but you seem certain it is. I’d still try another, preferably wired, keyboard; as you know, you have to be certain you get all the keys down together instantly as the first chime rings; much later and you miss that critical window. And, FWIW, I’ve had numerous Macs that required you hold the combo through a total of three chimes (this was especially true on many of the G3 Power Mac series) to truly clear all the settings (you could hear the volume of the chime increase noticeably on the third chime).

It’s not as complete, but you can also use sudo nvram -c to clear all the custom parameters (use sudo nvram -p to list them before you clear if you want). See this page for more nvram fun:

https://ss64.com/osx/nvram.html

The only other machines I’ve run into having difficulties resettings either SMC or PRAM usually required replacing the SMC controller itself, which for most people, means a new motherboard; but, even though the battery shouldn’t interfere with a PRAM reset, you can always remove the battery altogether and see what happens. Make sure it has a full 3.25v or higher or replace it with a new CR2022.

Another thing you can do to force SMC and PRAM to take another look at itself is to swap out PCIe cards, or RAM amounts. The change in these configurations forces a controller parameter review in firmware; especially if you have a card lying around that has not been installed since the last SMC or PRAM reset.

I’m still leaning on the keyboard, though; sorry if that irritates you; it’s not meant to.

(Al Varnell) #13

Note that nvram commands are blocked by SIP, but can be done from Recovery.

(senortim) #14

Just supporting what MMTalker reported. Long long ago I had what looked like a PRAM issue but turned out to be a corrupted disk driver.

(Apta) #15
2 Likes